Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Another Selfcheck Request Failed

  1. #11
    Join Date
    Mar 2010
    Posts
    27

    Default

    This amanda install is an Ubuntu package...

    Is there an alternate way? An env var to set somewhere or an extra config flag or config item somewhere in Amanda?

  2. #12
    Join Date
    Mar 2010
    Posts
    27

    Default

    Answering myself, for the benefit of others who may find this thread.

    Although there's some debate about why, the Ubuntu packages (Hardy through Karmic as of this writing) contain AMANDA binaries built on a dev system that didn't have SSH installed. So you cannot use SSH auth in amanda if you're using the Ubuntu packages.

    ref bug 229929 in LaunchPad:
    [url]https://bugs.launchpad.net/ubuntu/+source/amanda/+bug/229929[/url]
    ...note that this bug was initially, incorrectly diagnosed as a problem with 'amcheck-clients', so the bug is oddly named.

  3. #13
    Join Date
    Feb 2008
    Posts
    34

    Default Another Selfcheck Request Failed

    Quote Originally Posted by martineau View Post
    amanda is compiled without the ssh path, you must recompile amanda
    Or, since zmanda compiles using --with-ssh, you could use a package from [URL="http://www.zmanda.com/download-amanda.php"]http://www.zmanda.com/download-amanda.php[/URL]
    -Zmanda Software Release Engineer Extrordinaire

  4. #14

    Default

    Quote Originally Posted by dwlocks View Post
    Or, since zmanda compiles using --with-ssh, you could use a package from [URL="http://www.zmanda.com/download-amanda.php"]http://www.zmanda.com/download-amanda.php[/URL]
    Thanks for the link man

  5. #15

    Default amcheck-clients: could not find security driver 'bsdtcp' for host

    Hi all,

    I have redhat 5.5 with default amanda client ( amanda-client-2.5.0p2). I found this error when amcheck DailySet1.

    -bash-3.2$ /usr/sbin/amcheck DailySet1
    Amanda Tape Server Host Check
    -----------------------------
    Holding disk /dumps/amanda: 1663044 KB disk space available, using 1560644 KB
    slot 1: read label `DailySet1-01', date `X'

    NOTE: skipping tape-writable test
    Tape DailySet1-01 label ok
    NOTE: info dir /etc/amanda/DailySet1/curinfo: does not exist
    NOTE: it will be created on the next run.
    Server check took 0.335 seconds
    amcheck-clients: could not find security driver 'bsdtcp' for host 'synergy.amanda.com'

    Amanda Backup Client Hosts Check
    --------------------------------

    (brought to you by Amanda 2.5.0p2)


    Regards
    Larry

  6. #16
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Please, don't use thread started by someone else.

    The bsdtcp auth is not available in amanda-2.5.0p2, you must use the bsd auth.

  7. #17

    Default

    Quote Originally Posted by skjellyfetti View Post
    Hello,

    I'm fairly new to Amanda and I'd appreciate some help from the forum members if you please.

    I inherited a NAT'ed Linux server running Amanda 2.5.2p1 connecting to a public IP'ed Linux client which has been running very reliably for almost a year. I have made no changes other than to clean up some ever-expanding logfiles & archives on the client. A couple days ago backups started failing and now amcheck is failing...
    [URL=" http://tandaiduong.com.vn/duhoc-News,at,categories,catid,15.html "]du hoc[/URL]|[URL="http://tandaiduong.com.vn/duhoc-News,at,categories,catid,15.html"]du hoc singapore[/URL]|[URL="http://tandaiduong.com.vn/duhoc-News,at,categories,catid,5.html"]tu van du hoc[/URL]| and [URL="http://www.noithat-fami.net"]noi that fami[/URL] or [URL="http://www.noithat190.net.vn"]noi that 190[/URL]
    amcheck DailySet1
    Amanda Tape Server Host Check
    -----------------------------
    Holding disk /dumps/amanda: 27977276 KB disk space available, using 27874876 KB
    slot 2: read label `DailySet1-02', date `20091005'
    NOTE: skipping tape-writable test
    Tape DailySet1-02 label ok
    Server check took 0.065 seconds
    amcheck-clients: error: couldn't exec : No such file or directory
    close debug file: Bad file descriptor
    Amanda Backup Client Hosts Check
    --------------------------------
    WARNING: host.foo.bar: selfcheck request failed: error sending REQ: write error to : Broken pipe
    Client check: 1 host checked in 0.150 seconds, 1 problem found



    server debug log shows:
    amcheck: debug 1 pid 7152 ruid 34 euid 0: start at Wed Oct 14 15:55:21 2009
    amcheck: debug 1 pid 7152 ruid 34 euid 34: rename at Wed Oct 14 15:55:21 2009
    amcheck-clients: time 0.004: security_getdriver(name=ssh) returns 0x7f9664f2d600
    amcheck-clients: time 0.004: security_handleinit(handle=0x61eb20, driver=0x7f9664f2d600 (SSH))
    amcheck-clients: time 0.022: security_streaminit(stream=0x621540, driver=0x7f9664f2d600 (SSH))
    amcheck-clients: time 0.023: security_stream_seterr(0x621540, write error to : Broken pipe)
    amcheck-clients: time 0.023: security_seterror(handle=0x61eb20, driver=0x7f9664f2d600 (SSH) error=write error to : Broken pipe)
    amcheck-clients: time 0.023: security_seterror(handle=0x61eb20, driver=0x7f9664f2d600 (SSH) error=error sending REQ: write error to : Broken pipe)
    amcheck-clients: time 0.023: security_close(handle=0x61eb20, driver=0x7f9664f2d600 (SSH))
    amcheck-clients: time 0.023: security_stream_close(0x621540)
    amcheck-clients: time 0.023: security_stream_seterr(0x621540, write error to : Broken pipe)
    changer_query: changer return was 12 1
    changer_query: searchable = 0
    changer_find: looking for DailySet1-02 changer is searchable = 0
    amcheck: time 0.068: pid 7152 finish time Wed Oct 14 15:55:21 2009


    I am able to ssh from the server to the client without being prompted for a password, so ssh is working.

    My /etc/xinetd.d/amandaserver:
    # default: on
    # description: The amanda service
    service amanda
    {
    socket_type = stream
    protocol = tcp
    wait = yes
    user = backup
    group = backup
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsd amdump amindexd amidxtaped
    disable = no
    }


    Additonal note: on the server, under xinetd.d, I have amandaidx and amidxtape files as well. Are these necessary?

    And here is my client /etc/xinetd.d/amanda
    # default: on
    # description: The amanda service
    service amanda
    {
    socket_type = stream
    protocol = tcp
    wait = yes
    user = backup
    group = backup
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsd amdump
    disable = no
    }


    Correct me if I'm wrong, but having a NAT'ed setup, shouldn't auth=ssh? If so, then shouldn't auth=bsd fail? However, in my amanda.conf file, auth is set to ssh so I'm guessing that this may override any xinetd settings, no?

    I have changed both xinetd.d files to -auth=ssh, restarted xinetd and no love.

    Any ideas/thoughts?

    Thanks
    Randy
    In my amanda.conf i forgot auth=bsd line.
    But i had another problem.
    If I amcheck DailySet1 there is no problem, but amdump i had failure on backup.

    FAIL planner client1 /home 20100102004501 0 "[missing result for /home in client1 response]"

    Backup Server: RHEL4 i386, amanda-2.6.1
    Client1: RHEL4 x86_64, amanda-2.4.4
    Client1 is behind the firewall then i added net.inet.udp.maxdgram line in sysctl.cnf.

    error: "net.inet.udp.maxdgram" is an unknown key
    I also increased etimeout =4200
    What should i do?
    Please help guys..
    Last edited by mrphantuan; May 16th, 2011 at 01:11 AM.

  8. #18
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    xinetd is not used with ssh, you can remove the files.

    amcheck-clients: error: couldn't exec : No such file or directory
    No path for ssh ...
    You must recompile amanda with the ssh path.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •