Results 1 to 5 of 5

Thread: Server validation Failed error

  1. #1
    Join Date
    Mar 2009
    Posts
    25

    Default Server validation Failed error

    Hi, I am having problem setting up ZWC Community Edition

    The client is Window Vista, 32bit, running ZWC community edition 2.6.4p1
    The server is CentOS 5.0, running Zmanda Community version, 2.6.1. It works great with 14 Linux clients.

    *When I ran amcheck -c DailySet1, got error: Server validation Failed. Please register server with client.

    *The Windows log fie showed that it tried to do the backup by listing all the filenames in the directory
    But the ZWC Failure error code: 2

    *I have checked the registry keys
    HKEY_LOCAL_MACHINE\SOFTWARE\Zmanda\ZWC\1.0\Install \Servers.
    and they looked ok on the backup user name and the server FQDN
    I can ping between the server and the client

    *I turned off firewall, still the same error

    *I checked the ports, they looked ok:
    C:\Windows\system32>netstat -anb
    TCP 0.0.0.0:10080 0.0.0.0:0 LISTENING
    [ZWCService.exe]
    TCP 0.0.0.0:10081 0.0.0.0:0 LISTENING
    [ZWCService.exe]
    TCP 0.0.0.0:49152 0.0.0.0:0 LISTENING

    *There was no template defined in ZWCConfig.exe
    I don't know what the template is. I copied the amanda-client.conf file from the serer to the Windows client, and added it as a template. It didn't help.

    *The debug file of amcheck in the server showed that the server was able to connect to port 703 and 10080, was able to run Service noop, wrote 83 byes to the client, etc.

    Thank you in advance.

  2. #2
    Join Date
    Oct 2005
    Posts
    1,559

    Default

    1.There is no need to add a template in ZWCconfig.exe
    2. In ZWCconfig.exe, under servers tab, do you see your server FQDN?
    Server IP address is preferred in case there are name resolution issues.
    3. Please check ZWCservice is running on the client.

    Paddy

  3. #3
    Join Date
    Mar 2009
    Posts
    25

    Default

    Hi Paddy

    Thank you for helping me!

    2.In ZWCcofnig.exe, under servers tab, I have to click on the server list to see the my server's FQDN. I actually tried either FQDN or IP address, I still got the same error. Every time I changed the server, I did restart ZWCservice by double click on ZWCservice.exe
    3. Yes, ZWCservice is running, according to the Task Manager

    Godwin

  4. #4

    Default

    I missed this duplicate thread... I am having the same issue except with Windows Server 2008. I have verified everything as stated by the OP. Any solutions?

    Related thread: [url]http://forums.zmanda.com/showthread.php?t=2122[/url]
    Last edited by mboudro; August 15th, 2009 at 10:56 AM.

  5. #5
    Join Date
    Sep 2008
    Posts
    112

    Default

    Hi,

    Since, you have already registered the Amanda Server in the ZWC Client, we would need log files to debug the issue.

    1. Set the log level to 5 by setting following registry key
    HKEY_LOCAL_MACHINE\SOFTWARE\ZMANDA\ZWC\1.0\Debug\L ogLevel
    2. Restart ZWCService.

    Run Verify Client.

    Login to the Windows client machine using Administrator user. Go to "Start Menu > Programs > Zmanda Community Edition" and click on "ZWC Support". This will collect the client logs.

    On the Amanda server, run /opt/zmanda/amanda/bin/zm-support --config <configname>

    Please send us both the client and server log files.

    Regards,
    Prashant

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •