Results 1 to 10 of 10

Thread: Problem: 2.5.1p1 - "timeout waiting for ACK"

  1. #1
    Join Date
    Oct 2006
    Posts
    27

    Default Problem: 2.5.1p1 - "timeout waiting for ACK"

    Hi specialists,

    I did what is not to be done: I upgraded a software without having tested it previously. Now, here's my story: having run 2.4.0p? without any problems, I downloaded and installed the tarball of 2.5.1p1.

    That gave me a bit of a headache, for the paths were not the same, I had to adjust everything from /usr to /usr/local and /var to /var/local. When I realized that this has to be done fpr the xinet-entries as well (aahh!) everything seemed to work out fine, BUT: the first dump produced no estimation results and the message: "WARNING: server.domain: selfcheck request failed: timeout waiting for ACK". Since then I've not been not able to backup that local server, always with that error message.

    inserted: as not otherwise expected, amcheck shows the same behavior.

    I found some postings that especially this topic is resolved with patch 1, so I wonder: am I doing s.t. wrong?

    Thanx in advance for any hint,

    bests
    Matthew
    Last edited by phaidros; October 10th, 2006 at 08:30 AM.

  2. #2
    Join Date
    Apr 2006
    Posts
    116

    Default xinetd

    Hello,

    Can you please post the contents of all the amanda related files in the /etc/xinetd.d directory.

    Thanks

  3. #3
    Join Date
    Oct 2006
    Posts
    27

    Default

    ppragin,

    amanda has been compiled with the --with-user=backup --with-group=disk options.

    I tried different versions of the xinetd-file (not having understood the exact differences between bsd, bsdudp & bsdtcp and what that is all about). I have one file /etc/xinetd.d/amanda, it looks like this:
    ================================================== =======
    service amanda
    {
    only_from = server concordialx01.co.at mail.concordia.co.at
    socket_type = stream # dgram
    protocol = tcp # udp
    wait = no # yes
    user = backup
    group = disk
    groups = yes
    server = /usr/local/libexec/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    disable = no
    }

    service amandaidx
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = backup
    group = disk
    groups = yes
    server = /usr/local/libexec/amindexd
    }

    service amidxtape
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = backup
    group = disk
    groups = yes
    server = /usr/local/libexec/amidxtaped
    }

    ================================================== ===
    the "dgam, udp & yes" entries behind the #-symbol were the other version of this file, together with "-auth=bsd" and "-auth=bsdudp". no change in behavior whatsoever, even the amcheck-debug-files look almost identical (to the "unaided eye"):
    ================================================== ===
    amcheck: debug 1 pid 7439 ruid 34 euid 0: start at Tue Oct 10 18:59:01 2006
    amcheck: debug 1 pid 7439 ruid 34 euid 34: rename at Tue Oct 10 18:59:01 2006
    security_getdriver(name=BSD) returns 0x4007a0e0
    security_handleinit(handle=0x8060cb8, driver=0x4007a0e0 (BSD))
    amcheck-clients: time 0.001: bind_portrange2: Try port 614: Available - Success
    amcheck-clients: time 0.001: dgram_bind: socket bound to 0.0.0.0.614
    amcheck-clients: dgram_send_addr(addr=0xbfff77d0, dgram=0x4007b024)
    amcheck-clients: time 0.002: (sockaddr_in *)0xbfff77d0 = { 2, 10080, 192.168.1.80 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    security_getdriver(name=BSD) returns 0x4007a0e0
    security_handleinit(handle=0x8061930, driver=0x4007a0e0 (BSD))
    amcheck-clients: dgram_send_addr(addr=0xbfff77d0, dgram=0x4007b024)
    amcheck-clients: time 0.002: (sockaddr_in *)0xbfff77d0 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    amcheck-clients: time 0.011: dgram_recv(dgram=0x4007b024, timeout=0, fromaddr=0x4008b010)
    amcheck-clients: time 0.011: (sockaddr_in *)0x4008b010 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: time 0.012: dgram_recv(dgram=0x4007b024, timeout=0, fromaddr=0x4008b010)
    amcheck-clients: time 0.012: (sockaddr_in *)0x4008b010 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr(addr=0xbfff7650, dgram=0x4007b024)
    amcheck-clients: time 0.012: (sockaddr_in *)0xbfff7650 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    security_getdriver(name=BSD) returns 0x4007a0e0
    security_handleinit(handle=0x8062b90, driver=0x4007a0e0 (BSD))
    amcheck-clients: dgram_send_addr(addr=0xbfff73c0, dgram=0x4007b024)
    amcheck-clients: time 0.013: (sockaddr_in *)0xbfff73c0 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    security_close(handle=0x8061930, driver=0x4007a0e0 (BSD))
    amcheck-clients: time 0.021: dgram_recv(dgram=0x4007b024, timeout=0, fromaddr=0x4008b010)
    amcheck-clients: time 0.021: (sockaddr_in *)0x4008b010 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: time 0.032: dgram_recv(dgram=0x4007b024, timeout=0, fromaddr=0x4008b010)
    amcheck-clients: time 0.032: (sockaddr_in *)0x4008b010 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr(addr=0xbfff7650, dgram=0x4007b024)
    amcheck-clients: time 0.032: (sockaddr_in *)0xbfff7650 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    security_close(handle=0x8062b90, driver=0x4007a0e0 (BSD))
    amcheck-clients: dgram_send_addr(addr=0xbfff76e0, dgram=0x4007b024)
    amcheck-clients: time 10.030: (sockaddr_in *)0xbfff76e0 = { 2, 10080, 192.168.1.80 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    amcheck-clients: dgram_send_addr(addr=0xbfff76e0, dgram=0x4007b024)
    amcheck-clients: time 20.028: (sockaddr_in *)0xbfff76e0 = { 2, 10080, 192.168.1.80 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    security_seterror(handle=0x8060cb8, driver=0x4007a0e0 (BSD) error=timeout waiting for ACK)
    security_close(handle=0x8060cb8, driver=0x4007a0e0 (BSD))
    amcheck: pid 7439 finish time Tue Oct 10 18:59:31 2006

    ================================================== ===

    What else can I provide to help you to help me ?

    Thanks a lot for your time!

    Bests
    Matthew

  4. #4
    Join Date
    Apr 2006
    Posts
    116

    Default xinetd

    Hello,

    1.You will need to remove all amanda related files and services from /etc/xinetd.d
    2. Create new file /etc/xinetd.d/amandaserver:

    # default: on
    #
    # description: Amanda services for Amanda server and client.
    #
    service amanda
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = backup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }


    3. Make sure to modify the above "server" option with correct path for "amandad" on your system and it seems like it should be "/usr/local/libexec/amandad". But make sure this is the new binary for 2.5.1 and not the old one from your previous installation.

    4. restart xinetd
    5. check /var/log/messages for any errors
    6. run amcheck again

  5. #5
    Join Date
    Oct 2006
    Posts
    27

    Default

    Quote Originally Posted by ppragin
    Hello,

    1.You will need to remove all amanda related files and services from /etc/xinetd.d
    2. Create new file /etc/xinetd.d/amandaserver:
    # default: on
    #
    # description: Amanda services for Amanda server and client.
    #
    service amanda
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = backup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }
    :
    <snip>
    Thank you. In order to clarify things: I've got one single file describing all three services amandad, amindexd and amidxtaped. What about those?

    And by the way: I *did* try the TCP-option just as you described it above, result was the same. What are you aiming at?

    Cheers
    mat

  6. #6
    Join Date
    Apr 2006
    Posts
    116

    Default more info

    1. You need to remove all the services from your old /etc/xinetd.d/amanda file and replace them with only one service below:

    service amanda
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = backup
    group = disk
    groups = yes
    server = /usr/local/libexec/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }

    2. restart xinetd

    In the 2.5.1 version you don't need to specify amanda, amandaidx, amidxtaped services separately.

  7. #7
    Join Date
    Oct 2006
    Posts
    27

    Default problem remains

    Quote Originally Posted by ppragin
    1. You need to remove all the services from your old /etc/xinetd.d/amanda file and replace them with only one service below:

    service amanda
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = backup
    group = disk
    groups = yes
    server = /usr/local/libexec/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }

    2. restart xinetd

    In the 2.5.1 version you don't need to specify amanda, amandaidx, amidxtaped services separately.
    ppragin,

    I've done as you told me - result remains the same. /var/log/messages is empty, apart from the "--MARK--"-messages.

    Anything else I might try?

    Thx & bests
    Matthew
    Last edited by phaidros; October 12th, 2006 at 06:11 AM.

  8. #8
    Join Date
    Oct 2006
    Posts
    27

    Default Problem remains: "timeout waiting for ACK"

    * when I run /usr/local/libexec/amandad the systembehaves exactly as predicted: do nothing for 30secs, then terminate, BUT: when I press a key, nothing happens (system goes on waiting)

    * Does the file /etc/services have to reflect the same service names as /etc/xinetd.d/amandaserver contains in the server_args line?

    /etc/xinetd.d/amandaserver: amdump amindexd amidxtaped
    /etc/services: amanda 10080/tcp amandaidx 10082/tcp & amidxtape 10083/tcp
    (May I throw the udp-entry away?)

    * Is it of any concern that a logfile is created in /tmp/server whereas the name of the machine is another one, and "server" is only its "nick"? I added "server" and "server.domain.top"-entries to .amandahosts to be on the safe side, but to no effect: always "timeout waiting for ACK", when I try amcheck.

    * What does the "security_seterror" at the end of the debugfile mean? This semms to have to do s.t. with the matter doesn't it?

    Thanks for further suggestions, I really do need a solution *very* soon: I didn't run backups for week now!

    Bests
    Matthew

    Contents of debugfile after amcheck:
    amcheck: debug 1 pid 18200 ruid 34 euid 0: start at Thu Oct 12 18:16:17 2006
    amcheck: debug 1 pid 18200 ruid 34 euid 34: rename at Thu Oct 12 18:16:17 2006
    security_getdriver(name=BSD) returns 0x4007a0e0
    security_handleinit(handle=0x8060cb8, driver=0x4007a0e0 (BSD))
    amcheck-clients: time 0.001: bind_portrange2: Try port 875: Available - Success
    amcheck-clients: time 0.001: dgram_bind: socket bound to 0.0.0.0.875
    amcheck-clients: dgram_send_addr(addr=0xbfff74a0, dgram=0x4007b024)
    amcheck-clients: time 0.002: (sockaddr_in *)0xbfff74a0 = { 2, 10080, 192.168.1.80 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    security_getdriver(name=BSD) returns 0x4007a0e0
    security_handleinit(handle=0x8061930, driver=0x4007a0e0 (BSD))
    amcheck-clients: dgram_send_addr(addr=0xbfff74a0, dgram=0x4007b024)
    amcheck-clients: time 0.002: (sockaddr_in *)0xbfff74a0 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    amcheck-clients: time 0.011: dgram_recv(dgram=0x4007b024, timeout=0, fromaddr=0x4008b010)
    amcheck-clients: time 0.011: (sockaddr_in *)0x4008b010 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: time 0.014: dgram_recv(dgram=0x4007b024, timeout=0, fromaddr=0x4008b010)
    amcheck-clients: time 0.014: (sockaddr_in *)0x4008b010 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr(addr=0xbfff7320, dgram=0x4007b024)
    amcheck-clients: time 0.014: (sockaddr_in *)0xbfff7320 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    security_getdriver(name=BSD) returns 0x4007a0e0
    security_handleinit(handle=0x8062b90, driver=0x4007a0e0 (BSD))
    amcheck-clients: dgram_send_addr(addr=0xbfff7090, dgram=0x4007b024)
    amcheck-clients: time 0.015: (sockaddr_in *)0xbfff7090 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    security_close(handle=0x8061930, driver=0x4007a0e0 (BSD))
    amcheck-clients: time 0.105: dgram_recv(dgram=0x4007b024, timeout=0, fromaddr=0x4008b010)
    amcheck-clients: time 0.105: (sockaddr_in *)0x4008b010 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: time 0.128: dgram_recv(dgram=0x4007b024, timeout=0, fromaddr=0x4008b010)
    amcheck-clients: time 0.128: (sockaddr_in *)0x4008b010 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr(addr=0xbfff7320, dgram=0x4007b024)
    amcheck-clients: time 0.128: (sockaddr_in *)0xbfff7320 = { 2, 10080, 192.168.1.78 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    security_close(handle=0x8062b90, driver=0x4007a0e0 (BSD))
    amcheck-clients: dgram_send_addr(addr=0xbfff73b0, dgram=0x4007b024)
    amcheck-clients: time 10.126: (sockaddr_in *)0xbfff73b0 = { 2, 10080, 192.168.1.80 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    amcheck-clients: dgram_send_addr(addr=0xbfff73b0, dgram=0x4007b024)
    amcheck-clients: time 20.125: (sockaddr_in *)0xbfff73b0 = { 2, 10080, 192.168.1.80 }
    amcheck-clients: dgram_send_addr: 0x4007b024->socket = 4
    security_seterror(handle=0x8060cb8, driver=0x4007a0e0 (BSD) error=timeout waiting for ACK)
    security_close(handle=0x8060cb8, driver=0x4007a0e0 (BSD))
    amcheck: pid 18200 finish time Thu Oct 12 18:16:47 2006
    Last edited by phaidros; October 12th, 2006 at 08:42 AM.

  9. #9
    Join Date
    Apr 2006
    Posts
    116

    Default bsdtcp

    Hello,

    1. Do you get any errors in the /var/log/messages about amanda service not starting?

    2. Please make sure you specify this in your dumptype in amanda.conf:
    auth "bsdtcp"

    3. After you do this try running amcheck again

    Pavel

  10. #10
    Join Date
    Oct 2006
    Posts
    27

    Default

    Quote Originally Posted by ppragin
    Hello,
    :
    2. Please make sure you specify this in your dumptype in amanda.conf:
    auth "bsdtcp"
    :
    Tadaa! Thanks a lot. Your point 2 did the job! Drop me a note, when you are in Vienna, I owe you a beer!

    Cheers

    Matthew

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •