Results 1 to 4 of 4

Thread: amrecover ssh host key verification failed

  1. #1

    Unhappy amrecover ssh host key verification failed

    Hi All!

    server: SLES10sp2 x64, amanda 2.6.1p1
    client: Debian_etch amanda 2.6.1

    After checking and rechecking my configs i still get a strange error
    # amrecover
    Host key verification failed.
    AMRECOVER Version 2.6.1. Contacting server on <host>
    [request failed: EOF on read from <host>]

    ssh keys are set up back and forth so I can ssh as amandabackup user with no password entry; I even can ssh as root (which I think should not be necessary).

    what i've noticed while setting up a server/client for amdump is that amcheck on the server continued to give me an error:
    Amanda Backup Client Hosts Check
    WARNING: nfs02: selfcheck request failed: EOF on read from nfs02
    Client check: 1 host checked in 0.134 seconds.  1 problem found.
    until i locally on the nfs02 ran a usr/libexec/amanda/selfcheck program. it did not give out any output for some time so i killed it with ctrl-C, but then the problem was magically gone.

    is there any trick for setting up the ssh communication? i've done everything according to HowTos and rechecked every step but still there was a problem in communication. or should I use another authentication type? is there a "best" one? :-)

    sorry for a lot of dumb questions, but Im new to amanda. please help! it does not make much sense to have a backup if i cannot restore anything.

    thanks in advance!

    my client-config:
    conf "daily"             # your config name
    index_server "mfs1"   # your amindexd server
    tape_server  "mfs1"   # your amidxtaped server
    tapedev      ""         # your tape device
                            # if not set, Use configure or ask server.
                            # if set to empty string "", ask server
                            # amrecover will use the changer if set to the value
                            # of 'amrecover_changer' in the server amanda.conf.
    #   auth        - authentication scheme to use between server and client.
    #                 Valid values are "bsd", "bsdudp", "bsdtcp", "krb5", "local",
    #                 "rsh" and "ssh".
    #                 Default: [auth "bsdtcp"]
    auth "ssh"
    ssh_keys "/var/lib/amanda/.ssh/id_rsa"                   # your ssh keys file if you use ssh auth
    client_username "amandabackup"
    amandad_path "/usr/libexec/amanda/amandad"

  2. #2


    anyone? please!

    I'm slowly out of ideas... amdump from server works fine, but amrecover fails even locally on the server...

    checked amanda-client.conf in the /etc/amanda on both machines - files seem to be just fine. tried removing client_username and path to amandad - nothing changed.

    conf "daily"		
    index_server "mfs01"	
    tape_server  "mfs01"	
    tapedev      ""
    auth "ssh"
    ssh_keys "/var/lib/amanda/.ssh/id_rsa_amdump"
    Last edited by spad; May 9th, 2009 at 12:44 AM.

  3. #3
    Join Date
    Nov 2005


    Do amandad get executed? Please post the amandad.*.debug files
    What's in the amrecover.*.debug and amcheck.*.debug files?

  4. #4


    hi all!


    the trick was to start from the client

    ssh mfs01 -l amandabackup

    and accept the key.
    this is somehow never mentioned like that in the docs... or at least i missed it :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts