Results 1 to 4 of 4

Thread: Windows restore problems

  1. #1

    Default Windows restore problems

    Hi Folks,

    I’m working on Zmanda Management Console (installed on SLES 10 SP 3) and I’m doing some test with a Windows 2003 32 bit client.
    Here are informations about my systems
    Server packages name:
    amanda_enterprise-backup_server-2.6.4p2-1.sles10.i586.rpm
    amanda-enterprise-2.6.4-installer.bin
    Client package name:
    ZWCInstaller-Server-32bit.zip

    I’m able to perform a full backup (without any error) of my Windows server, but I receive a strange message during the restore procedure.
    If I try to restore one of the file, I have the message:
    Status of Restore: Failure
    Output:
    Use of uninitialized value in concatenation (.) or string at /opt/zmanda/amanda/bin/amfetchandresolve line 3352.
    DBD::mysql::st execute failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 at /opt/zmanda/amanda/bin/amfetchandresolve line 3602.
    Use of uninitialized value in concatenation (.) or string at /opt/zmanda/amanda/bin/amfetchandresolve line 3356.
    Use of uninitialized value in concatenation (.) or string at /opt/zmanda/amanda/bin/amfetchandresolve line 3356.
    DBD::mysql::st execute failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'and restore=true) and conf_dle_id=' at line 1 at /opt/zmanda/amanda/perl/lib/5.8.8/i686-linux-thread-multi/Logging.pm line 197.
    ERROR: Error selecting index files list from index_details
    ERROR: Files Not Selected for Restore
    Error restoring the selected files


    I tried to gunzip my index file, and in that list I can see all the file previously backupped (also the file that I’m tring to restore).

    Here is my disklist file (as you can see I’m backupping the entire “C:” drive):
    tstcs2.psc.pscnet.com "c:/" {
    auth "bsdtcp"
    index 1
    comment "Global definitions"
    compress none
    property "zmc_uuid" "49cb9e4ec2e68"
    property "zmc_type" "windows"
    property "zmc_amanda_configuration_name" "DailySetLIBRARY"
    property "last_modified_by" "admin"
    property "last_modified_time" "2009-03-26 08:25:29"
    property "zmc_amanda_configuration_id" "2"
    property "zmc_version" "1"
    program "DUMP"
    }




    Have you got any idea?
    I tried to post this issue on the “Amanda Enterprise” forum, but with my account I can’t (even if I’m a Zmanda customer)

    Thanks in advance,
    Federico Biavati
    Last edited by fbiavati; March 26th, 2009 at 02:43 PM.

  2. #2
    Join Date
    Nov 2005
    Posts
    52

    Default Windows restore problems

    Hi Fedrico
    I have enabled access for you to be able to post to Enterprise forums. It looks like you may be running into a bug. Did you install all the updates and patches for 2.6.4 from Zmanda Network? Also , you can use the support tab in Zmanda Network to log a technical support issue.

    Thanks
    tk

  3. #3

    Default

    Hi TK,
    Thank you for your support.
    To be honest I bought the Enterprise version only yesterday, and I spent the week before working on the free version.
    So my Amanda Enterprise server is up and running only from 24 hours and I didnít patch anything.

    Iíll try to apply every patch for my O.S. and Iíll let you know.

    Thanks,
    Federico Biavati

  4. #4

    Default

    Hi TK,

    after installing the following patches:
    patch-5603.tar.gz
    patch-5774.tar.gz
    patch-5894.tar.gz
    patch-6270.tar.gz

    my problem is solved.
    now I'm able to restore a file in my windows server.

    Thanks!!!
    Federico

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •