Results 1 to 3 of 3

Thread: concerning the configuration of ZMC

  1. #1
    Join Date
    Feb 2009
    Location
    France
    Posts
    3

    Default concerning the configuration of ZMC

    Hello Folks
    I ve a probleme with the verify fonction
    especially with the end to end fonction

    I got this faillure message
    Output:

    ERROR : Configuration errors found during amcheck, to resolve errors pl run verify installation/server/client from GUI

    Amanda Tape Server Host Check
    -----------------------------
    slot 1:read label `test-00', date `X'.
    NOTE: skipping tape-writable test
    Tape test-00 label ok
    NOTE: info dir /etc/amanda/zmc_test_quick/curinfo/localhost/_tmp_zmc_test_quick_data does not exist
    NOTE: it will be created on the next run.
    NOTE: index dir /etc/amanda/zmc_test_quick/index/localhost/_tmp_zmc_test_quick_data does not exist
    NOTE: it will be created on the next run.
    Server check took 0.780 seconds

    Amanda Backup Client Hosts Check
    --------------------------------
    WARNING: Usage of fully qualified hostname recommended for Client localhost.
    WARNING: localhost: selfcheck request failed: Connection refused
    Client check: 1 host checked in 10.017 seconds. 1 problem found.

    (brought to you by Amanda 2.6.4p2)
    my xinetd amanda server is
    # default: on
    #
    # description: Amanda services for Amanda server and client.
    #
    service amanda
    {
    only_from = toto.blahblah.com tata.blahblah.com tutu.blahblah.com localhost
    socket_type = dgram
    protocol = udp
    wait = yes
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    disable = no
    }

    still on my toto.blahblah.com server i have also my amandaclient

    service amanda
    {
    only_from = localhost
    socket_type = dgram
    protocol = udp
    wait = yes
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsd amdump
    disable = no
    }
    and in my .amandahosts on my too.blahblah server
    I have That
    localhost root amindexd amidxtaped
    localhost amandabackup amdump

    I've also tried with toto.blahblah.com instead of localhost
    but still the same output
    and the most funiest thing I found is
    when I perform a check by hand doing su -amandabackup
    amcheck BackupSet2
    the check works
    so I need some of you help

  2. #2
    Join Date
    Feb 2009
    Location
    France
    Posts
    3

    Default Post Scriptum

    I've read all the documentation that I could find about this,
    In fact Yesterday I had a amanda 2.6.0 running and no I've amanda 2.6.5 with a nice GUI but not working...

    Thanks in advance still looking forward to hear from you

  3. #3
    Join Date
    Oct 2005
    Posts
    1,559

    Default

    Quote Originally Posted by lebarbu34 View Post
    my xinetd amanda server is
    # default: on
    #
    # description: Amanda services for Amanda server and client.
    #
    service amanda
    {
    only_from = toto.blahblah.com tata.blahblah.com tutu.blahblah.com localhost
    socket_type = dgram
    protocol = udp
    protocol must be tcp and socket_type must be stream. Please see [url]http://wiki.zmanda.com/index.php/How_To:Configure_bsd%2C_bsdtcp%2C_or_bsdudp_authen tication#bsdtcp[/url]


    still on my toto.blahblah.com server i have also my amandaclient

    service amanda
    {
    only_from = localhost
    socket_type = dgram
    protocol = udp
    wait = yes
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsd amdump
    disable = no
    }
    On client, you cannot have only_from as "localhost". It should have Amanda server name.

    Please fix your xinetd entries.

    Paddy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •