Results 1 to 9 of 9

Thread: ftp error

  1. #1

    Question ftp error


    When I am trying to start an FTP backup, the log file shows this:
    2009-01-20 19:05:24 User shocked requested backup of (
    2009-01-20 19:05:24 Couldn't create new FTP object

    What would cause the "Couldn't create new FTP object" error?

    Thank you

  2. #2


    hello there,

    The error message you're seeing is a result of the bundled CPAN modules.

    The good news is that they're installed correctly.

    The bad news is that your ftp configuration is not set correctly, or the server is inaccessible. The FTP object establishes a connection at its creation time and throws that error if it cannot connect.

    Can you verify your ability to connect with the parameters entered via the web interface?
    Last edited by pcmantz; January 22nd, 2009 at 09:33 AM. Reason: clarification

  3. #3



    Thank you for the reply. I am still getting the same error. I have tried this from the backuppc machine:

    # ftp
    Connected to
    220 ProFTPD 1.3.1 Server ( [xx.xx.xx.20]
    Name ( ftp_username_here
    331 Password required for ftp_username_here
    230 User ftp_username_here logged in
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> quit
    221 Goodbye.

    I reset the ftp password on backuppc to make sure it is correct, and it is. the exact error is still:
    2009-01-22 10:43:46 User myname requested backup of (
    2009-01-22 10:43:46 Couldn't create new FTP object

    Is there anything else I can troubleshoot?

  4. #4


    Could you please post your backup client's .pl configuration script? I'd like to take a look at it.

  5. #5


    file paste:
    $Conf{FtpPasswd} = 'our_password';
    $Conf{FtpUserName} = 'our_username';
    $Conf{XferMethod} = 'ftp';
    $Conf{PingMaxMsec} = 200;
    $Conf{FtpShareName} = [

    just so you know.. the pw and username were 100% correct.

  6. #6


    Have any pings to the server succeeded? I want to make sure that this isn't a connection issue.

    Could you try setting $Conf{ClientNameAlias} to the appropriate hostname?

  7. #7



    Yes, the pings succeed because it said they were over 20ms, which is why I raised the limit to 200.

    As for adding "$Conf{ClientNameAlias}"

    I did add it to the .pl file I pasted above, and reloaded backuppc. It still gives the same error.

  8. #8


    Any thoughts?

  9. #9


    i get the same error, didn't found anything around google... any idea?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts