Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: amrecover not responding

  1. #1
    Join Date
    Nov 2008
    Posts
    26

    Default amrecover not responding

    Hi all
    i am trying to test my amrecover but anytime i try to run amrecover
    it doesnt do anything just a blank response till i quit itcan any one help
    my amanda-client conf is
    #amanda.conf - sample Amanda client configuration file.
    #
    # This file normally goes in /etc/amanda/amanda-client.conf.
    #
    conf "DailySet1, DailySet2" # your config name
    #conf "DailySet2" # your config name

    index_server "LON-TI-IT-03" # your amindexd server

    tape_server "LON-TI-IT-03" # your amidxtaped server

    #tapedev "/dev/null" # your tape device
    # auth - authentication scheme to use between server and client.
    # Valid values are "bsd", "bsdudp", "bsdtcp" and "ssh".
    # Default: [auth "bsdtcp"]

    auth "bsdtcp"

    # your ssh keys file if you use ssh auth

    and my xinetd/amanda is
    # default: on
    # #
    # # description: Amanda services for Amanda client.
    # #
    service amanda
    {
    #only_from = LON-TI-IT-03
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = amanda, amandabackup
    group = disk
    groups = yes
    server = /usr/lib/amanda/
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }

  2. #2
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    [QUOTE=ay4you;5859
    conf "DailySet1, DailySet2" # your config name
    [/QUOTE]

    Is it really your config name? I think space is not allowed in a config name

  3. #3
    Join Date
    Nov 2008
    Posts
    26

    Default

    yes i have 2 different config file for 2 different backups but they are both on the same server and i also tried it with one of the still the same
    it is not giving me any errors when the config was wrong there was an error now its just blank like its waiting to connect or something
    ]# amrecover

    thats all till i ^C to stop it
    Last edited by ay4you; December 12th, 2008 at 03:45 AM.

  4. #4
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    The remove 'conf' from amanda-client.conf and add it is as argument to amrecover.

    Your xinetd config is broken:
    user = amanda, amandabackup
    Only one user is allowed, What is the user you use on the server?

  5. #5
    Join Date
    Nov 2008
    Posts
    26

    Default

    i have removed the second user and ran
    # amrecover -C amanda-client

    still the same blank nothing is happening
    i use amandabackup on the server

  6. #6
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Did you fix your xinetd setting and restarted xinetd?
    user = amandabackup
    Oh and the server line:
    server = /usr/lib/amanda/
    it should be:
    server = /path/to/amandad
    replace "/path/to/amanda" with the path on your machine.

    Check system log for xinetd error?
    Post amrecover.*.debug file and amandad.*.debug file.

  7. #7
    Join Date
    Nov 2008
    Posts
    26

    Default

    i changed the config in the xinetd file the problem is i can't find the log files
    where are the on the client or server

    server = /path/to/amandad
    replace "/path/to/amanda" with the path on your machine.
    is that on the server or client

  8. #8
    Join Date
    Nov 2008
    Posts
    26

    Default

    here is the amandad.debug
    amandad: debug 1 pid 6129 ruid 81 euid 81: start at Fri Dec 12 13:50:13 2008
    security_getdriver(name=bsdtcp) returns 0xb7ebb140
    amandad: version 2.5.1
    amandad: build: VERSION="Amanda-2.5.1"
    amandad: BUILT_DATE="Thu Oct 25 03:02:01 CDT 2007"
    amandad: BUILT_MACH="Linux localhost 2.6.22.10.tex1 #1 SMP Thu Oct 11 09:44:19 WST 2007 i686 Intel(R) Pentium(R) D CPU 2.66GHz GNU/Linux"
    amandad: CC="gcc" CONFIGURE_COMMAND="'./configure' 'linux' 'gnu'"
    amandad: paths: bindir="/usr/bin" sbindir="/usr/sbin"
    amandad: libexecdir="/usr/lib/amanda" mandir="/usr/share/man"
    amandad: AMANDA_TMPDIR="/tmp/amanda" AMANDA_DBGDIR="/tmp/amanda"
    amandad: CONFIG_DIR="/etc/amanda" DEV_PREFIX="/dev/"
    amandad: RDEV_PREFIX="/dev/" DUMP="/sbin/dump"
    amandad: RESTORE="/sbin/restore" VDUMP=UNDEF VRESTORE=UNDEF
    amandad: XFSDUMP="/sbin/xfsdump" XFSRESTORE="/sbin/xfsrestore"
    amandad: VXDUMP=UNDEF VXRESTORE=UNDEF
    amandad: SAMBA_CLIENT="/usr/bin/smbclient" GNUTAR="/bin/tar"
    amandad: COMPRESS_PATH="/bin/gzip" UNCOMPRESS_PATH="/bin/gzip"
    amandad: LPRCMD="/usr/bin/lpr" MAILER="/usr/bin/Mail"
    amandad: listed_incr_dir="/var/lib/amanda/gnutar-lists"
    amandad: defs: DEFAULT_SERVER="localhost" DEFAULT_CONFIG="DailySet1"
    amandad: DEFAULT_TAPE_SERVER="localhost" HAVE_MMAP HAVE_SYSVSHM
    amandad: LOCKING=POSIX_FCNTL SETPGRP_VOID DEBUG_CODE
    amandad: AMANDA_DEBUG_DAYS=4 BSD_SECURITY RSH_SECURITY USE_AMANDAHOSTS
    amandad: CLIENT_LOGIN="amanda" FORCE_USERID HAVE_GZIP
    amandad: COMPRESS_SUFFIX=".gz" COMPRESS_FAST_OPT="--fast"
    amandad: COMPRESS_BEST_OPT="--best" UNCOMPRESS_OPT="-dc"
    security_handleinit(handle=0x804fe20, driver=0xb7ebb140 (BSDTCP))
    security_streaminit(stream=0x80503d8, driver=0xb7ebb140 (BSDTCP))
    amandad: time 0.000: accept recv REQ pkt:
    <<<<<
    SERVICE noop
    OPTIONS features=ffffffff9ffeffffffff00;
    >>>>>
    amandad: time 0.000: creating new service: noop
    OPTIONS features=ffffffff9ffeffffffff00;

    amandad: time 0.001: sending ACK pkt:
    <<<<<
    >>>>>
    amandad: time 0.002: sending REP pkt:
    <<<<<
    OPTIONS features=fffffeff9ffeffffff7f;
    >>>>>
    amandad: time 0.006: received ACK pkt:
    <<<<<
    >>>>>
    security_close(handle=0x804fe20, driver=0xb7ebb140 (BSDTCP))
    security_stream_close(0x80503d8)
    security_handleinit(handle=0x804f7c8, driver=0xb7ebb140 (BSDTCP))
    security_streaminit(stream=0x80503d8, driver=0xb7ebb140 (BSDTCP))
    amandad: time 0.044: accept recv REQ pkt:
    <<<<<
    SERVICE selfcheck
    OPTIONS features=ffffffff9ffeffffffff00;maxdumps=1;hostnam e=samba.ti.office;config=DailySet2;
    GNUTAR /home/images 0 OPTIONS |;auth=bsdtcp;compress-fast;index;
    >>>>>
    amandad: time 0.044: creating new service: selfcheck
    OPTIONS features=ffffffff9ffeffffffff00;maxdumps=1;hostnam e=samba.ti.office;config=DailySet2;
    GNUTAR /home/images 0 OPTIONS |;auth=bsdtcp;compress-fast;index;

    amandad: time 0.045: sending ACK pkt:
    <<<<<
    >>>>>
    amandad: time 0.049: sending REP pkt:
    <<<<<
    OPTIONS features=fffffeff9ffeffffff7f;
    OK /home/images
    OK /home/images
    OK /home/images
    OK /usr/lib/amanda/runtar executable
    OK /bin/tar executable
    OK /var/lib/amanda/gnutar-lists/. read/writable
    OK /etc/amandates read/writable
    OK /bin/gzip executable
    OK /dev/null read/writable
    OK /tmp/amanda has more than 64 KB available.
    OK /tmp/amanda has more than 64 KB available.
    OK /etc has more than 64 KB available.
    >>>>>
    amandad: time 0.087: received ACK pkt:
    <<<<<
    >>>>>
    security_close(handle=0x804f7c8, driver=0xb7ebb140 (BSDTCP))
    security_stream_close(0x80503d8)
    amandad: time 0.087: pid 6129 finish time Fri Dec 12 13:50:13 2008
    and here is the amrecover.debug

    amrecover: debug 1 pid 6229 ruid 0 euid 0: start at Fri Dec 12 14:02:29 2008

  9. #9
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    The client where you run amrecover try to contact the server, so the server must be configured to accept request from the client.
    the xinetd config must be done on the server.

  10. #10
    Join Date
    Nov 2008
    Posts
    26

    Default

    this is my xinetd on the server
    # default: on
    # #
    # # description: Amanda services for Amanda server and client.
    # #
    service amanda
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = amandabackup
    group = disk
    groups = yes
    server = /usr/lib/amanda/amandad
    server_args = -auth=bsdtcp amdump amindexd amidxtaped
    }


    also i found the error log the amrecover.debug this is the last part from the last time i tried amrecover
    mrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 592: Available - amrecover: connect_portrange: connect from 0.0.0.0.592 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 593: Available - amrecover: connect_portrange: connect from 0.0.0.0.593 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 594: Available - amrecover: connect_portrange: connect from 0.0.0.0.594 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 595: Available - amrecover: connect_portrange: connect from 0.0.0.0.595 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 596: Available - amrecover: connect_portrange: connect from 0.0.0.0.596 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 597: Available - amrecover: connect_portrange: connect from 0.0.0.0.597 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 598: Available - amrecover: connect_portrange: connect from 0.0.0.0.598 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 599: Available - amrecover: connect_portrange: connect from 0.0.0.0.599 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 600: Available - amrecover: connect_portrange: connect from 0.0.0.0.600 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 601: Available - amrecover: connect_portrange: connect from 0.0.0.0.601 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 602: Available - amrecover: connect_portrange: connect from 0.0.0.0.602 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 603: Available - amrecover: connect_portrange: connect from 0.0.0.0.603 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 604: Available - amrecover: connect_portrange: connect from 0.0.0.0.604 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 605: Available - amrecover: connect_portrange: connect from 0.0.0.0.605 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 606: Available - amrecover: connect_portrange: connect from 0.0.0.0.606 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 607: Available - amrecover: connect_portrange: connect from 0.0.0.0.607 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 608: Available - amrecover: connect_portrange: connect from 0.0.0.0.608 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 609: Available - amrecover: connect_portrange: connect from 0.0.0.0.609 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Skip port 610: Owned by npmp-local.
    amrecover: connect_port: Skip port 611: Owned by npmp-gui.
    amrecover: connect_port: Skip port 612: Owned by hmmp-ind.
    amrecover: connect_port: Try port 613: Available - amrecover: connect_portrange: connect from 0.0.0.0.613 failed
    amrecover: connect_portrange: connect to 192.168.2.160.10080 failed: No route to host
    amrecover: connect_port: Try port 614: Available -
    so basically it connected from that last line it say amrecover: connect_port: Try port 614: Available
    Last edited by ay4you; December 12th, 2008 at 04:23 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •