Results 1 to 9 of 9

Thread: amanda 2.6.0 cant do incremental

  1. #1
    Join Date
    Dec 2008
    Posts
    21

    Default amanda 2.6.0 cant do incremental

    amanda 2.6.0 on RHEL5 64

    here is what I do :
    1. add file1 ( 10 Mb) in my disk, run amdump, success.
    2. add file2 ( 9 Mb) in my disk, run amdump, failed. it says

    FAILURE DUMP SUMMARY:
    t24prd.sahabatfinance.co.id /data/larsen3 lev 1 FAILED "[dump larger than available tape space, 17722 KB, skipping incremental]"
    planner: FATAL cannot fit anything on tape, bailing out

    my tape size is 15 Mb, but my dumptype strategy is "nofull". summary says it is lev 1 but why size is 17722 KB ? shouldn't its just around 9 Mb ?

    this is my config
    # amanda.conf - sample Amanda configuration file. See amanda.conf(5) for
    # details

    org "my organization" # your organization name for reports
    mailto "amanda" # space separated list of operators at your site
    dumpuser "amanda" # the user to run dumps under

    inparallel 4 # maximum dumpers that will run in parallel (max 63)
    # this maximum can be increased at compile-time,
    # modifying MAX_DUMPERS in server-src/driverio.h
    dumporder "sssS" # specify the priority order of each dumper


    taperalgo first


    displayunit "k" # Possible values: "k|m|g|t"


    netusage 8000 Kbps # maximum net bandwidth for Amanda, in KB per sec

    dumpcycle 7 days # the number of days in the normal dump cycle
    runspercycle 5 # the number of amdump runs in dumpcycle days
    # (4 weeks * 5 amdump runs per week -- just weekdays)
    tapecycle 4 tapes # the number of tapes in rotation


    bumpsize 20 Mb # minimum savings (threshold) to bump level 1 -> 2
    bumppercent 20 # minimum savings (threshold) to bump level 1 -> 2
    bumpdays 1 # minimum days at each level
    bumpmult 4 # threshold = bumpsize * bumpmult^(level-1)

    etimeout 300 # number of seconds per filesystem for estimates.
    dtimeout 1800 # number of idle seconds before a dump is aborted.
    ctimeout 30 # maximum number of seconds that amcheck waits
    # for each client host

    device_output_buffer_size 1280k
    # amount of buffer space to use when writing to devices

    usetimestamps yes


    flush-threshold-dumped 0
    flush-threshold-scheduled 0
    taperflush 0
    autoflush no

    runtapes 1 # number of tapes to be used in a single run of amdump
    tpchanger "chg-disk" # the tape-changer glue script
    tapedev "file:/space/amanda-vtapes/slots" # the no-rewind tape device to be used

    #changerfile "/usr/local/etc/amanda/DailySet1/changer"
    #changerfile "/usr/local/etc/amanda/DailySet1/changer-status"
    changerfile "/usr/local/etc/amanda/test/chg-disk-status"
    #changerdev "/dev/sg1"


    maxdumpsize -1 # Maximum number of bytes the planner will schedule
    # for a run (default: runtapes * tape_length).
    tapetype HARDDISK # what kind of tape it is (see tapetypes below)
    labelstr "^test-[0-9]*$" # label constraint regex: all tapes must match

    amrecover_do_fsf yes # amrecover will call amrestore with the
    # -f flag for faster positioning of the tape.
    amrecover_check_label yes # amrecover will call amrestore with the
    # -l flag to check the label.
    amrecover_changer "changer" # amrecover will use the changer if you restore
    # from this device. It could be a string like 'changer' and amrecover will use your
    # changer if you set your tape to 'changer' with 'setdevice changer' or via
    # 'tapedev "changer"' in amanda-client.conf

    holdingdisk hd1 {
    comment "main holding disk"
    directory "/dumps/amanda" # where the holding disk is
    use -100 Mb # how much space can we use on it
    # a non-positive value means:
    # use all space but that value
    chunksize 1Gb # size of chunk if you want big dump to be
    # dumped on multiple files on holding disks
    # N Kb/Mb/Gb split images in chunks of size N
    # The maximum value should be
    # (MAX_FILE_SIZE - 1Mb)
    # 0 same as INT_MAX bytes
    }


    define tapetype HARDDISK {
    length 15 mbytes
    }



    define dumptype global {
    comment "Global definitions"
    # This is quite useful for setting global parameters, so you don't have
    # to type them everywhere. All dumptype definitions in this sample file
    # do include these definitions, either directly or indirectly.
    # There's nothing special about the name `global'; if you create any
    # dumptype that does not contain the word `global' or the name of any
    # other dumptype that contains it, these definitions won't apply.
    # Note that these definitions may be overridden in other
    # dumptypes, if the redefinitions appear *after* the `global'
    # dumptype name.
    # You may want to use this for globally enabling or disabling
    # indexing, recording, etc. Some examples:
    # index yes
    # record no
    # split_diskbuffer "/raid/amanda"
    # fallback_splitsize 64m
    }


    define dumptype comp-user-tar {
    user-tar
    auth "bsdtcp"
    strategy nofull
    compress client fast
    }

    ##END##

  2. #2
    Join Date
    Dec 2008
    Posts
    21

    Default

    I try to install amanda 2.6.0 on different machine ( centos)
    I did the same thing as before, and still the results is the same.

    It says dump failure because the size ( which is total size) is more than the tape size.

    amanda still try do dump total file, even when I set strategy to nofull, even when dump summary says its level 1 backup.

    any ideas ?

    paxvor

  3. #3
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    306

    Default

    Even for nofull, I suppose the first backup (even though level 1) will still need to be the full disklist entry, ie. a full backup. If your disklist entry is bigger than your tape capacity, you need to either make exclusions to bring it down to the tape size, divide it down to the tape size

    [url]http://wiki.zmanda.com/index.php/How_To:Split_DLEs_With_Exclude_Lists[/url]

    or use more than one tape per run (runtapes > 1 in amanda.conf) and setting tape_splitsize.

  4. #4
    Join Date
    Dec 2008
    Posts
    21

    Default

    the first backup is no problem , since i know it must be the full backup.
    but the 2nd and 3rd backup is doing full backup ( I can tell from the size ), even though it says lev 1 backup. I'm positive the DLE not exceeded the tape capacity. I use vtape and only small size files in my DLE ( about 9 MB each file).

  5. #5
    Join Date
    Dec 2008
    Posts
    21

    Default

    is there a way to solve this problem ? anyone.
    any help would be appreciated ..

    paxvor

  6. #6
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    With 'nofull', amanda always do level 1 backup. As no full backup (level 0) are done, all level 1 include all files.
    'nofull' should be use only if the full backup is done by another config.
    What you want is:
    strategy standard
    dumpcycle 10000
    bumpdays 10000

  7. #7
    Join Date
    Dec 2008
    Posts
    21

    Default

    I change my config into :
    ====

    strategy standard
    dumpcycle 10000
    bumpdays 10000
    =========

    result :

    add file 1, 1st dump : full ( only file 1 )
    add file 2, 2nd dump : level1 ( only file 2)
    add file 3 , 3rd dump : level 1 ( file 2 + file 3)

    I want to make incremental in every dump ( in 3rd dump only file 3 backed up, in 4th dump only file 4 backed up, and so on).

    thnks

    - paxvor -

  8. #8
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    You want to increase the level at every run.
    Amanda is limited to level 0-9, using more level would make the restoration take too much time.
    When do you expect full backup to be done? Every backup system need a full do be done on a regular schedule.

  9. #9
    Join Date
    Dec 2008
    Posts
    21

    Default

    i understand your point , and i couldn't agree more.

    I just have this thought to make the most of my situation today ( very big files to backup , limited tape capacity ) until I have the ideal backup system.

    thnks for the 9 level information.

    - paxvor -

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •