Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: self check problem

  1. #1

    Question self check problem

    amcheck DailySet1
    Amanda Tape Server Host Check
    -----------------------------
    slot 6:read label `DailySet1-6', date `X'.
    NOTE: skipping tape-writable test
    Tape DailySet1-6 label ok
    NOTE: host info dir /etc/amanda/DailySet1/curinfo/carona.rrap-software.com does not exist
    NOTE: it will be created on the next run.
    NOTE: index dir /etc/amanda/DailySet1/index/carona.rrap-software.com does not exist
    NOTE: it will be created on the next run.
    Server check took 0.394 seconds

    Amanda Backup Client Hosts Check
    --------------------------------
    WARNING: carona.rrap-software.com: selfcheck request failed: timeout waiting for ACK
    Client check: 2 hosts checked in 30.414 seconds. 1 problem found.

    (brought to you by Amanda 2.6.0p2)

    Hi all,

    when i am running amcheck DailySet1 am getting this error
    i installed amanda server on cent os 5.2 and my client is solaris-10 (x86-intel version)

    please help me........... I tried a lot

  2. #2
    Join Date
    Oct 2008
    Location
    Campinas-SP
    Posts
    34

    Default

    Hi !

    Is carona.rrap-software.com the Solaris 10 right ?
    Looks like a remote connection problem. It has any kind of firewall running on it (iptables/ipchains) ?

    On Solaris, check the inetd configuration file for the amanda service has "disable = no". I think the default is "disable = yes" and you need to change it yourself by editing the file. Restart inetd after any changes on its configuration files.

  3. #3

    Default

    I am new to solaris may i get details about inet file needed for amanda
    is this same as amandaserver & amandaclient file in the /xinetd.d/ directory in LINUX

  4. #4
    Join Date
    Oct 2008
    Location
    Campinas-SP
    Posts
    34

    Default

    I am not sure if it is the same on linux. On linux it is /etc/xinetd.d/amandaclient and it looks like this:
    Code:
    [zenoss@agente86 ~]$ cat /etc/xinetd.d/amandaclient 
    # default: on
    #
    # description: The Amanda backup client should be enabled for systems
    #              which will be backed up by an Amanda backup server.
    
    service amanda
    {
    	disable		= no
    	flags           = IPv4
            flags		= IPv6
    	socket_type	= stream
    	protocol	= tcp
    	wait		= no
    	user		= amandabackup
    	group		= disk
    	groups		= yes
    	server		= /usr/libexec/amanda/amandad 
    	server_args     = -auth=bsdtcp amdump
    }
    [zenoss@agente86 ~]
    And don't forget to check if it has a firewall running. Disable it just to test the connection again using amcheck.

    cheers,

  5. #5

    Default

    in solaris inetd config file should be at /var/lib/amanda/example/inetd.conf.amandaclient
    is amanda service running?

    try running following command , it should show online
    # svcs -a |grep -i amanda
    online Nov_14 svc:/network/amanda/tcp:default

    if it is not onlne try to restart with "svcadm restart svc:/network/amanda/tcp:default" command.

  6. #6

    Default

    svcs -a |grep -i amanda

    i tried this .............

    i copied the contents of /var/lib/amanda/example/inetd.conf.amandaclient file and put it in /etc/inetd.conf file ............then i restarted the amanda by using this
    svcadm restart svc:/network/amanda/tcp:default command
    then i got this output

    svcadm: Pattern 'svc:/network/amanda/tcp:default' doesn't match any instances


    here iS the content of /etc/inetd.conf


    amanda stream tcp nowait amandabackup /usr/libexec/amanda/amandad amandad -auth=ssh amdump amindexd amidxtaped


    am usig ssh as authentication protocol
    i dont is there any problem in my installed package for amanda.................????
    Last edited by praveen; December 4th, 2008 at 09:21 PM.

  7. #7
    Join Date
    Oct 2008
    Location
    Campinas-SP
    Posts
    34

    Default

    I'm sorry, I never used the ssh authentication. I'm afraid I don't have any other ideas to help you.....
    I hope others can.

    cheers

  8. #8
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Show me you are using ssh as authentification?
    > amadmin DailySet1 disklist | grep -i auth

    If you are using ssh, an inetd is not needed.

  9. #9

    Default

    amadmin DailySet1 disklist | grep -i auth
    auth ssh
    auth ssh

  10. #10
    Join Date
    Nov 2005
    Location
    Canada
    Posts
    1,049

    Default

    Add:
    debug_auth 1
    to the amanda.conf and amanda-client.conf

    retry amcheck.
    post the latest amcheck.*.debug for the server
    post the latest amandad.*.debug and selfcheck.*.debug from the client.
    Check system log to be sure the ssh made a connection

    Can you upgrade amanda on carona.rrap-software.com to 2.6.0p2?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •