Results 1 to 3 of 3

Thread: amrecover is not using the default tape drive

  1. #1
    Join Date
    Oct 2008
    Location
    Campinas-SP
    Posts
    34

    Default amrecover is not using the default tape drive

    Hi !

    Looks like amrecover is not using the default tape drive as configured in amanda.conf. I need to explicit indicate the correct tape drive on command line.

    using the default tape drive. (please, note the message "Extracting files using tape drive changer" - I don't have a tape drive changer ; and the following "Not an amanda tape")
    Code:
    root@bigslam:/tmp>amrecover -C diario 
    AMRECOVER Version 2.6.0p2. Contacting server on localhost ...
    220 bigslam AMANDA index server (2.6.0p2) ready.
    Setting restore date to today (2008-11-27)
    200 Working date set to 2008-11-27.
    200 Config set to diario.
    200 Dump host set to bigslam.
    Use the setdisk command to choose dump disk to recover
    amrecover> setdisk profiles_h-m
    200 Disk set to profiles_h-m.
    amrecover> cd melissa
    /melissa
    amrecover> add NTUSER.DAT
    Added file /melissa/NTUSER.DAT
    amrecover> extract
    
    Extracting files using tape drive changer on host localhost.
    The following tapes are needed: diario-21
    
    Restoring files into directory /tmp
    WARNING: Existing file /tmp/melissa/NTUSER.DAT will be overwritten
    Continue [?/Y/n]? Y
    
    Extracting files using tape drive changer on host localhost.
    Load tape diario-21 now
    Continue [?/Y/n/s/d]? Y
    Load tape diario-21 now
    Continue [?/Y/n/d]? Y
    Not an amanda tape
    Load tape diario-21 now
    Continue [?/Y/n/d]? Y
    Not an amanda tape
    Load tape diario-21 now
    Continue [?/Y/n/d]? n
    amrecover: short block 0 bytes
    UNKNOWN file
    amrecover: Can't read file header
    Extractor child exited with status 1
    amrecover> quit
    200 Good bye.
    root@bigslam:/tmp>
    However, explicit use of the right device on command line is fine:
    Code:
    root@bigslam:~>amgetconf diario  tapedev
    tape:/dev/nst0
    root@bigslam:~>root@bigslam:/tmp>amrecover -C diario -d /dev/nst0
    AMRECOVER Version 2.6.0p2. Contacting server on localhost ...
    220 bigslam AMANDA index server (2.6.0p2) ready.
    Setting restore date to today (2008-11-27)
    200 Working date set to 2008-11-27.
    200 Config set to diario.
    200 Dump host set to bigslam.
    Use the setdisk command to choose dump disk to recover
    amrecover> setdisk profiles_h-m
    200 Disk set to profiles_h-m.
    amrecover> cd melissa
    /melissa
    amrecover> add NTUSER.DAT
    Added file /melissa/NTUSER.DAT
    amrecover> extract
    
    Extracting files using tape drive /dev/nst0 on host localhost.
    The following tapes are needed: diario-21
    
    Restoring files into directory /tmp
    WARNING: Existing file /tmp/melissa/NTUSER.DAT will be overwritten
    Continue [?/Y/n]? Y
    
    Extracting files using tape drive /dev/nst0 on host localhost.
    Load tape diario-21 now
    Continue [?/Y/n/s/d]? Y
    Load tape diario-21 now
    Continue [?/Y/n/d]? Y
    ./melissa/NTUSER.DAT
    Also, I had to confirm twice the message asking to load the tape (see above). I am sure the tape is on the tape drive. Just before to call amrecover, I ran amcheck and the tape diario-21 was loaded and recognized.

  2. #2
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    306

    Default

    Hmmm, that is strange. If everything is working fine except for amrecover, possibly there is something unexpected in /etc/amanda/amanda-client.conf or /etc/amanda/<config>/amanda-client.conf. If everything looks good there, you can at least set the record straight with the same file by expliciting stating

    conf "diario # your config name
    index_server "localhost" # your amindexd server
    tape_server "localhost" # your amidxtaped server
    tapedev "tape:/dev/nst0" # your tape device

    Paul

  3. #3

    Default Same problem here

    Just upgraded from 2.5.0p2-4 where "amrecover -d default" used to work as described in the amrecover manpage:

    Code:
    To use the default tape device selected by the tape server, the word default must be specified.
    After I upgraded to 2.6.1p1 this no longer works:

    Code:
    Extracting files using tape drive default on host atlas.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •