Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Incremental backup always emails despite configuring otherwise

  1. #1

    Unhappy Incremental backup always emails despite configuring otherwise

    Hi there

    I'm using Zmanda v1 for incremental backups. I have removed the 'mailto=' line from my configuration file (I use RSS for updates), but I am still receiving emails! Is this a bug or is there some other configuration I need to do to turn them off?

    Many thanks

  2. #2

    Default

    Have you set "mailto" in "/etc/mysql-zrm/mysql-zrm.conf", which is normally treated as global config ?

  3. #3

    Default

    Ah yes, removing this has fixed the problem, thanks!

  4. #4

    Default

    If we need to set it in the global config, then how can I get email from one backup and not from another?

  5. #5

    Default

    I have a further question on this thread.

    I am now using a single configuration for both my daily and incremental (every 15 minutes) backups. I would like the daily run to send me an email, whereas I don't want an email for the incremental run.

    Is it possible to specify "no email" from the command line when I schedule my incremental run? From what I've read there is no way to do this at the moment.

  6. #6
    Join Date
    Oct 2006
    Posts
    199

    Default

    Quote Originally Posted by lylo View Post
    I have a further question on this thread.

    I am now using a single configuration for both my daily and incremental (every 15 minutes) backups. I would like the daily run to send me an email, whereas I don't want an email for the incremental run.

    Is it possible to specify "no email" from the command line when I schedule my incremental run? From what I've read there is no way to do this at the moment.
    mail policy will be available in the next release and there you will be able to specify the policy on the command line too.

    --kkg

  7. #7

    Default

    Quote Originally Posted by lylo View Post
    I have a further question on this thread.

    I am now using a single configuration for both my daily and incremental (every 15 minutes) backups. I would like the daily run to send me an email, whereas I don't want an email for the incremental run.

    Is it possible to specify "no email" from the command line when I schedule my incremental run? From what I've read there is no way to do this at the moment.
    We can use post backup plugin for the same. ZRM passes arguments such as “--databases --backup-directory --checksum-pending “ to post backup plugin.
    In “--backup-directory” you can find “index” file, in which search for “backup-level”, if it is set to “0” then it is full backup. You can write a script to read this value and send a mail by using mail command if backup-level is “0”.
    If this works, disable automatic mailing for backup set.

    For more info on post-backup-plugin read “/usr/share/mysql-zrm/plugins/post-backup.pl”.

  8. #8

    Default mysql mail

    I didn't mean to hijack this thread but, when backups are configured via mysql user cron, how do you tell it not to mail 'root' account every time it runs a job. Sendmail is not configured for mysql user - is there a way to add mysql user to sendmail to avoid this or stop this email process all together>?

  9. #9

    Default

    Quote Originally Posted by linuxguy View Post
    I didn't mean to hijack this thread but, when backups are configured via mysql user cron, how do you tell it not to mail 'root' account every time it runs a job. Sendmail is not configured for mysql user - is there a way to add mysql user to sendmail to avoid this or stop this email process all together>?
    Can you check "mailto" option in /etc/mysql-zrm/__backup_set_name__/mysql-zrm.conf OR /etc/mysql-zrm/mysql-zrm.conf
    files, this might have been set to mailto="root@localhost".

  10. #10

    Default

    Quote Originally Posted by kulkarni_mangesh View Post
    Can you check "mailto" option in /etc/mysql-zrm/__backup_set_name__/mysql-zrm.conf OR /etc/mysql-zrm/mysql-zrm.conf
    files, this might have been set to mailto="root@localhost".
    I checked and its not.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •