Results 1 to 2 of 2

Thread: Please help, i can't recovery non-ascii files

  1. #1

    Default Please help, i can't recovery non-ascii files

    (Sorry bad english)

    Hi guys, i can't recovery non-ascii files.

    i'm using amrecover to recovery files, my amanda version is 2.5, when i send the ls command in the amrecover shell it return a list like that (i.e.):

    2008-10-30 Diret?rio1
    2008-10-30 Administra??o

    I just can add this files sending this comand (i.e.):

    add Dire*
    add Admi*

    and it return

    Added dir Diret\347rio1 at date 2008-10-30
    Added dir Administra\347\343o at date 2008-10-30

    and when i send the extract comand, after few minutes amanda can't find the file.
    I can just recovery ascii files

    Please somebody help me!
    Last edited by duduzinhu16; November 7th, 2008 at 02:45 AM.

  2. #2

    Default Problem Solved

    Problem Solved

    I think this problem happen because the amanda database is using a different encoding of the linux, and when amanda try to extract the files of the tape, the GNUTAR cant find the file (please correct me if I'm wrong).


    just type:

    # export LC_ALL=pt_BR.ISO8859-1
    # export LANG=pt_BR.ISSO8859-1

    Change the "pt_BR.ISO8859-1" by your own encoding

    Thank you!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts