Results 1 to 2 of 2

Thread: Scheduler: Deleting in a backup-set specific manner

  1. #1

    Default Scheduler: Deleting in a backup-set specific manner

    I'm having difficulty managing my backup schedule when I have overlapping backup times for different backup sets. When I attempt to delete an entry for a specific backup set, all entries that match the time/interval are being removed.

    Ex:
    0 12 * * * /usr/bin/zrm-pre-scheduler --action backup --backup-set set1 --backup-level 1 --interval daily
    0 12 * * * /usr/bin/zrm-pre-scheduler --action backup --backup-set set2 --backup-level 1 --interval daily
    0 14 * * * /usr/bin/zrm-pre-scheduler --action backup --backup-set set2 --backup-level 1 --interval daily

    When I run:
    mysql-zrm-scheduler --delete --interval daily --start 12:00 --backup-set set2

    Both the first and second entry are being removed.

    This is very troublesome for me right now because my multiple databases with different backup sets need to be sent to different S3 buckets, and when I tweak one backup setting, it's effecting my other backups. Is there any way around this?

    Overall I've found Zmanda very helpful and have had a lot of success automating the creation of a backup plan + S3 export (through a post-backup-plugin) with deployment tools. This is the last issue that I'm trying to work around.

    thanks
    -Wes

  2. #2
    Join Date
    Oct 2006
    Posts
    199

    Default

    Quote Originally Posted by winhamwr View Post
    I'm having difficulty managing my backup schedule when I have overlapping backup times for different backup sets. When I attempt to delete an entry for a specific backup set, all entries that match the time/interval are being removed.

    Ex:
    0 12 * * * /usr/bin/zrm-pre-scheduler --action backup --backup-set set1 --backup-level 1 --interval daily
    0 12 * * * /usr/bin/zrm-pre-scheduler --action backup --backup-set set2 --backup-level 1 --interval daily
    0 14 * * * /usr/bin/zrm-pre-scheduler --action backup --backup-set set2 --backup-level 1 --interval daily

    When I run:
    mysql-zrm-scheduler --delete --interval daily --start 12:00 --backup-set set2

    Both the first and second entry are being removed.

    This is very troublesome for me right now because my multiple databases with different backup sets need to be sent to different S3 buckets, and when I tweak one backup setting, it's effecting my other backups. Is there any way around this?

    Overall I've found Zmanda very helpful and have had a lot of success automating the creation of a backup plan + S3 export (through a post-backup-plugin) with deployment tools. This is the last issue that I'm trying to work around.

    thanks
    -Wes
    I am unable to reproduce this issue.
    Could you specify which version of ZRM you are using and on which OS?

    Also it will be helpful if you can post the output of the delete command and the output of crontab -l both before and after the delete comand is run.

    --kkg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •