Results 1 to 5 of 5

Thread: AMCHECK - selfcheck request failed: timeout waiting for ACK

  1. #1

    Default AMCHECK - selfcheck request failed: timeout waiting for ACK

    Server (Ubuntu Hardy, IP addr:192.168.3.132), Amanda version: 2.5.2p1
    Client (Ubuntu Dapper, IP addr:192.168.3.145), Amanda version: 2.4.5p1

    Because the client is running 2.4 I am using bsd as the auth method. But I am getting the following when running amcheck:

    Amanda Backup Client Hosts Check
    --------------------------------
    WARNING: 192.168.3.145: selfcheck request failed: timeout waiting for ACK
    Client check: 1 host checked in 29.989 seconds, 1 problem found

    (brought to you by Amanda 2.5.2p1)



    I did check [url=http://wiki.zmanda.com/index.php/Amcheck:_selfcheck_request_failed]this page from the wiki[/url], but I haven't been able to solve the problem using the information there. Here are my xinetd and .amanadahosts configurations. Note that the user and group are both "backup" because this is how it was set up when I installed Amanda from apt.

    *** SERVER ***

    /etc/xinetd.d/amanda:
    Code:
    service amanda
    {
            socket_type     = dgram
            protocol        = udp
            wait            = yes
            user            = backup
            group           = backup
            groups          = yes
            server          = /usr/lib/amanda/amandad
            disable         = no
    }
    service amandaidx
    {
            socket_type     = stream
            protocol        = tcp
            wait            = no
            user            = backup
            group           = backup
            groups          = yes
            server          = /usr/lib/amanda/amindexd
            disable         = no
    }
    service amidxtape
    {
            socket_type     = stream
            protocol        = tcp
            wait            = no
            user            = backup
            group           = backup
            groups          = yes
            server          = /usr/lib/amanda/amidxtaped
            disable         = no
    }
    .amandahosts file
    Code:
    192.168.3.132 backup amdump
    192.168.3.132 root amindexd amidxtaped
    192.168.3.145 root amindexd amidxtaped

    *** CLIENT ***

    /etc/xinetd.d/amanda:
    Code:
    service amanda
    {
           socket_type     = dgram
           protocol        = udp
           wait            = yes
           user            = backup
           group           = backup
           groups          = yes
           server          = /usr/lib/amanda/amandad
           disable         = no
    }
    .amandahosts file
    Code:
    192.168.3.132 backup amdump

    Can anyone tell me what I'm doing wrong?

  2. #2
    Join Date
    Nov 2007
    Location
    Sunnyvale, CA
    Posts
    59

    Default

    Usually when I see something like this, it is because the client and server cannot "see" one another correctly.

    Typically, it is because of some DNS weirdness. Are either of these machines using DHCP?

    If not, you may want to try putting the IP addresses in each machines' /etc/hosts file along with hostnames. Then, replace the IP addresses in your Amanda configuration files with the hostnames you just put into /etc/hosts. (Make sure that both machines are listed in /etc/hosts on both machines, and that you can ping each from the other by name.)

    If you ARE on DHCP, then you're ip addresses may have changed. Ensure that you can ping each machine from the other.

    Finally, are you running firewall software on either machine? That could be interfering.

  3. #3

    Default

    The machines had the individual boxes' hostnames and IPs in the /etc/hosts already.

    I checked and there were no iptable rules on either machine. They're behind the same firewall and are on the same subnet so it wouldn't have been our corporate firewall causing the problem. I'm still puzzled as to what the cause could have been.

    In the end I just removed the debian package from that older box, then downloaded and compiled the 2.5.2p1 source, and was able to successfully configure the client to use bsdtcp authentication. Backup successfully completed for that host last night, so it looks like I'm good for now.

    Thanks for the ideas though, I will definitely keep that in mind should I see this problem again.

  4. #4
    Join Date
    Mar 2008
    Location
    Malaysia
    Posts
    14

    Default amcheck- selfcheck request failed

    Try to restart the xinetd services..

  5. #5
    Join Date
    Mar 2008
    Location
    Malaysia
    Posts
    14

    Default amcheck- selfcheck request failed

    restart the xinetd services

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •