Search:

Type: Posts; User: David.Boyd@insightbb.com

Page 1 of 2 1 2

Search: Search took 0.15 seconds; generated 21 minute(s) ago.

  1. Jean-Louis, I couldn't get ./autogen to work...

    Jean-Louis,

    I couldn't get ./autogen to work ... same complaint about aclocal.

    I downloaded 3.4.5 and it configured and build just peachy.

    I am testing now, but everything looks good.
    ...
  2. Jean-Louis, Thanks for the quick reply. The...

    Jean-Louis,

    Thanks for the quick reply.

    The patch appears to apply correctly. configure appear to run correctly.

    The attachment shows an error which occurs during gmake.

    I have time and...
  3. FreeBSD doesn't have libdl so Amanda 3.4.3 and 3.4.4 won't build

    FreeBSD doesn't have libdl so Amanda 3.4.3 and 3.4.4 won't build.

    The Makefile.in in the device-src directory unconditionally tries to include -ldl. This causes FreeBSD to fail during the build....
  4. Jean-Louis, Sorry it took so long to get back...

    Jean-Louis,

    Sorry it took so long to get back to you.

    The changes that you made allows amanda to build properly on FreeBSD. There is still one test in "configure" that fails to detect FreeBSD...
  5. Jean-Louis, If you can let me know what I can...

    Jean-Louis,

    If you can let me know what I can do to test this, I'll be glad to help.

    I have several VM's available for testing.

    Hope I can help.

    David Boyd.
  6. FreeBSD needs some love in Amanda's configure script

    The Amanda configure script has several (4) places where it attempts to discover the FreeBSD release version. The tests fail to differentiate between release 1 and release 10.

    The enclosed patch...
  7. Test in 3.3.3.svn.5188 causes install/execution failure

    The test for glib_major_version in patch/build 3.3.3.svn.5188 appears to be backwards.

    !glib_major_version < 2 always fails for glib 2.0+ (2.34 in my case)

    I think this fixes it.
    ...
  8. flush-threshold-dumped not exactly working

    We are very happy with 3.2.0 ... thanks for the great work.

    but ...

    with:

    flush-threshold-dumped 25
    flush-threshold-scheduled 50
    taperflush 50
    autoflush yes
  9. new test

    Jean-Louis,

    I rebuilt amanda (using svn.3194 which includes your patch).

    I ran the next backup cycle (approximately 44Gb).

    The tape error appears to reflect the patch as expected.
    ...
  10. fixed-block or variable-block

    Dustin,

    The output of mt status indicates that the Mammoth drive is configued (default) to variable block mode.
  11. path: /usr/local/sbin/mtx

    Jean-Louis,

    I saw that.

    Yes, the path is correct.

    Also, amtape and amlabel are able to manipulate the changer just fine.

    Also, as I indicated, everything works on 2.6.1p1.
  12. patch applied

    and the last 10000 lines.
  13. patch applied

    Jean-Louis,

    I applied your patch to 3.1.0 (svn.3170) and reran the backup.

    The results look identical.

    I am enclosing the first 10000 lines and the last 10000 lines of taper.*.debug.

    This...
  14. mtx and patch

    Jean-Louis,

    yes and yes.

    using mtx version 1.3.11

    I will apply the patch and retry tonight.
  15. taper.*.debug

    taper-debug.zip attached
  16. taper.*.debug too large

    The taper.*.debug file is 50+ meg raw and 800+ k zipped. How should I upload it? (the posted limit is 97.7 k )
  17. taper: FATAL no device is available

    Amanda 3.1.0 (svn.3164)

    using FreeBSD 6.4-RELEASE-p10

    using Exabyte Mammoth EZ17 library.

    using mtx version 1.3.11

    using chg-robot
  18. 3.1.0beta2 fails during tape write

    Whether amdump ("killed while writing to tape") or amflush ("killed while flushing to tape") 3.1.0beta2 (through svn.3027), I have been unable to successfully run on FreeBSD 6.4-RELEASE.

    A...
  19. Maybe I'm missing something here. The...

    Maybe I'm missing something here.

    The amanda-2.6.1-20090223 that I just configured and installed is missing subroutines "do_clean" and "do_eject" in /usr/local/libexec/amanda/chg-glue and is...
  20. Will these patches (chg-glue and compat.pm) be...

    Will these patches (chg-glue and compat.pm) be included in a near future snapshot?
  21. You're right. I didn't see chg-glue.pl. I...

    You're right.

    I didn't see chg-glue.pl.

    I copied chg-glue.pl to chg-glue.

    command: amtape DailySet2 eject

    result: "amtape: slot <none> is ejected."
  22. Yes. Ready, willing and able.

    Yes.

    Ready, willing and able.
  23. The "processing EJECT" line verifies that I did,...

    The "processing EJECT" line verifies that I did, in fact, install compat.pm properly.

    Unfortunately, as I state last night, the resulting debug logs look identical to the earlier ones (with...
  24. I've done that. I inserted an...

    I've done that.

    I inserted an Amanda::Debug::debug("processing EJECT") line in compat.pm to verify correct execution.

    I've created a test server with the same library hardware (an Exabyte...
  25. Okay, I must be doing something wrong ... the...

    Okay, I must be doing something wrong ... the results are the same.

    I copied a new version of compat.pm to Amanda/Changer.

    Was there something else I needed to do?
Results 1 to 25 of 38
Page 1 of 2 1 2