It might be worth using a newer version of client and server. Our documentation has been steadily getting better, and at this point, 2.5.2p1 is getting old pretty old.

The debian/ubuntu...