PDA

View Full Version : Conflicts with Perl upgrade on RHEL 4.4



paolocampegiani
November 5th, 2007, 08:04 AM
Today Red Hat has released a security upgrade for Perl:

https://rhn.redhat.com/errata/RHSA-2007-0966.html

I cannot install this, because the current version of ZRM I'm running on the server (MySQL-zrm-1.2.1-1) requires a newer version of Perl:

$ rpm -q --requires MySQL-zrm | grep perl
/usr/bin/perl
perl >= 5.8.7

and the Red Hat upgrade is to perl-5.8.5-37.RHEL4

What puzzles me is that the _current_ installed version of Perl is perl-5.8.5-36.RHEL4, so the installation of MySQL-zrm should have been failed in the first place, whilst I've been able do perform it (I don't remember forcing the installation, though it could had been).

Anyone could suggest me what to do? It's safe to remove MySQL-zrm, perform the Perl upgrade, and then reinstall it, ignoring the required Perl version?

paddy
November 5th, 2007, 01:10 PM
Today Red Hat has released a security upgrade for Perl:

https://rhn.redhat.com/errata/RHSA-2007-0966.html

I cannot install this, because the current version of ZRM I'm running on the server (MySQL-zrm-1.2.1-1) requires a newer version of Perl:

$ rpm -q --requires MySQL-zrm | grep perl
/usr/bin/perl
perl >= 5.8.7

and the Red Hat upgrade is to perl-5.8.5-37.RHEL4

What puzzles me is that the _current_ installed version of Perl is perl-5.8.5-36.RHEL4, so the installation of MySQL-zrm should have been failed in the first place, whilst I've been able do perform it (I don't remember forcing the installation, though it could had been).

Anyone could suggest me what to do? It's safe to remove MySQL-zrm, perform the Perl upgrade, and then reinstall it, ignoring the required Perl version?

You can ignore the Perl version. We have used minimum perl version as
5.8.7 because that is the oldest version that has been tested by Zmanda.

Paddy

paolocampegiani
November 6th, 2007, 02:58 AM
You can ignore the Perl version. We have used minimum perl version as
5.8.7 because that is the oldest version that has been tested by Zmanda.

Paddy

This means that, everytime Red Hat releases a Perl upgrade, to install it it's required to:

- remove MySQL-zrm
- up2date Perl
- reinstall MySQL-zrm

so please fix it.

paddy
November 7th, 2007, 10:44 AM
This means that, everytime Red Hat releases a Perl upgrade, to install it it's required to:

- remove MySQL-zrm
- up2date Perl
- reinstall MySQL-zrm

so please fix it.


If MySQL-zrm is the only conflict, you can use -f option for "up2date perl"

Unfortunately, there is no easy way to add dependencies on availability of certain
perl modules/functions in rpms.

Has any other user has found the perl dependency as a nuisance because
perl is available in multiple sources?

Thanks,
Paddy

MGJ
November 12th, 2007, 07:09 AM
I am having the same problem. BTW you can't force up2date, you must download the rpm and then force the installation.

Please fix it.

paddy
November 12th, 2007, 07:39 AM
I am having the same problem. BTW you can't force up2date, you must download the rpm and then force the installation.

Please fix it.

Please file a request in http://forums.zmanda.com/bugzilla

Thanks
Paddy

paolocampegiani
November 26th, 2007, 02:09 AM
A bug has been filed: http://forums.zmanda.com/bugzilla/show_bug.cgi?id=52

paddy
November 26th, 2007, 09:59 AM
A bug has been filed: http://forums.zmanda.com/bugzilla/show_bug.cgi?id=52


This bug will be fixed in the next community release. If you want the fix
earlier, please download the 1.2.1-2 rpm package from
http://www.zmanda.com/community-builds.php
(filename "MySQL-zrm-1.2.1-2.noarch.rpm")

Thanks,
Paddy