PDA

View Full Version : selfcheck request failed: timeout waiting for ACK



user1
July 4th, 2007, 06:01 PM
I have installed the server and clients version 2.5.0p2 on Fedora Core 6. I am currently trying to backup/debug a single machine, the home server, which has a firewall, amanda server and the client. I have followed the Quick install instructions on this site; After the installation, amcheck returns the following error. As I can see, it is binding to a different port all the time -- in this case 591. I followed the instructions on the zmanda site, and adjusted iptables accordingly, and then some more adjustments that I could find on the web. I am including some relavant information below, Please let me know what else is required to troubleshoot.

WARNING: myserver: selfcheck request failed: timeout waiting for ACK
Client check: 1 host checked in 30.009 seconds, 1 problem found

__________________________________________________ _______________
bash$ cat /var/log/amanda/amcheck.20070704182804.debug
amcheck: debug 1 pid 23307 ruid 33 euid 0: start at Wed Jul 4 18:28:04 2007
amcheck-clients: time 0.120: bind_portrange2: trying port=591
amcheck-clients: time 0.120: dgram_bind: socket bound to 0.0.0.0.591
amcheck: pid 23307 finish time Wed Jul 4 18:28:35 2007
__________________________________________________ ________________

Note: The IP address of this machine is 192.168.1.1

Firewall setup -- only section pertaining to amanda shown
# Amanda server
iptables -t filter -A INPUT -p tcp -s 192.168.1.0/16 -m tcp --dport 50000:50100 -j ACCEPT
iptables -t filter -A OUTPUT -p tcp -s 192.168.1.0/16 -m tcp --dport 50000:50100 -j ACCEPT
iptables -t filter -A INPUT -p udp -m udp -s 192.168.1.1 --dport 10080 -j ACCEPT
iptables -t filter -A OUTPUT -p udp -m udp -s 192.168.1.1 --dport 10080 -j ACCEPT

iptables -t filter -A INPUT -p tcp -m tcp -s 192.168.1.1 --dport 10082:10083 -j ACCEPT

iptables -t filter -A INPUT -p udp -m udp -s 192.168.1.1 --dport 901 -j ACCEPT
iptables -t filter -A OUTPUT -p udp -m udp -s 192.168.1.1 --dport 901 -j ACCEPT

iptables -t filter -A INPUT -p udp -m udp -s 192.168.1.1 --dport 10080:10083 -j ACCEPT

user1
July 5th, 2007, 06:23 PM
The problem is partially solved and narrowed down to IPTABLES setup (current IPTABLES setup attached in the original thread). So please focus your help on the correct firewall setup; all else is fine with the firewall disabled -- something I can't afford to do.

The issue was complicated by the amanda daemon not running; the cause: in /etc/xinet.d/amanda, I had user = <name1, name2, name3>. A quick look at the "var/log/messages" reveals it wants a single user name. So I made it amanda, and finally the daemon starts.

Please help!

user1
July 9th, 2007, 07:18 PM
I have solved the problem on amand server; the amcheck goes through without any complains -- so now I should be able to backup the server itself. I thank everyone who has read this post