PDA

View Full Version : amcheck behavior when changer needs a new tape



epithumia
May 4th, 2006, 07:30 AM
I've been running 2.5.0 for about a week now on FC5, installed from RPMs built from the Fedora CVS tree with the "amtape update" patch applied. My tape changer is an Exabyte Magnum 1x7 with an LT03 drive. Everything's working great; amanda has no problems controlling the changer and finding the proper tape to use.

However, yesterday was the first day that I left the changer full of recently-used tapes; I wanted to see what would happen. amcheck duly went through the changer looking for the tape it wanted (it doesn't seem to use the barcode catalog at all) and after not finding a usable tape it did nothing. I was hoping to get an email telling me to load some new tapes.

What's supposed to happen here?

pjjw
June 7th, 2006, 05:23 PM
If you want amcheck to send mail, you can feed it the -m option to send email to the address in amanda.conf if there are errors, or -you can use -M<address> to specify another address.

we run amcheck in a cron job at our site, so the output is seen every time..

epithumia
June 7th, 2006, 05:28 PM
Unfortuantely the bug is that amcheck doesn't think there's anything to complain about, so it doesn't send a mail. If you pass -a instead, it will always send a mail whether or not there's anything wrong. However, this message happily informs you "No problems found".

This bug is fixed by a patch I received on the amanda-users list. This patch is still required with 2.5.0p2.