PDA

View Full Version : Problems with taper hanging



AlanG
May 30th, 2017, 07:19 AM
Hi,

(apologies if this is a double post, it didn't seem to work first time).

Have problems with the backup run hanging and it appears to be the taper process.

Sometimes the run will complete, but more often than not most of the dumps will remain on the holding disk and the taper process will stop updating the log. I have to kill taper to get amdump to complete and send the mail report.

Running amflush on the remaining dumps will sometimes complete, but usually hangs as well.

I've pushed large quantities of data to the tape drive via tar, without issue, so can't see a problem there.

The taper always hangs on this point in the log,

taper: Building type SPLIT_FILE header of 65536-65536 bytes with name='mgt-ams-satdb-01.XXX' disk='/var/log/audit' dumplevel=1 and blocksize=65536

But with a different DLE each time.

Running strace on the taper I see this repeated indefinitely.

poll([{fd=0, events=POLLIN}, {fd=3, events=POLLIN}], 2, 5000) = 0 (Timeout)
lseek(4, 0, SEEK_SET) = 0
lseek(4, 0, SEEK_CUR) = 0
write(4, "0", 1) = 1
ftruncate(4, 1) = 0
poll([{fd=0, events=POLLIN}, {fd=3, events=POLLIN}], 2, 5000) = 0 (Timeout)
lseek(4, 0, SEEK_SET) = 0
lseek(4, 0, SEEK_CUR) = 0
write(4, "0", 1) = 1
ftruncate(4, 1) = 0
poll([{fd=0, events=POLLIN}, {fd=3, events=POLLIN}], 2, 5000) = 0 (Timeout)
lseek(4, 0, SEEK_SET) = 0
lseek(4, 0, SEEK_CUR) = 0
write(4, "0", 1) = 1
ftruncate(4, 1) = 0

I was on 3.4, upgraded to 3.4.4 to see if that resolved it, but still remains the same.

Any assistance appreciated.

Thanks,

Alan

martineau
May 30th, 2017, 08:06 AM
You can first your initial post: https://forums.zmanda.com/showthread.php?6409-Problems-with-taper-hanging