PDA

View Full Version : Amanda 2.5.2-1 Selfcheck Request Failed



ddenton
June 11th, 2007, 12:58 PM
I hate to beat a dead horse here, because so many people seem to have asked this question, but none of the solutions I've seen are working for me. I, of course, have a server and client that don't seem to be communicating.

Both machines in question are RHEL 4 servers running, one running the 2.5.1-p2 client, and the other the server package. When I run "amcheck DailySet1", I get:

WARNING: myclient.mydomain.com: selfcheck request failed: timeout waiting for ACK
Client check: 1 host checked in 29.998 seconds, 1 problem found

I've installed both systems by RPM, and followed these instructions almost to the letter:
http://amanda.zmanda.com/quick-backup-setup.html

There's only 1 thing that stood out, and that's a directive in the amanda.conf file on the server. When running the labeling step, I got an error message saying that a dump-type parameter was expected. I pinned it down to the root-tar directive under the dump-type. The labeling procedure wouldn't continue with it in place, so I had to comment it out.

This log was pulled from /tmp/amanda/server/DailySet1 after I ran amcheck...

amcheck: debug 1 pid 31833 ruid 505 euid 0: start at Mon Jun 11 15:40:46 2007
amcheck: debug 1 pid 31833 ruid 505 euid 505: rename at Mon Jun 11 15:40:46 2007
security_getdriver(name=BSD) returns 0x4b60e0
security_handleinit(handle=0x8363470, driver=0x4b60e0 (BSD))
amcheck-clients: time 0.000: bind_portrange2: Try port 937: Available - Success
amcheck-clients: time 0.001: dgram_bind: socket bound to 0.0.0.0.937
amcheck-clients: dgram_send_addr(addr=0xbff58a20, dgram=0x4b7084)
amcheck-clients: time 0.002: (sockaddr_in *)0xbff58a20 = { 2, 10080, 192.168.100.232 }
amcheck-clients: dgram_send_addr: 0x4b7084->socket = 4
changer_query: changer return was 25 1
changer_query: searchable = 0
changer_find: looking for NULL changer is searchable = 0
amcheck-clients: dgram_send_addr(addr=0xbff58910, dgram=0x4b7084)
amcheck-clients: time 10.001: (sockaddr_in *)0xbff58910 = { 2, 10080, 192.168.100.232 }
amcheck-clients: dgram_send_addr: 0x4b7084->socket = 4
amcheck-clients: dgram_send_addr(addr=0xbff58910, dgram=0x4b7084)
amcheck-clients: time 19.999: (sockaddr_in *)0xbff58910 = { 2, 10080, 192.168.100.232 }
amcheck-clients: dgram_send_addr: 0x4b7084->socket = 4
security_seterror(handle=0x8363470, driver=0x4b60e0 (BSD) error=timeout waiting for ACK)
security_close(handle=0x8363470, driver=0x4b60e0 (BSD))
amcheck: pid 31833 finish time Mon Jun 11 15:41:16 2007

So, it atleast appears that the server's trying to communicate. I can ping the client machine by IP address and by hostname, and xinetd must be listening because I can telnet to the client from the server on port 10080.

I'm sure this question has been asked alot before, but given the above info can anyone point me in the right direction? Please let me know what else you may need...

Thanks in advance.

P.S. - I noticed from the above output that the server was trying to communicate using UDP datagrams, so I tweaked the amandaserver and amandaclient xinetd conf files to socket = dgram and protocol = udp, with no luck. ANd I restarted xinetd after each of those changes...

ddenton
June 11th, 2007, 01:07 PM
This might be progress. After changing the socket to dgram and the protocol to UDP, this showed up in the /tmp/amanda/amandad folder. There's a record debug log corresponding to each attempt to run amcheck after the protocol changes:

amandad: debug 1 pid 12230 ruid 501 euid 501: start at Mon Jun 11 16:03:40 2007
security_getdriver(name=bsdtcp) returns 0x13f140
amandad: version 2.5.1p2
amandad: build: VERSION="Amanda-2.5.1p2"
amandad: BUILT_DATE="Thu Nov 9 11:02:36 PST 2006"
amandad: BUILT_MACH="Linux RHES4-VM-1 2.6.12.6-xen3_7.1_rhel4.1 #1 SMP Tue Dec 13 16:02:54 PST 2005 i686 i686 i386 GNU/Linux"
amandad: CC="gcc"
amandad: CONFIGURE_COMMAND="'./configure' '--build=i386-redhat-linux' '--prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--libexecdir=/usr/lib/amanda' '--datadir=/usr/share' '--sysconfdir=/etc' '--sharedstatedir=/var/lib/amanda' '--localstatedir=/var/lib/amanda' '--libdir=/usr/lib' '--includedir=/usr/include' '--infodir=/usr/info' '--mandir=/usr/share/man' '--with-gnutar=/bin/tar' '--with-gnutar-listdir=/var/lib/amanda/gnutar-lists' '--with-dumperdir=/usr/lib/amanda' '--with-index-server=localhost' '--with-tape-server=localhost' '--with-user=amandabackup' '--with-group=disk' '--with-owner=paddy' '--with-fqdn' '--with-bsd-security' '--with-bsdtcp-security' '--with-bsdudp-security' '--with-ssh-security' '--with-assertions'"
amandad: paths: bindir="/usr/bin" sbindir="/usr/sbin"
amandad: libexecdir="/usr/lib/amanda" mandir="/usr/share/man"
amandad: AMANDA_TMPDIR="/tmp/amanda" AMANDA_DBGDIR="/tmp/amanda"
amandad: CONFIG_DIR="/etc/amanda" DEV_PREFIX="/dev/"
amandad: RDEV_PREFIX="/dev/" DUMP="/sbin/dump"
amandad: RESTORE="/sbin/restore" VDUMP=UNDEF VRESTORE=UNDEF
amandad: XFSDUMP=UNDEF XFSRESTORE=UNDEF VXDUMP=UNDEF VXRESTORE=UNDEF
amandad: SAMBA_CLIENT="/usr/bin/smbclient" GNUTAR="/bin/tar"
amandad: COMPRESS_PATH="/bin/gzip" UNCOMPRESS_PATH="/bin/gzip"
amandad: LPRCMD="/usr/bin/lpr" MAILER="/usr/bin/Mail"
amandad: listed_incr_dir="/var/lib/amanda/gnutar-lists"
amandad: defs: DEFAULT_SERVER="localhost" DEFAULT_CONFIG="DailySet1"
amandad: DEFAULT_TAPE_SERVER="localhost" HAVE_MMAP HAVE_SYSVSHM
amandad: LOCKING=POSIX_FCNTL SETPGRP_VOID ASSERTIONS DEBUG_CODE
amandad: AMANDA_DEBUG_DAYS=4 BSD_SECURITY RSH_SECURITY USE_AMANDAHOSTS
amandad: CLIENT_LOGIN="amandabackup" FORCE_USERID HAVE_GZIP
amandad: COMPRESS_SUFFIX=".gz" COMPRESS_FAST_OPT="--fast"
amandad: COMPRESS_BEST_OPT="--best" UNCOMPRESS_OPT="-dc"
amandad: time 0.000: getpeername returned: Transport endpoint is not connected
amandad: time 0.000: pid 12230 finish time Mon Jun 11 16:03:40 2007

martineau
June 11th, 2007, 01:19 PM
You must first choice which auth mechanism you want to use.
You configured your disklist to use 'bsd' and your xinetd to use 'bsdtcp', it can't work.
'bsdtcp' is the prefered choice.
Read http://wiki.zmanda.com/index.php/Configuring_bsd/bsdudp/bsdtcp_authentication to configure your xinetd for the auth mechanism you want to use.
And configure your disklist to use the same auth mechanism.

martineau
June 11th, 2007, 01:31 PM
I've installed both systems by RPM, and followed these instructions almost to the letter:
http://amanda.zmanda.com/quick-backup-setup.html


Did you read:
Go to the “define dumptype global” section in the amanda.conf file and add the “auth "bsdtcp"” line right before the last “}” bracket. This is done to enable “BSDTCP” authentication.

ddenton
June 12th, 2007, 08:03 AM
This may be dumb, but does the password located in the .am_passphrase file need to match the password of the amandabackup user on either the client or the server? I don't see that specified in the doc...

dustin
June 12th, 2007, 08:07 AM
nope -- the passphrase is used to unlock the encryption key. It has nothing to do with login passwords.

ddenton
June 12th, 2007, 08:18 AM
Martineau and Dustin,

Thanks for the replies.

I've set the following files to bsdtcp auth:

Client - /etc/xinetd.d/amandaclient
Server - /etc/xinetd.d/amandaserver
Server - /etc/amanda/DailySet1/amanda.conf (in the global section)

After restartin xinetd on both machines, I'm now not getting new entries in the /tmp/amanda/amandad/ folder on my client machine. I'm also now getting an error saying "unable to bind to a reserved port (got port 34142)". I was getting I was getting entries in /tmp/amanda/amandad/ when I had all of the bsdtcp entries set to bsdudp. Should either work?

Does anyone have an opinion on why the root-tar directive in my amanda.conf file causes nothing to work? I get an error on line X in the amanda.conf file when it's un-commented.

Thanks again for the assistance

ddenton
June 12th, 2007, 08:19 AM
Dustin,

Should my .am_passphrase file be empty then? I found an older set of install instructions that had a line saying you should echo a password and write it to the file, but the new instructions don't have that line.

dustin
June 12th, 2007, 08:24 AM
You only need .am_passphrase if you're using encryption. I would make sure you can get everything running without encryption, first.

ddenton
June 12th, 2007, 08:58 AM
Now I'm getting this...

WARNING: myserver.mydomain.com: selfcheck request failed: recv error: Connection reset by peer

I'm also getting this in the debug folder on the server. No new entries are showing up in my client's debug folder.


amcheck: debug 1 pid 3547 ruid 505 euid 505: start at Tue Jun 12 11:55:50 2007
amcheck: debug 1 pid 3547 ruid 505 euid 505: rename at Tue Jun 12 11:55:50 2007
security_getdriver(name=bsdtcp) returns 0x7eb140
security_handleinit(handle=0x8c94470, driver=0x7eb140 (BSDTCP))
security_streaminit(stream=0x8c948d0, driver=0x7eb140 (BSDTCP))
amcheck-clients: time 0.001: connect_port: Skip port 512: Owned by exec.
amcheck-clients: time 0.001: connect_port: Skip port 513: Owned by login.
amcheck-clients: time 0.002: connect_port: Skip port 514: Owned by shell.
amcheck-clients: time 0.002: connect_port: Skip port 515: Owned by printer.
amcheck-clients: time 0.003: connect_port: Try port 516: Available -
errno 13 strerror Permission denied
amcheck-clients: stream_client: Could not bind to port in range 512-1023.
amcheck-clients: time 0.003: connect_port: Try port 1025: Available -
amcheck-clients: time 0.004: connected to 192.168.100.232.10080
amcheck-clients: our side is 0.0.0.0.1025
amcheck-clients: try_socksize: send buffer size is 65536
amcheck-clients: try_socksize: receive buffer size is 65536
security_seterror(handle=0x8c94470, driver=0x7eb140 (BSDTCP) error=did not get a reserved port: 1025)
security_stream_seterr(0x8c948d0, recv error: Connection reset by peer)
security_seterror(handle=0x8c94470, driver=0x7eb140 (BSDTCP) error=recv error: Connection reset by peer)
security_close(handle=0x8c94470, driver=0x7eb140 (BSDTCP))
security_stream_close(0x8c948d0)
changer_query: changer return was 25 1
changer_query: searchable = 0
changer_find: looking for NULL changer is searchable = 0
amcheck: pid 3547 finish time Tue Jun 12 11:55:50 2007

ddenton
June 12th, 2007, 10:39 AM
I should preface by saying that the most recent debug output before this post occurred after I changed the action in my disklist entry from root-tar to always-full. Upon changing it back to root-tar, I get this output:


amcheck: debug 1 pid 11308 ruid 505 euid 0: start at Tue Jun 12 13:29:12 2007
amcheck: debug 1 pid 11308 ruid 505 euid 505: rename at Tue Jun 12 13:29:12 2007
security_getdriver(name=BSD) returns 0x7eb0e0
security_handleinit(handle=0x929d470, driver=0x7eb0e0 (BSD))
amcheck-clients: time 0.000: bind_portrange2: Try port 550: Available - Success
amcheck-clients: time 0.000: dgram_bind: socket bound to 0.0.0.0.550
amcheck-clients: dgram_send_addr(addr=0xbfe3ae20, dgram=0x7ec084)
amcheck-clients: time 0.001: (sockaddr_in *)0xbfe3ae20 = { 2, 10080, 192.168.100.232 }
amcheck-clients: dgram_send_addr: 0x7ec084->socket = 4
changer_query: changer return was 25 1
changer_query: searchable = 0
changer_find: looking for NULL changer is searchable = 0
amcheck-clients: dgram_send_addr(addr=0xbfe3ad10, dgram=0x7ec084)
amcheck-clients: time 9.999: (sockaddr_in *)0xbfe3ad10 = { 2, 10080, 192.168.100.232 }
amcheck-clients: dgram_send_addr: 0x7ec084->socket = 4
amcheck-clients: dgram_send_addr(addr=0xbfe3ad10, dgram=0x7ec084)
amcheck-clients: time 19.998: (sockaddr_in *)0xbfe3ad10 = { 2, 10080, 192.168.100.232 }
amcheck-clients: dgram_send_addr: 0x7ec084->socket = 4
security_seterror(handle=0x929d470, driver=0x7eb0e0 (BSD) error=timeout waiting for ACK)
security_close(handle=0x929d470, driver=0x7eb0e0 (BSD))
amcheck: pid 11308 finish time Tue Jun 12 13:29:42 2007

I'm pretty sure this has something to do with the root-tar directive in my amanda.conf file, but can't say for sure.

If you have any input on this, please advise...

dustin
June 12th, 2007, 11:12 AM
Authentication methods are specified in dumptype configs. It sounds like you have a number of different authentication methods specified, and that's why changing dumptypes is changing your connection behavior. Hopefully the configs I just asked for in thread 630 (http://forums.zmanda.com/showthread.php?t=630) will clear that up.