PDA

View Full Version : Amanda 2.5 Debian UDP problem



lfrodrigues
April 18th, 2006, 08:00 AM
Hi,

I have setup amanda and a test client for it, my problem is that I get:
WARNING: work: selfcheck request failed: timeout waiting for ACK
when runing amcheck.

It works fine if I use the client on localhost but not with a client on another
machine.

I've looked at the trafic with tcpdump: the server send packges but the client
never reply's.

I've read the mailing list and googled a bit but nothing I found solved my
problem.

Did anyone had this problem? Help, please...

Best regards,

Luis

PS: amandad is started with inetd because it saves the following log:

amandad: debug 1 pid 1883 ruid 34 euid 34: start at Tue Apr 18 12:54:51 2006
amandad: version 2.5.0
amandad: build: VERSION="Amanda-2.5.0"
amandad: BUILT_DATE="Mon Apr 3 05:06:49 PDT 2006"
amandad: BUILT_MACH="Linux rover 2.6.15-15-686 #1 SMP PREEMPT Mon Feb 6
18:34:45 UTC 2006 i686 GNU/Linux"
amandad: CC="gcc"
amandad: CONFIGURE_COMMAND="'./configure' '--prefix=/usr'
'--bindir=/usr/sbin' '--mandir=/usr/share/man' '--libexecdir=/usr/lib/amanda'
'--enable-shared' '--sysconfdir=/etc' '--localstatedir=/var/lib'
'--with-gnutar-listdir=/var/lib/amanda/gnutar-lists'
'--with-index-server=localhost' '--with-user=backup' '--with-group=backup'
'--with-bsd-security' '--with-amandahosts'
'--with-smbclient=/usr/bin/smbclient' '--with-debugging=/var/log/amanda'
'--with-dumperdir=/usr/lib/amanda/dumper.d' '--with-tcpportrange=50000,50100'
'--with-udpportrange=840,860' '--with-maxtapeblocksize=256' '--no-create'
'--no-recursion'"
amandad: paths: bindir="/usr/sbin" sbindir="/usr/sbin"
amandad: libexecdir="/usr/lib/amanda" mandir="/usr/share/man"
amandad: AMANDA_TMPDIR="/tmp/amanda"
amandad: AMANDA_DBGDIR="/var/log/amanda" CONFIG_DIR="/etc/amanda"
amandad: DEV_PREFIX="/dev/" RDEV_PREFIX="/dev/" DUMP="/sbin/dump"
amandad: RESTORE="/sbin/restore" VDUMP=UNDEF VRESTORE=UNDEF
amandad: XFSDUMP="/sbin/xfsdump" XFSRESTORE="/sbin/xfsrestore"
amandad: VXDUMP=UNDEF VXRESTORE=UNDEF
amandad: SAMBA_CLIENT="/usr/bin/smbclient" GNUTAR="/bin/tar"
amandad: COMPRESS_PATH="/bin/gzip" UNCOMPRESS_PATH="/bin/gzip"
amandad: LPRCMD="/usr/bin/lpr" MAILER="/usr/bin/Mail"
amandad: listed_incr_dir="/var/lib/amanda/gnutar-lists"
amandad: defs: DEFAULT_SERVER="localhost" DEFAULT_CONFIG="DailySet1"
amandad: DEFAULT_TAPE_SERVER="localhost"
amandad: DEFAULT_TAPE_DEVICE="null:" HAVE_MMAP HAVE_SYSVSHM
amandad: LOCKING=POSIX_FCNTL SETPGRP_VOID DEBUG_CODE
amandad: AMANDA_DEBUG_DAYS=4 BSD_SECURITY RSH_SECURITY USE_AMANDAHOSTS
amandad: CLIENT_LOGIN="backup" FORCE_USERID HAVE_GZIP
amandad: COMPRESS_SUFFIX=".gz" COMPRESS_FAST_OPT="--fast"
amandad: COMPRESS_BEST_OPT="--best" UNCOMPRESS_OPT="-dc"
amandad: time 29.972: pid 1883 finish time Tue Apr 18 12:55:21 2006

tkr
April 18th, 2006, 08:05 AM
Do you have the right services enabled in /etc/inetd.conf file for amanda?
What about .amandahosts entries on the client?
Any warnings on the amcheck output other than the timeout?
Complete output of amcheck might be useful,if you see other warnings.

Also take a look at the timeout variable in amanda.conf.

Thanks
tk

lfrodrigues
April 18th, 2006, 02:29 PM
Do you have the right services enabled in /etc/inetd.conf file for amanda?

Yes debian set its up when I install the package.



What about .amandahosts entries on the client?


on the server(cat):
/etc/amandahosts:
localhost backup
work backup

on client (work):
/etc/amandahosts:
localhost backup
work backup
cat backup

Is this what you're asking?





Any warnings on the amcheck output other than the timeout?
Complete output of amcheck might be useful,if you see other warnings.

Just this:

(...)

Server check took 0.000 seconds

Amanda Backup Client Hosts Check
--------------------------------
WARNING: Usage of fully qualified hostname recommended for Client localhost.
WARNING: Usage of fully qualified hostname recommended for Client localhost.
WARNING: Usage of fully qualified hostname recommended for Client localhost.
WARNING: work: selfcheck request failed: timeout waiting for ACK
Client check: 2 hosts checked in 30.016 seconds, 1 problem found


Best regards,

Luis

tkr
April 18th, 2006, 03:22 PM
[QUOTE=lfrodrigues]Yes debian set its up when I install the package.



on the server(cat):
/etc/amandahosts:
localhost backup
work backup

on client (work):
/etc/amandahosts:
localhost backup
work backup
cat backup

Is this what you're asking?

>> Yes. Please use FQDNs.





Just this:

(...)

Server check took 0.000 seconds

Amanda Backup Client Hosts Check
--------------------------------
WARNING: Usage of fully qualified hostname recommended for Client localhost.
WARNING: Usage of fully qualified hostname recommended for Client localhost.
WARNING: Usage of fully qualified hostname recommended for Client localhost.
WARNING: work: selfcheck request failed: timeout waiting for ACK
Client check: 2 hosts checked in 30.016 seconds, 1 problem found


>> It seems like "cat" passess but "work" fail. Whats the difference in set up?
>> Is there a firewall involved? Can you try adjusting the ctimeout in >>amanda.conf and see if that makes a difference. Does "work" behave well >>in other aspects, from a network prespective?

Thanks
tk

lfrodrigues
April 19th, 2006, 01:39 AM
>> Yes. Please use FQDNs.

I am, since this are servers that are on the internet I did't want to put the full name here.



>> It seems like "cat" passess but "work" fail. Whats the difference in set up?
>> Is there a firewall involved? Can you try adjusting the ctimeout in >>amanda.conf and see if that makes a difference. Does "work" behave well >>in other aspects, from a network prespective?


work behaves just fine in every other thing. There's a CISCO router involved (but just for the trafic that goes outside this network. Since all the computers are on the same subnet only a switch is really involved.

I don't think chaning timeout will make a diference because I see 3 requests udp packages from server getting the client (running tcpdump on the client) but see no packages leaving...

Thanks,

_LR_

lfrodrigues
April 19th, 2006, 07:03 AM
Finally after 2 day I found out the problem:

I have an internal DNS server so I didn't had the server ip on the client hosts file. If I add it there it works fine...

Does anyone know why amanda doesn't use the DNS.

In nsswitch.conf i have:
hosts: files dns

so should work...

Thanks for trying to help.

_LR

xmanbadung
May 28th, 2006, 11:50 PM
Hi all,

It happen with Fedora Core 5 too, the same error accure when client /etc/hosts file not included tape-server address inside, even nslookup could resolve the tape-server address properly.

Cheers
xmanbadung

simon_ihmig
August 28th, 2006, 11:12 AM
I can confirm this problem.

I have a similar setup: debian sarge, amanda 2.5.0p2 backports.org package
Everything is configured correctly, amandad is invoked by the server but nothing happens.

I also have an internal bind9 server running, internal domain names are resolved correctly, also on the amanda client machine, so the amanda server is reachable under his fqdn (e.g. using ping).

Adding a line to /etc/hosts on the client for the amanda server fixes the problem. Thanks lfrodrigues for that hint, that saved my day! (after hours of unneccessary troubleshooting however :mad: )

I hope this is getting fixed!!!

Greetings,
Simon