PDA

View Full Version : invalid REQ



kumpfjn
April 12th, 2007, 07:21 AM
I setup my windows clients to use ssh for backup and when I run amcheck I get this from the "Amanda Backup Client Hosts Check":

Amanda Backup Client Hosts Check
--------------------------------
ERROR: NAK winsrv3.ad.cas.uc.edu: invalid REQ
ERROR: NAK winsrv4.ad.cas.uc.edu: invalid REQ
ERROR: NAK winsrv1.ad.cas.uc.edu: invalid REQ
ERROR: NAK winsrv2.ad.cas.uc.edu: invalid REQ
Client check: 4 hosts checked in 0.942 seconds, 4 problems found

I used this for my disklist:
winsrv1.ad.cas.uc.edu "/cygdrive/c/Documents and Settings" comp-user-tar
winsrv2.ad.cas.uc.edu "/cygdrive/c/Documents and Settings" comp-user-tar
winsrv3.ad.cas.uc.edu "/cygdrive/c/Documents and Settings" comp-user-tar
winsrv4.ad.cas.uc.edu "/cygdrive/c/Documents and Settings" comp-user-tar

I can ssh to those clients with the amandabackup user and can see those paths. I'm not sure what I am still missing.

martineau
April 12th, 2007, 07:28 AM
Could you provide the complete amandad.*.debug file from a client?
What is the command in the .ssh/authorized_keys? did it list '-auth=ssh'?

kumpfjn
April 12th, 2007, 08:33 AM
How do I get the debug info on the client side?

Which .ssh/authorized_keys the client or server? Neither seem to have that listed in it, where should it be?

Thanks!

martineau
April 12th, 2007, 08:40 AM
How do I get the debug info on the client side?

Which .ssh/authorized_keys the client or server? Neither seem to have that listed in it, where should it be?

Thanks!

Debug are in /tmp/amanda by default.

The command in the client authorized_keys should be command="/PATH/TO/amandad -auth=ssh amdump"

kumpfjn
April 12th, 2007, 08:55 AM
amandad.20070412100425.debug amandad.20070412112711.debug
amandad.20070412100623.debug amandad.20070412112902.debug
amandad.20070412101253.debug
-bash-3.2$ cat amandad/amandad.20070412112902.debug
amandad: debug 1 pid 2740 ruid 6172 euid 6172: start at Thu Apr 12 11:29:02 2007
security_getdriver(name=ssh) returns 0x4246f0
amandad: version 2.5.1p3
amandad: build: VERSION="Amanda-2.5.1p3"
amandad: BUILT_DATE="Tue Feb 6 16:48:10 PST 2007"
amandad: BUILT_MACH="CYGWIN_NT-5.1 windows-build 1.5.24(0.156/4/2) 2007-01-31 10:57 i686 Cygwin"
amandad: CC="gcc" CONFIGURE_COMMAND="'./configure' 'cygwin'"
amandad: paths: bindir="/usr/bin" sbindir="/usr/sbin"
amandad: libexecdir="/usr/lib/amanda" mandir="/usr/man"
amandad: AMANDA_TMPDIR="/tmp/amanda" AMANDA_DBGDIR="/tmp/amanda"
amandad: CONFIG_DIR="/etc/amanda" DEV_PREFIX="/" RDEV_PREFIX="/"
amandad: DUMP="/bin/dump" RESTORE="/usr/sbin/restore" VDUMP=UNDEF
amandad: VRESTORE=UNDEF XFSDUMP=UNDEF XFSRESTORE=UNDEF VXDUMP=UNDEF
amandad: VXRESTORE=UNDEF SAMBA_CLIENT=UNDEF GNUTAR="/bin/tar.exe"
amandad: COMPRESS_PATH="/usr/bin/gzip"
amandad: UNCOMPRESS_PATH="/usr/bin/gzip" LPRCMD="/usr/bin/lpr"
amandad: MAILER="NONE"
amandad: listed_incr_dir="/var/lib/amanda/gnutar-lists"
amandad: defs: DEFAULT_SERVER="localhost" DEFAULT_CONFIG="DailySet1"
amandad: DEFAULT_TAPE_SERVER="localhost" HAVE_SYSVSHM
amandad: LOCKING=POSIX_FCNTL SETPGRP_VOID DEBUG_CODE
amandad: AMANDA_DEBUG_DAYS=4 BSD_SECURITY RSH_SECURITY USE_AMANDAHOSTS
amandad: CLIENT_LOGIN="amandabackup" HAVE_GZIP
amandad: COMPRESS_SUFFIX=".gz" COMPRESS_FAST_OPT="--fast"
amandad: COMPRESS_BEST_OPT="--best" UNCOMPRESS_OPT="-dc"
security_handleinit(handle=0xa658e0, driver=0x4246f0 (SSH))
security_streaminit(stream=0xa65958, driver=0x4246f0 (SSH))
amandad: time 0.000: accept recv REQ pkt:
<<<<<
SECURITY USER amandabackup
SERVICE noop
OPTIONS features=fffffeff9ffeffffff7f;
>>>>>
amandad: time 0.000: received invalid REQ packet:
<<<<<
SECURITY USER amandabackup
SERVICE noop
OPTIONS features=fffffeff9ffeffffff7f;
>>>>>

amandad: time 0.000: sending NAK pkt:
<<<<<
ERROR invalid REQ
>>>>>
security_close(handle=0xa658e0, driver=0x4246f0 (SSH))
security_stream_close(0xa65958)
amandad: time 0.015: pid 2740 finish time Thu Apr 12 11:29:02 2007

martineau
April 12th, 2007, 09:57 AM
Are you sure it use ssh?
What's the output of 'amadmin <config> disklist winsrv1.ad.cas.uc.edu'?
What is the auth setting?

kumpfjn
April 12th, 2007, 10:47 AM
I thought so but maybe not. Also the ssh server in the windows client stopped and won't start again. I just reinstalled the amandaclient using the bsdtcp instead of ssh and now everything works fine.