PDA

View Full Version : Old backups are missing



pspuranik
September 12th, 2013, 12:40 AM
Hi,
I am backing up three hosts (four disks) from last one month. I am using S3 as a tape device. Today I detected that ...

-- amanda is showing history for last 9 backups only and all previous backups are also removed from tape
-- S3 bucket size reduced by considerable chunk; within a day it dropped by 25%.

I have not performed any manual clean-up operation. I am clueless about what happened. Also clueless about why it retained last 9 backups? from where the number 9 came.

Details of my deployment are as per below..

VERSION="Amanda-3.3.4"

dumpcycle 1week # the number of days in the normal dump cycle
runspercycle 5 # the number of amdump runs in dumpcycle days
tapecycle 10 # the number of tapes in rotation
runtapes 1 # number of tapes to be used in a single run of amdump

I seek your help in understanding this behaviour.

Best Regards,

martineau
September 12th, 2013, 03:35 AM
From the tapecycle, you must increase it if you want to keep more backup.

pspuranik
September 13th, 2013, 12:54 AM
martineau,
Thanks for the quick reply. But now I have many questions...

how would my configuration look like if I want to discard my backups only after five years? Do i need to create those many disks in my tape changer. Today my tape changer looks like this as I use only 10 disks.


define changer my_s3 {
tpchanger "chg-multi:s3:<bucket-name>/DailSet1/slot-{01,02,03,04,05,06,07,08,09,10}" # Number of tapes in your "tapecycle"
changerfile "s3-statefile"
}

Please share your experience.

Best Regards,

martineau
September 13th, 2013, 04:08 AM
You need 1827 volumes:
tpchanger "chg-multi:s3:<bucket-name>/DailSet1/slot-{01..1827}" # Number of tapes in your "tapecycle"