View Full Version : Low hardware compression rate (LTO-4)

April 17th, 2013, 04:39 AM

I'm using a TANDBERG LTO-4 HH device with 800/1600Gb tapes.
I would like to use only hardware compression in my backup process, because software take too much time.

First of all, I need to determinate the compression rate of my tape, but i'm stuck.

Here the test i've tried:

Append "/etc/stinit.def" with

manufacturer=TANDBERG model = "LTO-4 HH" {
mode1 blocksize=256 compression=1
After that, I wrote on the tape as follow:

# stinit
# mt-f /dev/nst0 tell (to get the start block number)
# tar cf /dev/nst0 file (file is a 800Mb text-file, so highly compressible)
# mt-f /dev/nst0 tell (to get the last block)

Then, i do : (last block number - start block number)*256 to get the size of file on the tape.
The figure 256 is the block size specified in stinit.def.

The is result is: 798Mb.

So, i conclude that my tape hasn't compressed anything, and i can't see why.

I've also tried to check if the compression was enabled with Amanda tool's amtapetype, heres the output:

# amtapetype -cf DailySet1 /dev/nst0

Checking for FSF_AFTER_FILEMARK requirement
Applying heuristic check for compression.
Wrote random (uncompressible) data at 43360121.704918 bytes/sec
Wrote fixed (compressible) data at 53978927.0204082 bytes/sec
Compression: enabled

So, I've configured my scsi drive to enable hardware compression, Amanda says it's on, but yet my tape won't compress datas. How come ?

Thank you for your help.