PDA

View Full Version : HP StorageWorks DAT72 USB (internal) making trouble?



phaidros
March 10th, 2007, 09:33 AM
Hi, everybody!

I wanted to start doing backups on my fairly new server. I've never had a USB-drive before, and was afraid that there might be trouble recognising it. But fortunately, the tapetype-command worked immediately with "/dev/nst0" as device-file (non-rewinding scsi-tapedrive).

I *was* relieved, but that was early, as I had to learn: when I tried to label my tapes, I would always receive the error "device or resource busy" at the end of the "checking"-phase - this would look like so:

amandauser@host:~$ amlabel DailySet1 xxx-01
labeling tape in slot 1 (/dev/nst0):
rewinding, reading label, not an amanda tape (Device or resource busy)
rewinding, writing label xxx-01, checking label
amlabel: not an amanda tape (Device or resource busy)
amandauser@host:~$

I found another posting somewhere stating that on a ???-drive, one had to change the setting of a dip-switch ("report busy status"), but the HP StorageWorks - drive doesn't have such a switch. Nor did I find any software-setting, which might do the job. As of now, my hardware seems to be absolutely worthless, so I really hope to get a hint!

I'm using debian etch and amanda 2.5.1p1 (the version which comes with debian - I tried to compile p3, but the configure-script fails)

Thanks a lot in advance!

Bests from Vienna/Austria
Matthew

paddy
March 10th, 2007, 06:53 PM
Are you able to access to usb drive using any other command? (such as dd)

Paddy

phaidros
March 10th, 2007, 11:05 PM
Hi, Paddy,

yes, there seems to be no problem. I was able to:

* analyse the tape with amtapetype
* erase it with mt erase
* create a testarchive with tar -cf /dev/nst0 ~
* read its contents table back with tar -tf /dev/nst0 and tar -tvf /dev/nst0
* restore the contents with tar -xf /dev/nst0 -C test
* position to end of medium with mt eom
* add another backup ( tar -cf /dev/nst0 / )
* rewind ( mt rewind )
* position the tape ( mt fsf )
* directly copy content onto it ( dd of=/dev/nst0 bs=1G )

All without any error message ( apart from those which were obvious in the respective situation ).

So to me it seems as if there was a problem with amanda, though I don't want to send you in my cul-de-sac, of course!

Thanks a lot for your help,

Bests
Matthew

phaidros
March 12th, 2007, 10:26 PM
Not a single hint? No one ever saw such a behaviour before? I'm really stuck, for everything else seems to be working flawlessly. I have to begin considering to use another backup-sw (which would be a pity after having spent several dozen hours in "amanda-research").

Thanks and Bests from Vienna/Austria
Matthew

Sachin
March 12th, 2007, 11:18 PM
Hi Matthew,
Could you let us know the changer script you are using?

You can get that with this command:
/usr/sbin/amgetconf <config-name> tpchanger

If possible also let us know the contents of changer.conf file.

Thanks,
Sachin

phaidros
March 14th, 2007, 12:55 AM
Hi Matthew,
Could you let us know the changer script you are using?

You can get that with this command:
/usr/sbin/amgetconf <config-name> tpchanger

If possible also let us know the contents of changer.conf file.

Thanks,
Sachin

Sachin,

amgetconf DailySet1 tpchanger results in an empty line as answer.

This comes to no surprise, as I commented the tapechanger line out (I read that this ought to be done, if you don't want to spread backups over tapes). Before that, I used "chg-manual", but the result was the same: "device or resource busy".

A file "changer.conf" doesn't exist on my system (even after I reenabled the "chg-manual" - glue-script).

What else can I provide?

Matthew

amberthold
March 15th, 2007, 02:30 AM
Hello everybody !

I have the same problem. amcheck reports "device or resource busy" but every other access is successfull.

I have used strace and found that amcheck issues several ioctl() calls between opening and reading the device. Maybe those ioctl() settings aren't suitable for this drive.
Is there any way to influence the ioctl() calls short of patching and recompiling the source ?


Greetings ... Adolf

phaidros
March 20th, 2007, 02:11 PM
I have the same problem. amcheck reports "device or resource busy" but every other access is successfull.

Hi, everyone!

Has anyone else seen this problem? In the meantime I wasn't able to investigate further, but maybe someone has a hint for us.

@amberthold: Maybe we could form a "carpool" on this subject: Please, be so kind as to inform me of any new insights, and I shall do the same. My next step is going to be: get a current source-version and get it compiled (I have trouble there, too). I'll setup a virtual host of its own for amanda, then I'm somewhat more flexible in (un/)installing software. As I'm not completely in control of my xen (to put it nicely) this will take some time, but I'll let you know.

Bests
phaidros

amberthold
March 22nd, 2007, 01:25 AM
Hi !

I solved the problem. My debian-Package was compiled with a tape block size of 256kb and either the kernel or the usb tape driver or the drive itself does not like that. One can reproduce the error with dd:

dd if=/dev/st0 of=tmp bs=256k

If you choose a blocksize of 120kb or below (but not below 32k) than it works.

After recompiling amanda with the configure-parameter "--with-maxtapeblocksize=64" it worked fine too.


--

Greetings ... Adolf

phaidros
March 25th, 2007, 05:38 AM
Adolf,

Great, congratulations! I'll try this as soon as I'll succeed in compiling amanda on a virtual host. Unfortunately, I've got some other stuff to do right now, but I'll post into the forum, because if your solution works fine for me as well, then I think, one can consider it a stable solution to the problem. Maybe we should post a bug, then.

Bests
Matthew

phaidros
August 9th, 2007, 01:27 PM
Hi folks,

it took quite a time, but at last I was able to test Adolf's solution myself: it works fine for me, too - thanks a lot, Adolf!

Bests from Vienna/Austria
Phaidros

phaidros
August 23rd, 2007, 12:01 PM
Adolf,

Great, congratulations! I'll try this as soon as I'll succeed in compiling amanda on a virtual host. Unfortunately, I've got some other stuff to do right now, but I'll post into the forum, because if your solution works fine for me as well, then I think, one can consider it a stable solution to the problem. Maybe we should post a bug, then.

Bests
Matthew

Adolf,

I was able to compile amanda (at last!) with maxblocksize=64k, and everything seems to work fine! Thanks again for your effort!

Bests
Matthew

raymond91007
June 4th, 2008, 01:49 PM
i solved a similar problem by a tapetype directive in amanda.conf

define tapetype dat72e {
comment "HP DAT 72"
readblocksize 64 kbytes
length 35480 mbytes
filemark 0 kbytes
speed 2906 kps
}

the key is "readblocksize 64 kbytes"

i got the idea from here <http://wiki.zmanda.com/index.php/Amanda.conf#TAPETYPE_SECTION>

kernelpannik
March 5th, 2009, 12:22 PM
@raymond91007, you saved my day!

Thanks to all of you for hammering this out. You saved my hide!!!

Felbape
July 24th, 2009, 02:10 PM
i solved a similar problem by a tapetype directive in amanda.conf

define tapetype dat72e {
comment "HP DAT 72"
readblocksize 64 kbytes
length 35480 mbytes
filemark 0 kbytes
speed 2906 kps
}

the key is "readblocksize 64 kbytes"

i got the idea from here <http://wiki.zmanda.com/index.php/Amanda.conf#TAPETYPE_SECTION>


Thanks Man, my problem solved thanks to your response

Regards


by the way, my tapetype conf is:

define tapetype HP-DAT {
comment "DAT tape drives"
readblocksize 64 kbytes
length 81920 mbytes
filemark 0 kbytes
speed 468 kbytes
}