PDA

View Full Version : Windows incremental is a full backup



PaulAm
February 11th, 2013, 10:07 AM
I must be missing something, so bear with me.

I have an Amanda 3.3.3 Linux server and I'm trying to get backups working with an XP-sp3 system running the ZWC-Community-3.3-32bit
edition.

If I do a force a full dump, run the dump and then run another dump, I would expect the incremental to be minimal. Instead, it is the same size as the full dump, although the report indicates that it is a Level 1 (but planner says it's overwriting the full dump)

amreport from level 0:


NOTES:
planner: Forcing full dump of pat-t60:"c:/Documents and Settings/pat" as directed.
taper: Slot 11 with label DS1-11 is not reusable
taper: Slot 12 with label DS1-12 is usable
taper: tape DS1-12 kb 21580 fm 1 [OK]

DUMP SUMMARY:
DUMPER STATS TAPER STATS
HOSTNAME DISK L ORIG-KB OUT-KB COMP% MMM:SS KB/s MMM:SS KB/s
---------------------------------------------- ------------------------------------- ---------------
pat-t60 "c:/Documents and Settings/pat" 0 27489 21580 78.5 0:09 2362.2 0:00 215800.0



amreport from level 1:


NOTES:
planner: Last full dump of pat-t60:"c:/Documents and Settings/pat" on tape DS1-14 overwritten in 1 run.
taper: Slot 14 with label DS1-14 is not reusable
taper: Slot 15 with label DS1-15 is usable
taper: tape DS1-15 kb 21581 fm 1 [OK]


DUMP SUMMARY:
DUMPER STATS TAPER STATS
HOSTNAME DISK L ORIG-KB OUT-KB COMP% MMM:SS KB/s MMM:SS KB/s
---------------------------------------------- ------------------------------------- --------------
pat-t60 "c:/Documents and Settings/pat" 1 27489 21581 78.5 0:09 2391.3 0:01 21581.0


This is the dumptype definition:
define dumptype zwc-compress {
global
index
strategy standard
auth "bsdtcp"
compress client fast
program "DUMP"
}

And this is the dle:
pat-t60 c:/Documents\ and\ Settings/pat zwc-compress

This happens even if I set strategy to "nofull"

I must be missing something, how do I get an incremental from Windows?

bubumannus
March 22nd, 2013, 06:21 AM
I have exactly the same problem. Even if I added amandabackup user to local Administrators group on the Windows client. Can anyone help? It seems an universal problem.

rkl
April 17th, 2013, 01:36 AM
I use a Linux server to backup Windows clients with Amanda 3.3.X and haven't had any problems with incrementals. The dumptype global stuff isn't listed in the original posting, so I'm assuming that's unmodified from the default.

In the latest setup of ours, I've now turned off all incremental -> full promotions using the "maxpromoteday 0" directive. I then force full backups on my own custom scheme (via "amadmin <set> force <machine> <disk>") that Amanda can't do itself. I would advise "estimate server" as a directive on Windows, because the default estimation code on Windows is appallingly slow I've found. I have "index yes" and "record yes" as options in my setup too.

Note that of course, to get incrementals, you should have more than one tape in your scheme and set the appropriate dumpcycle/runspercycle/tapecycle/runtapes directives.

ilyaa
July 4th, 2013, 09:54 PM
See this thread: https://forums.zmanda.com/showthread.php?4177-Full-and-Incremental-Backups

bubumannus
August 8th, 2013, 01:03 PM
This didn't say any solution.

ilyaa
September 2nd, 2013, 01:59 PM
This didn't say any solution.

I doesn't know solution for problem with ZWC version 3.3.
But there is solution for problem with backups on windows hosts - you should use ZWC version 3.1.3. With it incrementals work as expected.

bubumannus
October 23rd, 2013, 02:54 PM
When I switched to enterprise version, incremental backup works even with community version clients on windows 2k8 r2. So the problem is at the server side. Maybe the community version 3.3.4 server doesn't support incremental backup for windows.





I doesn't know solution for problem with ZWC version 3.3.
But there is solution for problem with backups on windows hosts - you should use ZWC version 3.1.3. With it incrementals work as expected.