PDA

View Full Version : Invalid db.table name 'my_db.my_db`.`first_table'



bminc
March 5th, 2007, 07:49 AM
Hello,

Our backup was running without any problems for couple of months now. Last night, out of the blue, it started giving this invalid db.table name error.

The DB structure or config hasn't changed since last successful backup. Here is the full error:


ERROR: Output of command: 'mysqlhotcopy' is {
Invalid db.table name 'my_db.my_db`.`first_table' at /usr/bin/mysqlhotcopy line 854.
}


OS: RHEL4
MySQL: 5.0.27
mysqlhotcopy v1.22


I'm not sure if it's normal for it to list the database name twice.

Anyone have an idea on what could be wrong?

Thanks!

shailen
March 14th, 2007, 01:54 PM
could you please post the contents of your

/var/log/mysql-zrm/mysql-zrm.log please.

also, can you post the mysql-zrm.conf file from your backup set. (don't forget to omit the passwords:) )

Thanks!

-Shailen

shailen
March 15th, 2007, 08:34 AM
Hi,

could you confirm a few things for me?

First of all were there any updates done to DBD:mysql ??

I was able to reproduce this issue.

Here's what worked for me.

I installed ZRM on Fedora Core 5 OS and set it up to protect my mysql database.

At this point i was running DBD:mysql 4.001

I then upgraded to DBD:mysql 4.003 and at this time when I ran ZRM it failed, with the same error.

I reverted back to DBD:mysql 4.001. and ZRM seemed to work fine.

my feeling is there is something within DBD:mysql 4.003 that effects mysqlhotcopy that is not effected in DBD:mysql 4.001

So could you please confirm for me what version of DBD:mysql you are currently running and IF it has been upgraded recently and also can you confirm any other changes made to the system once this stopped working?

thanks!
-Shailen