View Full Version : Dumptype Not Found

November 30th, 2011, 12:42 PM
I have Amanda community 3.1.2 installed on Ubuntu 10.4 LTS and I am trying to run a test backup on a Windows 7 client with Zmanda for Windows installed on it. I followed the Getting Started (http://wiki.zmanda.com/index.php/GSWA/Build_a_Basic_Configuration) Wiki and the 15 Minute Setup Community White paper from network.zmanda.com and when I run amcheck MyConfig, it gives me the error

"/etc/amanda/MyConfig/disklist", line 2: disk dumptype 'zwc-compress' not found
amcheck: errors processing config file

I've added the zwc-compress dumptype to /etc/amanda/template.d/dumptypes using the following code from one of the guides:

define dumptype zwc-compress {
compress client fast
program "DUMP"

Does anyone know what I am missing?

November 30th, 2011, 12:44 PM
Have you included /etc/amanda/template.d/dumptypes file in amanda.conf?

December 5th, 2011, 06:40 AM
Thank you for your reply. Adding that file to amanda.conf worked. It seems my server can now communicate with the Windows client, but is not authenticating:

Amanda Backup Client Hosts Check
ERROR: ephp.hlcommunity.org: Server validation Failed. Please register server with client.
Client check: 1 host checked in 0.662 seconds. 1 problem found.

I've entered the server IP address and other info in ZWC and restarted the PC, but I'm not sure what else to check.

Thank you for your reply.

December 5th, 2011, 08:31 AM
I figured out that the ZWC was not updating the registry, so I went into HKEY_LOCAL_MACHINE\SOFTWARE\Zmanda\ZWC\1.0\Install \Servers and added the server manually, that fixed the problem, though it was not an ideal way to do so.