PDA

View Full Version : dependencies ooooh dependencies



bv_chris
July 4th, 2011, 06:06 AM
Hello dear community.
I have a big problem.

My task is to check and accumulate all the rpm's amanda-backup-client 3.2.3-1 needs so it can run on (now don't laugh) Suse 9.2.

We have some (13) old Servers running Suse who cannot be updated to a newer system, cause of problems with old packages.
That's what they told me.
So i tried to get amanda-backupclient to run but the dependencie jungle caught me.

I now hit a wall with:
tar in version 1.15 because it requires glibc 2.4 which again requires glib-common v 2.5-58 (which isn't supported for Suse9.2) ,basesystem
not supported because this needs rpmlib v 4.4.6-1 (not supported) and a kernel higher then 2.6.9.
So my question is. Is there a way to make it work anyways (some wizardmagic or something?) or do I really need to upgrade the old-servers, which would make my task nullified.
I thank you for your time.

Mfg
Chris