PDA

View Full Version : Bug: break missing in amstar.c



p_michalczyk
June 29th, 2011, 07:28 AM
Without 'break' adding:



property "COMMAND-OPTIONS".....


to amanda.conf while using 'amstar' application-tool yields errors:



backup ~ # sudo -u amanda amcheck systemuser
Amanda Tape Server Host Check
-----------------------------
slot 2: volume 'systemuser-2'
Will write to volume 'systemuser-2' in slot 2.
NOTE: skipping tape-writable test
NOTE: info dir /backup/systemuser/curinfo/matrix/_samba_itnml does not exist
NOTE: it will be created on the next run.
NOTE: index dir /backup/systemuser/index/matrix/_samba_itnml does not exist
NOTE: it will be created on the next run.
Server check took 1.096 seconds

Amanda Backup Client Hosts Check
--------------------------------
ERROR: matrix: [amstar: bad ACL property value (-find)]
ERROR: matrix: [amstar: bad ACL property value (. -newer /tmp/some.file)]
Client check: 1 host checked in 5.080 seconds. 2 problems found.


Sample application-tool config:


define application-tool "STAR" {
comment "star files not older than year"
plugin "amstar"
property "STAR-PATH" "/bin/star"
property "STAR-TARDUMP" "/var/lib/amanda/star-lists/incrlist"
property "STAR-DLE-TARDUMP" "YES"
property "COMMAND-OPTIONS" "-find" ". -newer /tmp/some.file"
}


Patch file attached.

martineau
June 29th, 2011, 07:35 AM
Which amanda versionare you using?
Where is the patch?

p_michalczyk
June 29th, 2011, 07:39 AM
On the client experiencing this issue Amanda 3.2.3, compiled from source.

On the server Amanda 3.2.2 installed from Gentoo ebuild.

I added patch few minutes later after editing original post.

martineau
June 29th, 2011, 11:05 AM
Thanks

I committed the patch.