PDA

View Full Version : Disaster Recovery - Blank Tapes?



rsargeant
April 28th, 2011, 12:24 PM
Hi there,

I'm a complete Amanda Backup newbie so bear with me...

We are in the process of carrying out a DR on a failed server for a customer.
Their previous IT company used Amanda for backup and whilst I'm pretty good with Linux we've never used Amanda.

The version of Amanda in question is 2.5.2p1 which comes bundled with
Novell NOWS SBE. The configuration seems to have gone through okay and
I can interogate the Ultrium drive using the mt commands i.e. status and rewind etc.

To start off with I wanted to establish if the 2 x LTO3 tapes the client has given us actually contain any data.

So I tried both tapes using:

mt -f /dev/nst0 rewind
amrestore /dev/nst0

In both cases I get a similar output (different date string) as follows:

amrestore: 1: reached end of tape: date 20110224231727

I also then tried:

mt -f /dev/nst0 rewind
dd if=/dev/nst0 bs=32k count=1

AMANDA: TAPESTART DATE 20110224231727 TAPE DailySet1-04
014
1+0 records in
1+0 records out
32768 bytes (33 kb) copied, 0.01404 seconds, 2.3 MB/s

Is it looking like the tapes are blank or am I doing something wrong?

Many thanks,

Richard.

martineau
April 28th, 2011, 12:51 PM
You show the first file on tape, it is a TAPESTART, that's good.
Something else on the tape?

Before looking at what is on tape, do the report show that something was written on tape?
What's the ouput of: amadmin CONFIG find

rsargeant
April 28th, 2011, 03:17 PM
As follows:

amadmin DailySet1 find

No dump to list

Thanks,

Richard.

martineau
April 28th, 2011, 03:24 PM
Your backup never succeeded

Have you done some backup?
Do the email report show that the backup succeeded? Post the report.

rsargeant
April 28th, 2011, 03:34 PM
I am not sure if the backup was working before the server failed.

I have built a new server and just need to restore any data possible from one of the tapes, preferably to a different destination folder.

Unfortunatly I have no e-mail reports.