PDA

View Full Version : selfcheck request failed: Connection Refused



jt327
January 11th, 2007, 04:45 PM
Hey guys,

sorry to be posting on here again..i cant help but feel that im spamming this board with problem after problem.

okay well anyways ive decided to build up my amanda server again..thinking it would work better this time..however i was wrong. All i simply want to do is build a server that can backup one of its own local directories to disk..but thats aparrantly too hard for me.

upon running 'amcheck DailySet1' i get the following error..


Amanda Backup Client Hosts Check
---------------------------------
WARNING: server.xxx.local: selfcheck request failed: Connection refused
Client check: 1 host checked in 10.182 seconds, 1 problem found.

(brought to you by Amanda 2.5.1p2)

the end logfile (im not gunna post the whole thing unless you want me to) generated by this looks like..

amcheck-clients: time 10.156: connect_port: Skip port 512: Owned by exec.
amcheck-clients: time 10.156: connect_port: Skip port 513: Owned by login.
amcheck-clients: time 10.157: connect_port: Skip port 514: Owned by shell.
amcheck-clients: time 10.157: connect_port: Skip port 515: Owned by printer.
amcheck-clients: time 10.158: connect_port: Skip port 516: Owned by videotex.
amcheck-clients: time 10.168: connect_port: Try port 517: Available -
amcheck-clients: time 10.168: connect_portrange: connect from 0.0.0.0.517 failedamcheck-clients: time 10.168: connect_portrange: connect to 127.0.0.1.10080 failed: Connection refused
amcheck-clients: stream_client: Could not bind to port in range 512-1023.
amcheck-clients: time 10.170: connect_port: Skip port 1025: Owned by blackjack.
amcheck-clients: time 10.171: connect_port: Skip port 1026: Owned by cap.
amcheck-clients: time 10.181: connect_port: Try port 1027: Available -
amcheck-clients: time 10.181: connect_portrange: connect from 0.0.0.0.1027 failed
amcheck-clients: time 10.181: connect_portrange: connect to 127.0.0.1.10080 failed: Connection refused
amcheck-clients: stream_client: Could not bind to any port: Connection refused
security_seterror(handle=0x9c77d40, driver=0x5d2140 (BSDTCP) error=Connection refused)
security_close(handle=0x9c77d40, driver=0x5d2140 (BSDTCP))
security_stream_close(0x9c781a0)
amcheck: pid 10803 finish time Fri Jan 12 11:38:22 2007

now i have a question..if i want to use the server to as both the server and the client, should my .amandahosts file be any different? At the moment it looks like:

server.xxx.local amandabackup amdump amindexd amidxtaped

could this be a part of the problem? i have no idea..

any help on this matter would be really really appreciated. i have been stuffing around with amanda for weeks now and im about ready to give up.

Thanks in advance,

Jared.

ppragin
January 11th, 2007, 04:49 PM
Please run this on the server:
netstat -a | grep amanda

jt327
January 11th, 2007, 04:54 PM
hi,
netstat -a | grep amanda returns nothing...

any ideas why?

Jared.

ktill
January 11th, 2007, 05:10 PM
is there a file /etc/xinit.d/amandaclient or /etc/xinit.d/amandaserver?
how about restart xinit?

jt327
January 11th, 2007, 05:20 PM
sooo it turs out that a simple restart of xinetd fixed the problem with amcheck..thanks so much guys!

however i quickly just tried to run amdump. It worked fine, ie backed up to disk properly, except i errors looking like:

shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

and i have no idea why? (as you can tell im not that great with linux)

Jared.

ktill
January 11th, 2007, 05:24 PM
cd $HOME

then call amdump.

jt327
January 11th, 2007, 05:26 PM
thanks again..everything works great now! :):):)

jared.

yservel
January 15th, 2007, 03:35 AM
Hi there,

I have got a server and a client. I want to make a backup of both the client and the server.

Which means I use two amanda client, including one on the server. Doing a amcheck, The amanda client installed on the server managed to connect to the amanda server. However the client installed on the remote machine cannot connect to the amanda server. I received exactly the same error message, the client refused to connect.

Reason(s) why it doesn't connect must be different though.

Using the netstat -a command, on the server, i have the following result on the server:

tcp 0 0 *:amanda *:* LISTEN

Which means neither the amidxtaped nor the amandaexd services are running. I did a nmap 127.0.0.1 command to confirm this.

I do the same on the client side:

udp 0 0 *:amanda *:*

On my server, the content of the amanda file is the following:

service amanda
{
only_from = server.fullyqualified.dns client.fullyqualified.dns
socket_type = stream
protocol = tcp
wait = no
user = amandabackup
group = disk
groups = yes
server = /usr/lib/amanda/amandad
server_args = -auth=bsdtcp amdump amindexd amidxtaped
disable = no
}

I used to have a file for the amidxtaped and another one for the amindaexed services. These services were running fine and were using the ports 10082 and 10083. But apparently, we should only use one file now on the server with the 2.5.1b version.

On my client, the content of the amanda file is:

service amanda
{
only_from = server.fullyqualified.dns
socket_type = dgram
protocol = udp
wait = yes
user = amandabackup
group = disk
groups = yes
server = /usr/lib/amanda/amandad
server_args = -auth=bsd amdump
disable = no
}

Should I use bsdudp? Many thanks in advance. :)

Yannick

ktill
January 15th, 2007, 08:09 AM
Hi,

add
auth "bsdtcp"
to the dumptype to use bsdtcp.

--Kevin Till
Zmanda

yservel
January 24th, 2007, 04:26 AM
Hi,

add
auth "bsdtcp"
to the dumptype to use bsdtcp.

--Kevin Till
Zmanda

I added that plus a couple of other things and it worked fine. Many thanks!