PDA

View Full Version : Error amrecover message FEEDME - Got no header and data from server



micho1978
March 24th, 2011, 06:23 AM
I have 2 errors when I try to recover from amanda with amrecover :


pc-srv-prod DailyTape1 # amrecover
AMRECOVER Version 3.1.0. Contacting server on 10.177.18.34 ...
220 pc-srv-prod AMANDA index server (3.1.0) ready.
Setting restore date to today (2011-03-24)
200 Working date set to 2011-03-24.
200 Config set to DailyTape1.
200 Dump host set to pc-srv-prod.
Use the setdisk command to choose dump disk to recover
amrecover> listdisk
200- List of disk for host pc-srv-prod
201- /home/ltoure/ManageEngine.sav
200 List of disk for host pc-srv-prod
amrecover> setdisk /home/ltoure/ManageEngine.sav
200 Disk set to /home/ltoure/ManageEngine.sav.
amrecover> ls
2011-03-23-12-37-28 PMP/
2011-03-23-12-37-28 AppManager9/
2011-03-23-12-37-28 .
amrecover> add AppManager9
Added dir /AppManager9/ at date 2011-03-23-12-37-28
amrecover> extract

Extracting files using tape drive /dev/nst0 on host 10.177.18.34.
The following tapes are needed: DailyTape1-001

Extracting files using tape drive /dev/nst0 on host 10.177.18.34.
Load tape DailyTape1-001 now
Continue [?/Y/n/s/d]? y
Volume '' not found
Strange message from tape server: FEEDME


pc-srv-prod ~ # amrecover
AMRECOVER Version 3.1.0. Contacting server on 10.177.18.34 ...
220 pc-srv-prod AMANDA index server (3.1.0) ready.
Setting restore date to today (2011-03-24)
200 Working date set to 2011-03-24.
200 Config set to DailyTape1.
200 Dump host set to pc-srv-prod.
Use the setdisk command to choose dump disk to recover
amrecover> listdisk
200- List of disk for host pc-srv-prod
201- /home/ltoure/ManageEngine.sav
200 List of disk for host pc-srv-prod
amrecover> setdisk /home/ltoure/ManageEngine.sav
200 Disk set to /home/ltoure/ManageEngine.sav.
amrecover> ls
2011-03-23-12-37-28 PMP/
2011-03-23-12-37-28 AppManager9/
2011-03-23-12-37-28 .
amrecover> add /PMP
Invalid directory - Can't cd outside mount point "/home/ltoure/ManageEngine.sav"
amrecover> add /PMP/
Invalid directory - Can't cd outside mount point "/home/ltoure/ManageEngine.sav"
amrecover> add PMP/
File PMP/ doesn't exist in directory
amrecover> add PMP
Added dir /PMP/ at date 2011-03-23-12-37-28
amrecover> extract

Extracting files using tape drive /dev/nst0 on host 10.177.18.34.
The following tapes are needed: DailyTape1-001

Extracting files using tape drive /dev/nst0 on host 10.177.18.34.
Load tape DailyTape1-001 now
Continue [?/Y/n/s/d]? y
Got no header and data from server, check in amidxtaped.*.debug and amandad.*.debug files on server

My last backup was good :


backup@pc-srv-prod ~ $ amadmin DailyTape1 find

date host disk lv tape or file file part status
2011-03-23 12:37:28 pc-srv-prod /home/ltoure/ManageEngine.sav 1 DailyTape1-001 1 1/1 OK

Can someone try to solve my problems I want to restore backups without issues !

Thanks

martineau
March 24th, 2011, 06:48 AM
Do you loaded DailyTape1-001 in /dev/nst0?


Got no header and data from server, check in amidxtaped.*.debug and amandad.*.debug files on server


What's in those files?