PDA

View Full Version : Adhoc Full-Backup - /dev/nst0 Permission Denied



abouch
January 22nd, 2011, 07:57 AM
Hi All,

I've installed all dependencies and ran the .deb package for Ubuntu Server 10.10.

I then ran amserverconfig creating a configuration named 'Archive'.

I also added the LTO5 tape type to the template.d/tapetypes under the 'Archive' configuration.

I have a single disklist entry...

'localhost /var/staging high-tar'

I've created (I hope) a configuration that does not use a holding area, or vtapes, and has no predefined schedule - it will be run on an adhoc basis (although I think I need to read the docs further here to be sure - not sure if this is right yet).

My amanda.conf is below...

When I run am check - the client test passes - but the server check failes with

"Can't open tape device /dev/nst0: Permission denied"

Any suggestions? I've read the sticky message at the top of the forums... and I 'think' - I ran

usermod -G tape amandabackup
passwd -d amandabackup
su - amandabackup
passwd

mt -f /dev/nst0 status works ok as root.

Our goal here is to create an ad-hoc amanda backup configuration that will be run manually when our staging area has a certain amount of data in it (about 1.3TB - enough nearly fill a tape).

Thoughts? Comments or suggestions greatly appreciated.

Also wondering why the docs recommend using the non-rewinding device /dev/nst0 - as opposed to /dev/st0?

amanda.conf
---------------------
org "MyOrg Archive" # your organization name for reports
mailto "myuser@myorg" # space separated list of operators at your site
dumpcycle 1 # the number of days in the normal dump cycle
runspercycle 1 # the number of amdump runs in dumpcycle days
tapecycle 1 # the number of tapes in rotation
runtapes 1 # number of tapes to be used in a single run of amdump
tpchanger "chg-manual" # the tape-changer glue script
tapedev "/dev/nst0" # the no-rewind tape device
changerfile "/etc/amanda/Archive/chg-manual.conf" # tape changer configuration parameter file
changerdev "/dev/null" # tape changer configuration parameter device
tapetype LTO5 # what kind of tape it is
labelstr "^Archive-[0-9][0-9]*$" # label constraint regex: all tapes must match
dtimeout 1800 # number of idle seconds before a dump is aborted
ctimeout 30 # max number of secconds amcheck waits for each client
etimeout 300 # number of seconds per filesystem for estimates
define dumptype global {
comment "Global definitions"
auth "bsdtcp"
}
define dumptype gui-base {
global
program "GNUTAR"
comment "gui base dumptype dumped with tar"
compress none
index yes
}
includefile "advanced.conf"
includefile "/etc/amanda/template.d/dumptypes"
includefile "/etc/amanda/template.d/tapetypes"

abouch
January 22nd, 2011, 08:34 PM
Thanks to cesarius' sticky post - on full proof install - usermod -G tape amandabackup solved the problem. I'd forgotten to add amandabackup to the tape group.

Now getting an error

slot 23: Can't read label: Error reading Amanda header: Error reading 32768 bytes from /dev/nst0: Input/output error
Error reading Amanda header: Error reading 32768 bytes from /dev/nst0: Input/output error
Insert tape into slot 24 and press return
or type "NONE" to abort


Need to continue reading the docs I guess - since I thought my configuration was a single tape drive without slots.

Getting there....

abouch
January 22nd, 2011, 09:42 PM
Further progress...

If you are an Ubuntu user, or any server with kernel 2.6.34 or above - and you are using an HP ProLiant Server with an HP P212 SmartArray SAS HBA (or any SAS controller) to drive an LTO tape drive - then you MUST use the new HPSA scsci driver and NOT the previous cciss block level driver.

You can modify your grub2 configuration creating a custom menu entry which includes the following line....

linux /vmlinuz-2.6.35-24-server root=/dev/mapper/media01-root ro quiet cciss.cciss_allow_hpsa=1

Victory! :-)