View Full Version : AMRMTAPE returns segmentation fault

December 22nd, 2010, 12:56 PM
Hello Forum,

I've ran amdump a few times trying to determine the appropriate amanda.conf settings for runtapes, length (for vtapes), etc. I originally designed my configuration with 25 slots of 5120 Mbytes, but the first backup failed because "runtapes = 1", and I needed 50 Gbytes.

I thought Amanda would automatically span the dump across all slots. I was wrong. :)

Next I tried increasing runtapes to 10, no go. Then I just decided to set the vtape size to 50 Gbytes and that worked, but it left a horrible lump in the 25 defined slots.

I found a "howto" on configuring Amanda to split the dump across slots, but haven't yet tried it because: I'd like to reset everything to a state where all my vtapes are empty and begin a new cycle first. This is imperative because I do not have enough available disk space anymore. oop! :)

I am new to Amanda (obviously I should think), so I've been reading the forum trying to determine how to do this and I found a thread suggesting that I do amrmtape and then amtape reset.

I'd tried as per the suggestion and of course failed or I wouldn't be here.

Here's what happened:

amrmtape daily1 daily1-1
Segmentation fault

At this point I did the (new user panic thing) and tried to do the amtape reset and that actually completed fine. Now I have the following:

$ amtape daily1 show
amtape: scanning all 25 slots in changer:
slot 25: date X label daily1-25
slot 1: date 20101219153022 label daily1-1
slot 2: date 20101219182800 label daily1-2
slot 3: date 20101219185816 label daily1-3
slot 4: date 20101221104447 label daily1-4
slot 5: date X label daily1-5
slot 6: date X label daily1-6
slot 7: date X label daily1-7
slot 8: date X label daily1-8
slot 9: date X label daily1-9
slot 10: date X label daily1-10
slot 11: date X label daily1-11
slot 12: date X label daily1-12
slot 13: date X label daily1-13
slot 14: date X label daily1-14
slot 15: date X label daily1-15
slot 16: date X label daily1-16
slot 17: date X label daily1-17
slot 18: date X label daily1-18
slot 19: date X label daily1-19
slot 20: date X label daily1-20
slot 21: date X label daily1-21
slot 22: date X label daily1-22
slot 23: date X label daily1-23
slot 24: date X label daily1-24

Well, I've still got vtapes I'd like to get rid of and then run another amtape reset. So here it goes again:

$ amrmtape --changer changer daily1 daily1-4
Segmentation fault

$ amcheckdb daily1

I found this command in a past log and tried it. I don't know what it does, but I thought it might be something you'd ask about.

$ sh -x amrmtape daily1 daily1-4
sh: Can't open amrmtape

I'm not sure what to do at this point. I know I could simply run amconfigserver and start fresh that way, but I thought this might be worth reporting. And well, running amconfigserver seems too blunt a tool for something that should be doable in a more elegant way.

I'm running amanda-server 3.1.0. I will be delighted to collect any addtional information you may require.

December 22nd, 2010, 12:58 PM
Can you upgrade to amanda server 3.1.3?


December 22nd, 2010, 03:19 PM
There is nothing to stop me from trying, except my certain lack of knowledge. But I would like to know: is there any indication that upgrading will fix my problem? I mean, is the problem I have on a known buglist for 3.1.0?

That said, I'll try to do whatever you recommend, if you would kindly point me in the right direction. I am a very humble (wannabe) on this board. If I were to place myself within the grand scheme of things in the linux world, I would say that I am barely past the level of noob. I may well be a noob still.

I've been fortunate to have installed a working dhcp server that can dynamically update my DNS server. I can authenticate with LDAP as well. But, sadly, I am at the mercy of apt-get (and mostly) aptitude, and the hard working people that put those salivatingly delicious binaries together. I've never done a make install, ever. . . Maybe it's time to do that.

So Paddy, tell me what to do, and I will do it.

I currently understand debian based systems the best and most of my experience is with Ubuntu, which my true friends tell me, is not a real man's operating system. Is there a way to point to 3.1.3 binaries and upgrade from Ubuntu 10.10? Or must I download source and do the make install?

If make install is my only option, can you point me at some good reading material and I will try it in order to resolve this log?

Thank you in advance.

December 22nd, 2010, 10:08 PM
Hey Paddy,

I'm reading on the Wiki about the install. Thanks for pointing me towards that idea. I am sure I'll have some (probably many) questions.

First off, I clicked the community version page and it says 3.2.1 is the latest stable realease. Should I try that instead of 3.1.3?

Second, I see you have binary downloads, doh! I know why I thought they weren't available. I was confusing zmanda with openldap! That is exactly what happened. Sorry about that. :)

Third, and this will be based on your answer to question #1: Can I simply exec dpkg on top of the existing installation?

Four, If that is true then (please don't laugh), is there a pointer (URL or what ever it is called) that I can add to my sources.list for apt? I've never run dpkg (I told you I was a noob).

Thanks. :)

December 23rd, 2010, 11:22 AM
It is up to you. 3.2.1 has additional features that you can advantage of. See wiki.zmanda.com for information on features.

You will have to uninstall dpkg and install new dpkg. We don't have apt repository so
that you can do "apt-get install".

Happy holidays

December 23rd, 2010, 01:29 PM
ok Boss,

I'll learn to do dpkg.

I read about the new features such as automagic vtape spanning in 3.2.1 and I liked the sound of it.

For the record:

I decided to delete /var/lib/amanda/vtapes and /etc/amanda/daily1. Then I ran amserverconfig to put Amanda back to square one.

However, I could not get Amanda to span my vtapes with runtapes 15, tape size 5120mb, and split_tape 5100mb.

She backed up sda1 but not /dev/mapper/bkpc-root because root was considered to big.

Then I went to remove the vtape with amrmtape and got the same Segmentation fault. So . . .

I am going back and try it with 2.6.1 and I'll install 3.2.1 on a different vm as well. I want to learn your products. I'm not sure why I found backup technology so interesting, but I have. :)

Thanks again and let's close this log out.

March 13th, 2011, 04:00 PM
I'm having the same problem, using amanda 3.1.0 from the Ubuntu repositories, and upgrading to 3.2.x is not an option right now. I ran the amrmtape script in the perl debugger. The segmentation fault is occurring on line 172 of the perl script /usr/sbin/amrmtape, which looks like this:

$cfgerr_level = Amanda::Disklist::read_disklist('filename' => $diskfile);

$diskfile is set to /etc/amanda/UbDailySet1/disklist and the file is owned by user 'backup' and has read and write permissions.

Help would be greatly appreciated.