View Full Version : dgram bind!?!?!?

December 20th, 2010, 02:08 PM
Hello again,

I just posted and resolved this log:


But now I am getting:

AMRECOVER Version 2.6.1p1. Contacting server on ambk.corp.loc ...
[request failed: timeout waiting for ACK]

I have this log from the client when trying to do AMRECOVER.

Here is the log from the client. Any ideas:

root@bkpc:/var/log/amanda/client/daily1# cat amrecover.20101220164613.debug
1292885173.130467: amrecover: pid 1178 ruid 0 euid 0 version 2.6.1p1: start at M
on Dec 20 16:46:13 2010
1292885173.131151: amrecover: pid 1178 ruid 0 euid 0 version 2.6.1p1: rename at
Mon Dec 20 16:46:13 2010
1292885173.131234: amrecover: security_getdriver(name=bsd) returns 0xb77a1c40
1292885173.131265: amrecover: security_handleinit(handle=0x9f04388, driver=0xb77
a1c40 (BSD))
1292885173.137245: amrecover: dgram_bind: setting up a socket with family 2
1292885173.138124: amrecover: bind_portrange2: Try port 855: Available - Succes
1292885173.138170: amrecover: dgram_bind: socket 3 bound to
1292885173.138481: amrecover: dgram_send_addr(addr=0x9f043a8, dgram=0xb77a9a24)
1292885173.138495: amrecover: (sockaddr_in *)0x9f043a8 = { 2, 10080,
26 }
1292885173.138506: amrecover: dgram_send_addr: 0xb77a9a24->socket = 3
1292885183.148973: amrecover: dgram_send_addr(addr=0x9f043a8, dgram=0xb77a9a24)
1292885183.149025: amrecover: (sockaddr_in *)0x9f043a8 = { 2, 10080,
26 }
1292885183.149038: amrecover: dgram_send_addr: 0xb77a9a24->socket = 3
1292885193.159397: amrecover: dgram_send_addr(addr=0x9f043a8, dgram=0xb77a9a24)
1292885193.159450: amrecover: (sockaddr_in *)0x9f043a8 = { 2, 10080,
26 }
1292885193.159463: amrecover: dgram_send_addr: 0xb77a9a24->socket = 3
1292885203.169730: amrecover: security_seterror(handle=0x9f04388, driver=0xb77a1
c40 (BSD) error=timeout waiting for ACK)
1292885203.169809: amrecover: security_close(handle=0x9f04388, driver=0xb77a1c40

I am fresh out of ideas. Please help.

Thanks in advance!

December 21st, 2010, 06:24 AM
I'm still trippin out on this log. Does dgram_bind mean it is trying to do socket_type dgram? I don't have that in my xinetd settings:

root@bkpc:/var/log/amanda/client/daily1# cat /etc/xinetd.d/amanda
# default: on
# description: The amanda service
service amanda
# only_from = <Amanda server>
# flags = IPv4
socket_type = stream
protocol = tcp
wait = no
user = backup
group = backup
groups = yes
server = /usr/lib/amanda/amandad
server_args = -auth=bsdtcp amdump amindexd amidxtaped
disable = no

I'll keep plugging.

Thanks in advance! :)

December 21st, 2010, 06:32 AM
You run amrecover with the 'bsd' auth, but xinetd is configured for 'bsdtcp' auth

run amrecover with '-oauth=bsdtcp' or add 'auth "bsdtcp"' in amanda-client.conf

December 21st, 2010, 06:47 AM
Thanks a heap martineau! That did the trick.

I was going to ask about the amanda-client.conf file. I found that file in /usr/share/doc/amanda-common/examples/ only. My binary installer did not set it up.

What should I do to set up amanda-client.conf? I assume it should go in /etc on the client, right? The client does not have a /etc/amanda like the server does.

Sorry to be such a bother.
Thanks in advance again!

December 21st, 2010, 07:04 AM
Well, I actually took a look at the amanda-client.conf file and you know what? It told me exactly where to put it.

Sorry for the silly question.