PDA

View Full Version : SMTP error - notifications not being sent



msauerman
December 7th, 2010, 11:21 AM
I am unable to get ZCB to send notification emails when a backup completes. I am running the latest version of ZCB on a Windows 2003 server that also hosts my Exchange server. I have tried configuring the SMTP server settings in ZCB with all of the following and none work: smtp.mydomain.com, mail.mydomain.com, and the IP address of the mail server. All were set to use port 25 and the administrator@mydomain.com account for sending. Can anyone assist with this? Thanks.

paddy
December 7th, 2010, 11:33 AM
The answer depends on the Mail server being used and what verification it performs
before accepting an email.

Can you open a support case at Zmanda Network? Login to http://network.zmanda.com
and click on Support tab

There is also a Knowledgebase article on this topic at Zmanda Network.

thanks

mediationworks
January 24th, 2011, 08:41 PM
Paddy,

Can you point us to the Knowledgebase article on this topic at Zmanda Network? I can not find a Knowledgebase, nor any articles on SMTP. I only see a wiki about amanda (although I'm unclear how I would call amanda commands).

Thanks,
Fred

paddy
January 25th, 2011, 04:28 PM
Login to Zmanda Network and Click on Support tab. Select Knowledgebase and "How to for ZCB" from left panel. You can find an article "Troubleshooting Email issues".

If you want, you can open a support case in the Support tab.

mediationworks
February 1st, 2011, 08:14 AM
Did you ever resolve this issue?

I am mightily confused myself. I'm using Windows Small Business Server 2003 R2, Exchange Server 2005, Zmanda Cloud Backup 3.0.2

In the java script in dist.zip, I receive an error javax.mail.AuthenticationFailedException: failed to connect. The log.txt reports 535 5.7.3 Authentication unsuccessful.

Like the user who originated this thread, for hostname I have tried every combination of server.mydomain.local, server, 127.0.0.1, 192.168.my ip. For username I have tried every combination of my-email@mydomain.com and my-logon@mydomain-name.local.

To reinvigorate my confidence, I just telnet'ed to the server port 25 and sent an email to a gmail address. But if I use the same parameters in the java script that I use for "helo" and "mail from" in telnet I receive an error. One difference is that the java asks for a password, though none is needed to telnet while I am logged in to the server console.

mediationworks
February 6th, 2011, 11:44 AM
Dear Diary,

Configuring ZCB to send an email notification is surprisingly tricky. I haven't figured it out yet.

So here's the story so far. I'm using Small Business Server 2003 R2, Exchange Server 2005, and Zamanda Cloud Backup 3.0.2 To configure the SMTP settings, I've been using the java script from dist.zip that ZCB mentions in the Knowledgebase. There are five parameters in the script: (1) address to send mail. I can send the mail to an address either inside or outside the network. no problem here. (2) host address. I can use either the name of the server <servername>, or the name of the server plus the domain name <servername.domainname.local>. Either works well. (3) port. Exchange Server was set up with Basic Authentication (not TLS), so the correct answer is 25. (4) User name. This is baffling. I cannot use the admin account, although admin does get mail from other users. For example, I can send mail from java script to admin. I can use another account if I compose the email address in the form <username@domainname.local>. However, I receive an error "failed to connect" if I compose the email address in the form <username@domainname.com>. (5) Password. Self-explanatory.

So, great, I can get the diagnostic program to work if I use the from address as <username@domainname.local>. However, if I try to use that address in ZCB itself, in the dialog box Outgoing Mail SMTP notification, I receive an error "<username@domainname.local" is not a valid address. If instead I use the address <username@domainname.com>, I do not receive an error message. However, I don't receive email at the <to address>.

Diary, I hope that either Paddy or Prashant will notice this entry and respond.

Me.

prashant
February 7th, 2011, 05:23 AM
Hi,
Thanks for digging in and identifying the actual problem. I was able to reproduce the issue in-house as well. This looks like a bug. Will get back to you soon with the fix.

Regards,
Prashant

bberenberg
February 7th, 2011, 12:54 PM
Hi Fred,

You have case #6115 open for the same issue. In the future please reply to cases as it helps keep everything tracking. I was able to reproduce the issue and identified a workaround which will resolve this problem till the next ZCB release which will fix this problem. Please go into the email configuration dialog and set everything up as you plan to use it and use a .com tld. After saving your email configuration please go to the appropriate directory (adjust for x86 vs x64 as needed):


Win 7 / Vista / 2008 will have it in the ProgramData directory:

C:\ProgramData\Zmanda\Zmanda Cloud Backup(x64)\zcb\conf

Other versions of windows will have it in:

C:\Program Files\Zmanda\Zmanda Cloud Backup(x64)\zcb\conf

open up the zcb.conf file and switch the tld to be .local on the email-host-user-name field. I will update the case with the same information as well.
Please respond to the case regarding the results of how this worked for you.

wad4ipod
February 12th, 2011, 03:52 AM
Thought it might be an MS security patch blocking the java process or something.
Followed all the steps recommended in the support case I opened for one of my clients. Still not sending. Can send/relay successfully using simple smtp/telnet from the PC; different application.

Looking forward to the next update :)

paddy
February 12th, 2011, 08:18 PM
It depends how your SMTP server is configured for accepting the emails (what fields are
authenticated). Please open a support case. We can provide a tool that helps in figuring out what parameters need to be set.

wad4ipod
February 16th, 2011, 10:51 AM
For one client the ticket has and is opened:
6078

I have followed the support recommendations and still no emails.

I have another client on SBS 2003 that has the same issue. There is no ticket for them yet. Seemed like other people are have issues so time/efforts don't seem end-game.