PDA

View Full Version : Failed to create backup directory



software@flip.me
November 25th, 2010, 03:16 AM
Hi,

I installed zmanda cloud backup in my servers and started the backup. It starts the backup to a mapped network drive. But once scheduled the backup, it shows an error "failed to create backup directory and always fails. Happens in all 3 servers installed.

Please help me to fix this issue at the earliest.

prashant
November 25th, 2010, 08:24 PM
Hi,
ZCB schedules are run under the SYSTEM user context. This user does not have network privileges.
To resolve the issue, change the user for schedules to "amandabackup".

1. Open Windows Task Scheduler or Scheduled Tasks.
2. Identify the schedules created by ZCB.
3. Go to the Properties of the schedules that fail.
4. Change the user from SYSTEM to "amandabackup".

Please let us know if this resolves the issue.

Regards,
Prashant Joshi

software@flip.me
November 28th, 2010, 01:49 AM
Hi Prashant,

This seems to be working. I changed the user in Scheduled Tasks to amandabackup. I started the backup manually and it seems to be completed successfully. I will keep this open and see if it works properly on scheduled time.

Not sure if I can ask in the same thread, but I am not able to receive any email notifications from zmanda after completing the backup. I have given the same account details which I use in other services to send email notification. Is there any way to check what is happening?

prashant
November 28th, 2010, 09:01 PM
Hi,
I would request you to open a support case for the email notification issue and upload the logs.

Regards,
Prashant

software@flip.me
December 1st, 2010, 06:11 AM
Hi prashant,

All the scheduled backup failed! I changed the user to amandabackup in the scheduled tasks. It runs perfectly and takes the backup upload to amazon, if I do it manually.

Please let me know if I need to make further changes to fix this issue.

PS: Email issue is fixed and am getting emails now, unfortunately for failed backup!
Log:
Backup start time : 2010/12/01 19:00:03
Backup end time : 2010/12/01 19:00:03
Total Bytes backed up : 0.00 KB
Files on disk : 0
Files in backup : 0
Error Details : Failed to create backup directory.

prashant
December 1st, 2010, 08:40 PM
Hi,
That is strange. Is the ZCB machine and the network share a part of any domain? What credentials is the "ZWCService" started with? If its a domain account, please run the schedules as the domain amandabackup user and give privileges to this user on the network share.

In case, the schedules still have the same issue, I would request you to open a support case so that we can debug the issue.

Regards,
Prashant

software@flip.me
December 3rd, 2010, 01:23 PM
Hi prashant,
Its a domain environment and the schedule user is domain\amandabackup
Also i have given full access to the betwork drive and mapped
To each server which i want to take the backup.

I woukd really appreciate if you let me know on how to open
A support case for this issue as none of my backup is happening
automaticall which is bit scary.

paddy
December 3rd, 2010, 01:25 PM
Hi,

Please open a support case by logging in at http://network.zmanda.com and clicking
support tab.

Also attach the logs collected by clicking Tools->Collect Logs to the case.

thanks
Paddy

software@flip.me
December 5th, 2010, 12:01 AM
Thank a lot paddy,

Case opened and attache log file too.

software@flip.me
December 9th, 2010, 04:18 AM
Problem solved!

Got help from Zmanda support. Issue turned out to be the path mentioned in the destination drive. In the destination local drive, I gave the mapped drive as the location. (X:\backuppath). This works when I run it manually from ZCB, but fails during scheduled tasks.

This now changed with UNC path (\\servername\sharename) and all started working again perfectly! :)

Thank you all for the support and help once again, and really appreciate Zmanda support team for the quick response.

SouthWest
July 11th, 2012, 12:43 PM
I want to be able to backup to a Mapped Windows File Share but so far every configuration fails. Windows 2008 R2 server.

Have confirmed that the Mapped drive works and is writable, for user amandabackup, and that user is assigned to the schedule.

Read the KB articles and nothing seems to help, are there any other known issues around copying to a share drive?

Eric_R
July 11th, 2012, 12:53 PM
I want to be able to backup to a Mapped Windows File Share but so far every configuration fails. Windows 2008 R2 server.

Have confirmed that the Mapped drive works and is writable, for user amandabackup, and that user is assigned to the schedule.

Read the KB articles and nothing seems to help, are there any other known issues around copying to a share drive?

Hi SouthWest,

Are you by any chance running on a Windows domain?

If so, please verify the following that the ZWCService is started as the domain\amandabackup user

Go to Control Panel - Administrative Tools - Services, and check on the ZWCService

If that fails, please open a support case from http://network.zmanda.com

SouthWest
July 13th, 2012, 05:07 AM
Just checked and Yes the service is started. Backups to local disk are working. The server is set to workgroup,

Eric_R
July 13th, 2012, 06:59 AM
Hi Southwest,

Please collect logs as directed on this KB article:
http://kb.zmanda.com/article.php?id=456

Then open a support case (http://network.zmanda.com/createCase.php) and tell us what you've done from the above thread (in detail, please)

Also tell us the name of the log file you uploaded.

If you have followed all of the steps in this thread (and those in the User Guide and FAQs), then something deeper is at fault. We'll need the above information to diagnose your issue.

Thanks,
Eric
Zmanda Support