View Full Version : taper chrashes

November 8th, 2010, 01:29 PM

After upgrading to Amanda 3.1.0 (Ubuntu 10.10) the Amanda backup fails with the following error message:

Mon Nov 8 22:41:34 2010: taper: critical (fatal): Not all data in part was represented to cache_inform

In the mail reveived from Amanda it states:
driver: Taper protocol error
driver: going into degraded mode because of taper component error.

Does anybody have an idea what could be wrong ? It worked all fine with Ubuntu 10.04 and Amanda 2.6.1p1

Configuration for the changer is

tpchanger "chg-manual"
tapedev "tape:/dev/nst0"
changerfile "/etc/amanda/full/change-status"

Best regards

November 8th, 2010, 01:40 PM
Can you upgrade to 3.1.3?


November 9th, 2010, 01:17 AM
I'll give it a try - but without knowing what the problem really is and whether this is eventually solved by the newer version or not, I don't think there is a big chance ...
Hopefully the packages for Ubuntu 10.04 will work on 10.10.


November 11th, 2010, 11:28 AM
Upgrade of the amanda backup server from 3.10 to 3.1.3 solved the problem.
The clients are still 3.1.0, but it works :-)

Thank' s a lot.


November 11th, 2010, 04:20 PM

We are glad your configuration is working.

Please do share as much details of your configuration as possible on the forum. E.g. performance of your backups, backup media used, etc. This is very useful for other users who are planning Amanda installs.


November 12th, 2010, 04:27 AM
Some more details:

Amanda is used to backup my home office environment, i.e .a file/print server, a WWW-Server (virtualized, XEN ), a Mail Server (also virtualized, XEN) , a backup server and 2 clients, all Linux, no windows

Backup Server: Ubuntu 10.10 with one single DDS4 tape drive
Amanda 3.1.3 for Ubuntu 10.4 installed
File/print server: Ubuntu 10.10 with original Amanda package from ubuntu (3.1.0)

WWW/Mail Servers: Ubuntu 9.04 with original Amanda package from ubuntu (2.6.2p2)

Clients: Ubuntu 10.10 with original Amanda package from ubuntu (3.1.0)
Suse 10.2 with original Amanda package from Suse.

Size of backup: ~250GB
Performance : not an issue, I have just a single drive and use the manual changer
use a holdingdisk and DLE of 2 GB

If you want more details, feel free to asks