View Full Version : Amanda-3.1.2 32bit dumper died

September 29th, 2010, 01:29 PM
I have been running amanda for about a month. In that time last week I upgraded to 3.1.2 from 2.6.1p2. I did the upgrade since I upgraded to Ubuntu 10.02 and that upgrade seemed to break 2.6.1p2. Since then I haven't had a completely successful run. About 90% of the windows and linux machines complete ok but there are two that seem problematic.

The email that I receive is : "c:/work" lev 0 FAILED [dumper2 died]

From log.20100928 I get:

WARNING driver dumper2 pid 2806 is messed up, ignoring it.
FAIL driver "c:/work" 20100928182002 0 [dumper2 died]
WARNING driver dumper2 pid 2806 exited with signal 11

From /var/log/amanda/server/Daily/dumper.20100928182003001.debug I get:

Tue Sep 28 19:04:06 2010: dumper: stream_read_callback: data is still flowing
Tue Sep 28 19:04:08 2010: dumper: security_stream_seterr(0x8be7b30, EOF)

From /var/log/messages I get:

Sep 28 19:04:08 server kernel: [1637456.709116] dumper[2806]: segfault at a107000c ip b7170190 sp bf9380fc error 4 in libc-2.11.1.so[b7102000+153000]

Any thoughts or advice? Is reverting back to 2.6.1p2 an option or will the changes in ubuntu 10.02 affect that version of amanda as well?

Thanks in advance to whoever can help me out!!!

September 29th, 2010, 01:45 PM
This issue is probably fixed in 3.2.0.

Please try 3.2.0beta1 available on http://www.zmanda.com/download-amanda.php (version 3.2.0beta1).


September 30th, 2010, 06:24 PM
Did you try 3.2.0beta1? Did it fix your problem?

October 1st, 2010, 08:45 AM
Yes I tried it. I have server encryption turned on and that seems to have lead to a full scale failure. So, I tried one dle without the encryption and that worked fine. I'll post the failure in the 3.2 section once I get all the log files reviewed.