PDA

View Full Version : Amanda can't find new tapes



wsanders
September 13th, 2010, 02:07 PM
I have a question that has not been answered clearly in any Google searches I can find. I have a backup that failed with:


*** A TAPE ERROR OCCURRED: [Could not find a tape to use].
There are 198G of dumps left in the holding disk.
They will be flushed on the next run.

The next 8 tapes Amanda expects to use are: 8 new tapes.
The next 8 new tapes already labelled are: pool-20, pool-44, pool-33, pool-34, pool-35, pool-36, pool-37, pool-38.

FAILURE DUMP SUMMARY:
localhost /pool2/backups/mail lev 1 FAILED [Not enough holding disk space]
localhost /pool2/backups/mail lev 1 FAILED [out of holding space in degraded mode]

STATISTICS:
Total Full Incr.
-------- -------- --------
Estimate Time (hrs:min) 0:39
Run Time (hrs:min) 15:52
Dump Time (hrs:min) 4:12 0:00 4:12
Output Size (meg) 202997.5 0.0 202997.5
Original Size (meg) 202997.5 0.0 202997.5
Avg Compressed Size (%) -- -- -- (level:#disks ...)
Filesystems Dumped 6 0 6 (1:6)
Avg Dump Rate (k/s) 13722.1 -- 13722.1

Tape Time (hrs:min) 0:00 0:00 0:00
Tape Size (meg) 0.0 0.0 0.0
Tape Used (%) 0.0 0.0 0.0
Filesystems Taped 0 0 0

Chunks Taped 0 0 0
Avg Tp Write Rate (k/s) -- -- --

6 out of 7 of my DLEs got dumped to holding disk, I am assuming there was not room for the 7th.

Is there a way to get Amanda to write the successful runs to tape rather than just giving up when the holding disk fills up? I have "autoflush" set to "yes". Unfortunately, I have only 440G available on the holding disk, and I have LTO4 drives - what do I have to do to workaround the fact that my holding disk is smaller than my media size?

Thanks,
-W Sanders
St Marys College of California
http://wsanders.net