PDA

View Full Version : taper fatal error after unexpected label



mrobbert
July 23rd, 2010, 09:15 AM
I just upgraded to Amanda 3.1.1 using the provided RPM. The system is CentOS 5.4 x86_64 and is connected to a Dell ML6000 changer. I was using the chg-zd-mtx script previously and moved to the new chg-robot driver for the new install. I did a full update to get an inventory, but I still seem to be hitting unexpected labels quite frequently and it seems that whenever I do I get the following error:

/var/log/amanda/server/home-m-through-p/amcheck-device.20100722103127.debug-Thu Jul 22 10:32:55 2010: amcheck-device: ml6000: Expected label 'home-m-through-p-023', but got 'home-m-through-p-024'
/var/log/amanda/server/home-m-through-p/amcheck-device.20100722103127.debug:Thu Jul 22 10:32:55 2010: amcheck-device: critical (fatal): Can't locate auto/Amanda/Device/Device/swig_header.al in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8 /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /usr/lib/perl5/site_perl/5.8.8/Amanda/Device.pm line 34

I have two questions:
1. How can we fix the fatal error? I'm more than willing to help debug if this doesn't appear to be reproducible. I'm a capable Linux system administrator that knows a little perl, but not a developer.
2. Any thoughts on why my changer inventory appears to be off so much? I have resorted to running updates on small chunks of my library to find tapes, but I've hit the problem even then. The library has 188 slots and a full update takes many hours.

Thanks,
Mike Robbert

dustin
July 24th, 2010, 01:58 PM
(note to other readers - this was answered on amanda-users - see http://marc.info/?t=127990876900006&r=1&w=2)