PDA

View Full Version : amrecover error when extracting files



kenapp
July 8th, 2010, 11:08 AM
Hi,

I have installed Amanda backup server 3.1.1-1 for RHEL 5_x86 on a Centos 5.3 64 bit box, and the same version of Amanda backup client on another box with the same OS. Both use the ext3 file system.

I was following the "amanda 15 minute backup solution" found at http://amanda.zmanda.com/quick-backup-setup.html

The backups I have performed have apparently been successful (email notification seems OK, as well as the logfile), however, when I go to restore files on the client using amrecover, I run into an issue.

After invoking amrecover, I can issue the listdisk command and receive a list of the directories I backed up. I can issue the ls command to see a list of the files and directories in that backup set. I can use the add command to add files to be restored. I can use the lcd command to direct amrestore to restore files to the location I want.

My problem starts after issuing the extract command. This is the output I receive (I replaced the real IP address with xxx.xxx.xxx.xxx for this post):


amrecover> extract

Extracting files using tape drive changer on host xxx.xxx.xx.xxx.
The following tapes are needed: DailySet1-02

Extracting files using tape drive changer on host xxx.xxx.xx.xxx.
Load tape DailySet1-02 now
Continue [?/Y/n/s/d]? y
Restoring files into directory /restore
All existing files in /restore can be deleted
Continue [?/Y/n]? y

/usr/bin/gzip exited with status 1
/usr/sbin/amcryptsimple exited with status 2
tar: ./UPGRADE.txt: Not found in archive
tar: Error exit delayed from previous errors
Extractor child exited with status 2
amrecover> exit
200 Good bye.
[root@intranet amanda]#


I have no idea how to read the debug files. I have double and triple checked my setup as it is outlined in the Amanda 15-minute backup solution.

Would anyone be able to point me in the right direction to fix this? Let me know if I need to supply more information for trouble shooting.

Thanks,
ken

zbackup
July 8th, 2010, 11:19 AM
Ken,

Just making sure: Are you following the updated 15 minutes paper, downloadable from Zmanda Network (http://network.zmanda.com/) (free registration)?

thanks

kenapp
July 8th, 2010, 11:22 AM
Ken,

Just making sure: Are you following the updated 15 minutes paper, downloadable from Zmanda Network (http://network.zmanda.com/) (free registration)?

thanks

Nope, I don't think I am. I did realize some of the commands have been discontinued, and the config files and man pages had some different syntax that I followed. But I will check out the updated 15 paper and give it another shot. Thanks!

kenapp
July 12th, 2010, 10:47 AM
Thanks, after setting up Amanda as per the updated 15 minute paper, I was able to recover files I backed up.

zbackup
July 18th, 2010, 05:35 PM
Thanks, after setting up Amanda as per the updated 15 minute paper, I was able to recover files I backed up.

Good to hear. It will be great if you can share details of your configuration and any observations (e.g. backup times). These are very useful for other Amanda users. Also, if you have any feedback on the updated 15 minutes paper, please let us know.

Thanks!