View Full Version : taper: FATAL no device is available

June 15th, 2010, 11:26 AM
Amanda 3.1.0 (svn.3164)

using FreeBSD 6.4-RELEASE-p10

using Exabyte Mammoth EZ17 library.

using mtx version 1.3.11

using chg-robot


free.bsd1.net:/u 0 20178m failed: killed while writing to tape (14:56:14)


taper: FATAL no device is available to check the data_path at /usr/local/lib/perl5/site_perl/5.10.1/Amanda/Taper/Scribe.pm line 504.


free.bsd1.net /u lev 0 FAILED [too many taper retries]
free.bsd1.net /u lev 0 partial taper: error from mtx:


driver: Taper protocol error
driver: going into degraded mode because of taper component error.
taper: Error from set_label: error from mtx:
taper: Will request retry of failed split part.


taper: Amanda::Taper::Scribe: ignoring error while finishing device 'tape:/dev/nsa0': Error writing block: Mysterious short write on tape device: Tried 32768 got 0
taper: Amanda::Taper::Scribe: operation failed: error from mtx:
taper: Amanda::Taper::Scribe: cancelling the transfer: error from mtx:


Tried this previously on 3.1.0beta2 with same/similar results. (left a message on this forum on May 14th).

Falling back to 2.6.1p2 ... operation is successful.

June 15th, 2010, 11:48 AM
Can you post the complete taper.*.debug file

June 15th, 2010, 12:17 PM
The taper.*.debug file is 50+ meg raw and 800+ k zipped. How should I upload it? (the posted limit is 97.7 k )

June 15th, 2010, 12:57 PM
Post the latest thousand lines.

June 15th, 2010, 01:21 PM
taper-debug.zip attached

June 15th, 2010, 01:45 PM
I can't extract files.

$unzip taper-debug.zip
Archive: taper-debug.zip
warning [taper-debug.zip]: 76 extra bytes at beginning or within zipfile
(attempting to process anyway)
error [taper-debug.zip]: reported length of central directory is
-76 bytes too long (Atari STZip zipfile? J.H.Holm ZIPSPLIT 1.1
zipfile?). Compensating...
skipping: - need PK compat. v4.5 (can do v2.1)

note: didn't find end-of-central-dir signature at end of central dir.
(please check that you have transferred or created the zipfile in the
appropriate BINARY mode and that you have compiled UnZip properly)

June 15th, 2010, 02:05 PM
I extracted it with a newer unzip (6.00f BETA)

June 16th, 2010, 11:29 AM
Can you try the attached patch?

Are you using mtx to control the tape changer?

June 16th, 2010, 11:53 AM

yes and yes.

using mtx version 1.3.11

I will apply the patch and retry tonight.

June 16th, 2010, 03:56 PM

I applied your patch to 3.1.0 (svn.3170) and reran the backup.

The results look identical.

I am enclosing the first 10000 lines and the last 10000 lines of taper.*.debug.

This system is available most evenings for testing.

Let me know what you want to try next.


June 16th, 2010, 03:57 PM
and the last 10000 lines.

June 16th, 2010, 04:56 PM
Is the tape device in fixed-block or variable-block mode?


I'm following up on this on the freebsd-scsi list, by the way:

June 17th, 2010, 03:19 AM
We are trying to find how a write could return 0.

This simple patch make it less fatal, try it.

June 17th, 2010, 05:37 AM
I found that in the head debug file:
Wed Jun 16 17:54:23 2010: taper: invoking /usr/local/sbin/mtx -f /dev/changer nobarcode status
Wed Jun 16 17:54:23 2010: taper: warning: Can't exec "/usr/local/sbin/mtx": Invalid argument at /usr/local/lib/perl5/site_perl/5.10.1/Amanda/Changer/robot.pm line 1986.

Do /usr/local/sbin/mtx the correct path?

June 17th, 2010, 06:48 AM

I saw that.

Yes, the path is correct.

Also, amtape and amlabel are able to manipulate the changer just fine.

Also, as I indicated, everything works on 2.6.1p1.

June 17th, 2010, 06:59 AM

The output of mt status indicates that the Mammoth drive is configued (default) to variable block mode.

June 22nd, 2010, 04:25 AM
I haven't found why the taper can't exec mtx. I don't know what is 'Invalid argument'.

June 22nd, 2010, 09:26 AM

I rebuilt amanda (using svn.3194 which includes your patch).

I ran the next backup cycle (approximately 44Gb).

The tape error appears to reflect the patch as expected.

Enclosed are the first 5000 and the last 5000 lines of tape.*.debug.

I await further orders.