PDA

View Full Version : installing 3.1.0 client on openSUSE



Charles Curley
June 8th, 2010, 01:17 PM
I don't see a package for OpenSUSE 11, so I tried that for 10.

--------------------------------------------------
copper:~ # rpm -ivh amanda-backup_client-3.1.0-1.suse10.0.i586.rpm
error: Failed dependencies:
libcrypto.so.0.9.7 is needed by amanda-backup_client-3.1.0-1.suse10.0.i586
libcurl.so.3 is needed by amanda-backup_client-3.1.0-1.suse10.0.i586
libreadline.so.5 is needed by amanda-backup_client-3.1.0-1.suse10.0.i586
libssl.so.0.9.7 is needed by amanda-backup_client-3.1.0-1.suse10.0.i586
copper:~ # pre libcrypto libcurl libreadline libssl
libreadline6 6.0 18.4.1 i586
libcurl4 7.19.6 2.1 i586
copper:~ # lsb_release -a
LSB Version: n/a
Distributor ID: SUSE LINUX
Description: openSUSE 11.2 (i586)
Release: 11.2
Codename: n/a
copper:~ #
--------------------------------------------------

"pre" looks to see which packages are
present. http://www.charlescurley.com/blog/archives/2010/04/11/pre_a_package_scanning_script/index.html

Two of the failed dependency packages are present, but of more modern vintage than those called out.

I couldn't find the other two, but that could be my lack of expertise at YAST.

Is a package for 11 in the pipeline?

Thank you.