PDA

View Full Version : Problem installing RHEL5 3.1 binary



coolhandluke
June 3rd, 2010, 05:23 AM
# rpm -ivh amanda-backup_server-3.1.0-1.rhel5.i386.rpm
error: Failed dependencies:
amanda-backup_client conflicts with amanda-backup_server-3.1.0-1.rhel5.i386
#

coolhandluke
June 3rd, 2010, 05:25 AM
Client is not currently installed

# rpm -q amanda-backup_client
package amanda-backup_client is not installed
#

pyeatman
June 3rd, 2010, 03:07 PM
That's odd. The rpm command seems to be disagreeing with itself. It says the client package is installed in one execution and denies it in the other.

What, if any, "amanda" packages are installed?

# rpm -qa \*amanda*

coolhandluke
June 4th, 2010, 05:12 AM
# rpm -qa \*amanda*
amanda-backup_server-2.6.1p2-1.rhel5
#

I gave up and installed 2.6.1p2-1. This rpm package was not on my system at the time I had the error when attempting to install the 3.1 package.

PilotJLR
June 6th, 2010, 06:54 AM
I've noticed this problem as well. I have a test virtual machine with Amanda 2.6.1p2 installed. I downloaded the Amanda 3.1 rpm and have encountered the same problem.

This is on a CentOS 5.5 i386 machine.



[root@amanda tmp]# rpm -qa | grep -i amanda
amanda-backup_server-2.6.1p2-1.rhel5
[root@amanda tmp]# rpm -Uvh amanda-backup_server-3.1.0-1.rhel5.i386.rpm
error: Failed dependencies:
amanda-backup_client conflicts with amanda-backup_server-3.1.0-1.rhel5.i386


Even after removing the 2.6 amanda package, the errors persists.



[root@amanda tmp]# rpm -e amanda-backup_server
[root@amanda tmp]# rpm -Uvh amanda-backup_server-3.1.0-1.rhel5.i386.rpm
error: Failed dependencies:
amanda-backup_client conflicts with amanda-backup_server-3.1.0-1.rhel5.i386
[root@amanda tmp]# rpm -qa | grep amanda
[root@amanda tmp]



I'm thinking there is a bug in the RHEL 5 rpm's...

laduncan
June 7th, 2010, 01:26 PM
I'm seeing the same thing. RHEL 5.5 x64


[root@srv1 tmp]# rpm -qa |grep amanda
[root@srv1 tmp]# rpm -i amanda-backup_server-3.1.0-1.rhel5.x86_64.rpm
error: Failed dependencies:
amanda-backup_client conflicts with amanda-backup_server-3.1.0-1.rhel5.x86_64

coolhandluke
June 8th, 2010, 05:12 AM
I hope they fix the rpm soon :)

dwlocks
June 8th, 2010, 09:29 AM
From looking at the package, I think I've found the problem, but I need to replicate on a clean VM to confirm the fix.

I'll keep y'all informed.

Dan

Charles Curley
June 8th, 2010, 11:27 AM
I see the same thing on a freshly minted Centos 5.5 i386 VM, with
updates as of last night applied. I have no amada packages
installed.

Also, when using yum:

* yum complains as though the RPM had broken yum.

* yum also complains that the package isn't signed.

--------------------------------------------------
[root@quartz ~]# yum --nogpgcheck install amanda-backup_server-3.1.0-1.rhel5.i386.rpm
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: mirror.cisp.com
* base: mirror.rackspace.com
* extras: mirrors.rit.edu
* updates: centos-distro.cavecreek.net
Setting up Install Process
Examining amanda-backup_server-3.1.0-1.rhel5.i386.rpm: amanda-backup_server-3.1.0-1.rhel5.i386
Marking amanda-backup_server-3.1.0-1.rhel5.i386.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package amanda-backup_server.i386 0:3.1.0-1.rhel5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ==============================
Package
Arch Version Repository Size
================================================== ==============================
Installing:
amanda-backup_server
i386 3.1.0-1.rhel5 /amanda-backup_server-3.1.0-1.rhel5.i386 7.8 M

Transaction Summary
================================================== ==============================
Install 1 Package(s)
Upgrade 0 Package(s)

Total size: 7.8 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
amanda-backup_client conflicts with amanda-backup_server-3.1.0-1.rhel5.i386
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Lin ux%205&component=yum'])
[root@quartz ~]#
--------------------------------------------------

Thank you.

laduncan
June 8th, 2010, 02:32 PM
It looks like someone's filed a bug (a while back) with the fine folks doing YUM, as well: http://yum.osuosl.org/ticket/495

dwlocks
June 9th, 2010, 03:28 PM
I've committed a fix to the .spec and am working on building new packages.

dwlocks
June 10th, 2010, 01:50 PM
I see the same thing on a freshly minted Centos 5.5 i386 VM, with
updates as of last night applied. I have no amada packages
installed.

Also, when using yum:

* yum complains as though the RPM had broken yum.

* yum also complains that the package isn't signed.



Well, the RPM sort of does break things, but not in any permanent way. Generating a conflict with not-installed packages on install is pretty broken, eh?

And we don't currently sign our packages, so that error is going to come up even with the fixed package.

Dan

dwlocks
June 10th, 2010, 01:56 PM
Here's a diff of the changes. They're very simple.

http://amanda.svn.sourceforge.net/viewvc/amanda/amanda/branches/3_1_0_rpm/packaging/rpm/amanda.spec?view=diff&r1=3141&r2=3139&diff_format=h

I haven't figured out exactly how I'm going to tag this for release, but we'll have packages either later today or tomorrow morning.

Dan

dwlocks
June 11th, 2010, 01:11 PM
Updated rpms are available for download at http://www.zmanda.com/download-amanda.php

Dan

PilotJLR
June 11th, 2010, 04:55 PM
The new rpm's work for me. Thanks for fixing this so quickly!

zbackup
June 13th, 2010, 08:32 PM
The new rpm's work for me. Thanks for fixing this so quickly!

We are glad that the new RPMs worked. Please do share your overall Amanda experience (installation, configuration, hardware, performance). This is very useful for other Amanda users.

Thanks

laduncan
June 14th, 2010, 08:57 AM
Works well for us, too; thanks for fixing it!

synergy02046
June 14th, 2010, 09:47 PM
Hi all,

I met a problem when I did amcheck.

-sh-3.2$ amcheck DailySet1

Amanda Tape Server Host Check
-----------------------------
Holding disk /dumps/amanda: 1175552 KB disk space available, using 1073152 KB
slot 1:read label `DailySet1-01', date `X'.
NOTE: skipping tape-writable test
Tape DailySet1-01 label ok
NOTE: conf info dir /etc/amanda/DailySet1/curinfo does not exist
NOTE: it will be created on the next run.
NOTE: index dir /etc/amanda/DailySet1/index does not exist
NOTE: it will be created on the next run.
Server check took 3.633 seconds

Amanda Backup Client Hosts Check
--------------------------------
WARNING: synergy.amanda.com: selfcheck request failed: tcpm_recv_token: invalid size: amandad: error while loading shared libraries: libcrypto.so.7: cannot open shared object file: No su
Client check: 1 host checked in 0.191 seconds. 1 problem found.

(brought to you by Amanda 2.6.1p2)

I have tried to install libcrypto.so.7 package, but it always Failed Dependencies. And files conflict:

[root@synergy Desktop]# rpm -ivh openssl-0.9.8g-9.14.0.140asp.i386.rpm
warning: openssl-0.9.8g-9.14.0.140asp.i386.rpm: Header V3 DSA signature: NOKEY, key ID 9b3c94f4
error: Failed dependencies:
libc.so.6(GLIBC_2.7) is needed by openssl-0.9.8g-9.14.0.140asp.i386

[root@synergy Desktop]# rpm -ivh glibc-2.7-2.x86_64.rpm
warning: glibc-2.7-2.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
glibc-common = 2.7-2 is needed by glibc-2.7-2.x86_64
glibc > 2.5 conflicts with glibc-common-2.5-49.i386

Need help!!!


Thanks
Larry

Charles Curley
June 15th, 2010, 03:22 PM
WARNING: synergy.amanda.com: selfcheck request failed: tcpm_recv_token: invalid size: amandad: error while loading shared libraries: libcrypto.so.7: cannot open shared object file: No su
Client check: 1 host checked in 0.191 seconds. 1 problem found.


Hmm, which operating system are you using?

That's a rather old version of libcrypto; my machines here are 0.9.8 or so. Do you have a more recent version of libcrypto installed? In that case one possible hack is to symlink to it. Use locate to find out what you have and where it is, then cd there. E.g.:


# locate libcrypto.so
# cd /lib32/i486/
# ln -s libcrypto.so.0.9.8 libcrypto.so.0.7

This hack could break amanda, of course.

coolhandluke
June 16th, 2010, 11:39 AM
Thanks the new rpm installs just fine.

jah
December 30th, 2010, 04:13 AM
[root@sleepy jah]# rpm -qa \*amanda*
amanda-backup_server-3.2.1-1.fc11.i586
[root@sleepy jah]# yum localinstall /usr/local/amanda-backup_client-3.2.1-1.fc11.i586.rpm --nogpg
Loaded plugins: refresh-packagekit
Setting up Local Package Process
Examining /usr/local/amanda-backup_client-3.2.1-1.fc11.i586.rpm: amanda-
backup_client-3.2.1-1.fc11.i586
Marking /usr/local/amanda-backup_client-3.2.1-1.fc11.i586.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package amanda-backup_client.i586 0:3.2.1-1.fc11 set to be updated
--> Processing Conflict: amanda-backup_server-3.2.1-1.fc11.i586 conflicts
amanda-backup_client
--> Processing Conflict: amanda-backup_client-3.2.1-1.fc11.i586 conflicts
amanda-backup_server
--> Finished Dependency Resolution
amanda-backup_client-3.2.1-1.fc11.i586 from /amanda-backup_client-
.2.1-1.fc11.i586 has depsolving problems
--> amanda-backup_client conflicts with amanda-backup_server
amanda-backup_server-3.2.1-1.fc11.i586 from installed has depsolving
problems
--> amanda-backup_server conflicts with amanda-backup_client
Error: amanda-backup_server conflicts with amanda-backup_client
Error: amanda-backup_client conflicts with amanda-backup_server
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
[root@sleepy jah]#


I'm using:
http://www.zmanda.com/downloads/community/Amanda/3.2.1/Fedora_11/amanda-backup_client-3.2.1-1.fc11.i586.rpm
and
http://www.zmanda.com/downloads/community/Amanda/3.2.1/Fedora_11/amanda-backup_server-3.2.1-1.fc11.i586.rpm

This seems to be the same problem with the fc11 packages as was fixed in the redhat packages; agreed? I've never built any packages before, but I'd be willing to give it a try.

paddy
December 30th, 2010, 08:36 AM
There is no need to install amanda-backup_client if amanda-backup_server is installed.

Amanda server package includes Amanda client also

Paddy

jah
December 30th, 2010, 08:43 AM
Thanks Paddy.