PDA

View Full Version : ZWC 2.6.1 exclude syntax ignored



spyhunter
April 9th, 2010, 07:03 AM
I'm running ZWC Community version 2.6.1 on a Win 2003 Enterprise 32 bit server with Service Pack 2 installed.

The backup server is running Amanda 2.6.1p1. I'm trying to perform backups of the Windows machine, and I'm trying to exclude a couple directories, but it continues to try to back them up.

I tried to reproduce the problem on the machine by setting a test folder and test file up. The same thing happens..even though I try excluding the test folder, it backs up the test folder and the file inside of it.

Here is my syntax:

amanda.conf:

define dumptype winexclude-dump {
program "DUMP"
compress client none
index no
tape_splitsize 10000000
estimate server
exclude "d:/IA/test"
record yes
auth "bsdtcp"

}


and my disklist entry:

testserver.foo.net "d:/IA" winexclude-dump


amcheck reports no errors. When I run this, it backups up the contents of the IA folder, as well as the test folder, and the contents of the test folder, so it's going ignored.

prashant
April 12th, 2010, 01:13 AM
Hi,
This looks like a bug in the Windows client that the exclude list does not work if "/" (forward slash) is used in the directory path. Can you please try using "\\" instead of "/" in the exclude parameter.

eg: exclude "E:\\IA\\test"

I have verified that "\\" works fine.

Please let us know the outcome.

Regards,
Prashant

spyhunter
April 12th, 2010, 02:23 PM
Yes, I have verified that this works. Thanks very much for your help!

paddy
April 26th, 2010, 06:22 PM
Thanks. I have updated the documentation on the wiki.
http://wiki.zmanda.com/index.php/Zmanda_Windows_Client#Adding_dumptype_definitions_ on_the_Amanda_server_for_Windows_clients