View Full Version : amlabel error on 3.1.0beta1

March 31st, 2010, 03:43 AM
I testing amanda-3.1.0rc08-20100317 with chg:robot on ubuntu server 8.04 LTS and everything is working fine. I tried to upgrade to beta1

I'm able to compile and install from source. Config options are the same like on rc08

./configure --prefix=/usr --bindir=/usr/sbin --libexecdir=/usr/lib/amanda --without-amlibexecdir --without-amperldir --sysconfdir=/etc --sharedstatedir=/var/lib --localstatedir=/var/lib --with-user=amandabackup --with-group=disk --with-tcpportrange=50000,50100 --with-udpportrange=840,860 --with-debugging=/var/log/amanda --with-gnutar-listdir=/var/lib/amanda/gnutar-lists --with-index-server=localhost --with-bsd-security --with-smbclient=/usr/bin/smbclient --with-amandahosts --with-ssh-security --with-bsdtcp-security --with-bsdudp-security --without-ipv6

when I run:
amlabel -f DailySet1 DL0000L4 slot 1

I get this error:

amlabel: Undefined subroutine &Amanda::Changer::cluck called at /usr/lib/amanda/perl/Amanda/Changer.pm line 970

whan can be the cause of this problem?

my amanda.conf:

org "Test DailySet1" # your organization name for reports
mailer "/usr/bin/mail"
mailto "test@test" # space separated list of operators at your site
send-amreport-on all
dumpuser "amandabackup"

tapetype "DIL" # what kind of tape it is

dumpcycle 7 days # the number of days in the normal dump cycle
runspercycle 5 days # the number of amdump runs in dumpcycle days
tapecycle 15 # the number of tapes in rotation
usetimestamps yes
runtapes 10 # number of tapes to be used in a single run of amdump
maxdumpsize 10000gb

labelstr "^DL[0-9][0-9][0-9][0-9][A-Z][0-9]*$" # label constraint regex: all tapes must match

diskfile "/etc/amanda/DailySet1/disklist"
infofile "/etc/amanda/DailySet1/curinfo" # database DIRECTORY
logdir "/etc/amanda/DailySet1/logs" # log directory
indexdir "/etc/amanda/DailySet1/index" # index directory
tapelist "/etc/amanda/DailySet1/tapelist" # list of used tapes

dtimeout 43200 # number of idle seconds before a dump is aborted
ctimeout 60 # max number of secconds amcheck waits for each client
etimeout 43200 # number of seconds per filesystem for estimates
inparallel 10
dumporder "sssS"
taperalgo first
displayunit "g"
netusage 1 gbps
maxdumps 1
bumpsize 20m
bumppercent 20
bumpdays 1 day
amrecover_changer "changer"
device_output_buffer_size 1280k
reserve 20
autoflush on
amrecover_do_fsf on
amrecover_check_label on
#flush-threshold-dumped 50

holdingdisk dataPool {
comment "Main holding area"
directory "/dataPool/amandapool"
use 1000Gb
chunksize 2047Mb

define dumptype NEO {
comment "*splitsize* can only be defined in the scope of a dumptype definition, not a device"
auth "bsdtcp"
tape_splitsize 75000m
fallback_splitsize 2000m
index yes
holdingdisk auto
program "GNUTAR"
compress none
record yes
exclude list "/etc/amanda/amanda.excludes"

define dumptype BIG {
estimate calcsize

define dumptype NORMAL {
estimate client

define tapetype DIL {
comment "Created by amtapetype; compression enabled"
length 757110016 kbytes
filemark 0 kbytes
speed 120000 kps
blocksize 2048 kbytes

define changer "robot" {
tpchanger "chg-robot:/dev/sg24"
changerfile "/etc/amanda/DailySet1/chg-zd-mtx-state"
property "tape-device" "0=tape:/dev/nst1"
property append "tape-device" "1=tape:/dev/nst2"
property "eject-before-unload" "no"
property "use-slots" "1-30"
property "load-poll" "0s poll 3 s until 120 s"
property "mtx" "/usr/sbin/mtx"
property "fast-search" "true"
property "drive-choice" "lru"

tpchanger "robot"

Are you going to build packages for debian and ubuntu?

April 26th, 2010, 04:03 PM
The error "Undefined subroutine &Amanda::Changer::cluck called at" is fixed in the source repository.

zmanda build package for Ubuntu and debian.